Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Mladen Macanović
    @stsrki
    Denis Voituron
    @dvoituron
    Thanks... Very cool
    smithgor
    @smithgor
    Hi, looks great - trying (and so far failing) to get it running in Visual Studio 2019 RC and ASP.NET core 3 preview 3 as a single project razor components solution - would you expect it to work in this setup, or are changes needed? (I'm very new to Blazor, so this might be the cause of my issues!)
    Mladen Macanović
    @stsrki
    It's the problem with the razor components because they still dont support content files in the component libraries. As far as I know it will be implemented in the next preview 4 or 5. Until then you should stick with the Blazor 0.9 and just convert project later to the RC. Its mostly a few lines to change.
    smithgor
    @smithgor
    Blazor is the part that attracted me to try this technology, but obviously RC is coming first to production. I'll so as you suggest to get started. Appreciate the swift reply - many thanks.
    xAragornx
    @xAragornx
    Do you have any updates on adding razor component support to Blazorize?
    Mladen Macanović
    @stsrki
    @smithgor @xAragornx Actually I'm now in the middle of upgrading to the Razor Component. The biggest and only issue is the lack of support for static files by the RC. I have found this library BlazorEmbedLibrary that can help with the problem, but so far it's working only partially. Some files are loaded and some are still missing. I will need more time to test it. If everything goes well I will release new version in the next day or two.
    smithgor
    @smithgor
    I found this on GIT. Looks like preview 4 is design, then preview 5 is the implementation, so probably this is about 5-6 weeks away from being officially available. aspnet/AspNetCore#8177
    kiyote
    @kiyote
    Quick question...using something like Blazorise.Material....is there an obvious way to customize the colourscheme? Like...drop a css file in with a particularly named set of overrides or something?
    Mladen Macanović
    @stsrki
    @smithgor yeah I already saw that. Hopefully it will be soon. In the meantime I can publish temporary version that will work by using the BlazorEmbedLibrary or maybe I can create some bundle with all required js and css files that can be manually copied to the wwwroot folder
    @kiyote material is based on the library by daemonite which is based on the bootstrap. You can follow their documentation on http://daemonite.github.io/material/docs/4.1/getting-started/theming/
    @kiyote PS. this is the tool that I have used to create custom themes for my projects. you can find it on https://github.com/DevExpress/bootstrap-themes
    Mladen Macanović
    @stsrki
    @kiyote @smithgor the upgrade requires that all project must be targeted for netcoreapp3.0 instead of netstandard2.0. Is that OK for you guys?
    smithgor
    @smithgor
    @stsrki 3.0 is fine for me, and would let me start using Blazorise for sure.
    Mladen Macanović
    @stsrki

    Blazorise 0.6.2 now available

    This version now supports both Blazor 0.9 and the latest Razor Components. For RC there is some additional steps that needs to be done before using it. Please look at the readme or docs to find detail instructions.

    Github: https://github.com/stsrki/Blazorise

    Docs: https://blazorise.com/docs/

    Mladen Macanović
    @stsrki
    @smithgor @kiyote please try the latest version and let me know how it goes :)
    smithgor
    @smithgor
    @stsrki on it - thanks!
    kiyote
    @kiyote
    @stsrki Thanks, I'll look in to the theme stuff. 3.0 is no problem, it's embedded in to my Blazor app anyway. :)
    kiyote
    @kiyote
    Okay, so clearly I'm not understanding how to install this properly. I tried following the quick start guide, but I've not had any luck. I downloaded the bundle, put it in my wwwroot, added links to load those files, but nothing is themed. In fact, I can see that Blazorise is adding links in to the head to try to load similarly named files from the _content folder.... what am I missing?
    Previously, I just looked at how a demo was doing it, grabbed the material.min css and js and dropped them in my folder, loaded them manually and things seem to work
    Do I even need to drop the bundle in my wwwroot? It seems that Blazorise serves up generated files from the _content folder, which are fairly empty. So I still include the "real" material.min.css and material.min.js, and the blazorise stuff is in addition to that?
    Oh, god, I'm so stupid, that's for RC
    Mladen Macanović
    @stsrki
    Haha jep its just for RC
    So you managed to make it work?
    kiyote
    @kiyote
    Yeah, went back to just directly including the material.min css and js and things are nicely themed again.
    Still have no idea how to customize the colours, short of setting up sass and all that jazz.
    But I have some ideas.
    Mladen Macanović
    @stsrki
    I can try to figure something regarding the themeing. But that will probably take a long time.
    Its on a long term list
    kiyote
    @kiyote
    No worries, I'm pretty sure I can override :root{} in my own local css, that should work
    xAragornx
    @xAragornx
    Just FYI - Modals, dropdowns, and charts are not working on your online demo of Blazorise RC.
    Mladen Macanović
    @stsrki
    @xAragornx must be that something is missing on the server. On my dev PC it's working. tnx
    Mladen Macanović
    @stsrki
    it seems there is any issue with the jsRuntime when prerendering. aspnet/AspNetCore#8786
    Bryon Barnard
    @BarnyardTech
    image.png
    image.png
    I just went through your getting started page and I'm trying to implement your basic Line Chart. but I'm seeing both of the following at runtime.
    My app is razor components
    Mladen Macanović
    @stsrki
    @BarnyardTech Did you do this step? https://github.com/stsrki/Blazorise#razor-components
    Can you show me your index.cshtml code?
    Bryon Barnard
    @BarnyardTech

    '''@page "{*clientPath}"
    <!DOCTYPE html>

    <html>

    <head>
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
    <title>dgMetrics</title>
    <base href="~/" />

    <link href="css/bootstrap/bootstrap.min.css" rel="stylesheet" />
    <link href="css/site.css" rel="stylesheet" />
    <link href="css/kendo-themes/default/dist/all.css" rel="stylesheet" type="text/css" />
    <link href="css/kendo-themes/material/dist/all.css" rel="stylesheet" type="text/css" />
    <link href="css/kendo-themes/bootstrap/dist/all.css" rel="stylesheet" type="text/css" />
    
    <link rel="stylesheet" href="https://stackpath.bootstrapcdn.com/bootstrap/4.2.1/css/bootstrap.min.css" integrity="sha384-GJzZqFGwb1QTTN6wy59ffF1BuGJpLSa9DkKMp0DgiMDm4iYMj70gZWKYbI706tWS" crossorigin="anonymous" />
    <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.4.1/css/all.css" integrity="sha384-5sAR7xN1Nv6T6+dT2mhtzEpVJvfS3NScPQTrOxhwjIuvcA67KV2R5Jz6kr4abQsz" crossorigin="anonymous" />
    
    <link href="css/blazorise/blazorise.css" rel="stylesheet" />
    <link href="css/blazorise/blazorise.bootstrap.css" rel="stylesheet" />
    <link href="css/blazorise/blazorise.sidebar.css" rel="stylesheet" />
    <link href="css/blazorise/blazorise.snackbar.css" rel="stylesheet" />
    
    <script src="blazorise.js"></script>
    <script src="blazorise.bootstrap.js"></script>
    <script src="blazorise.charts.js"></script>
    <script src="blazorise.sidebar.js"></script>
    <script src="https://cdnjs.cloudflare.com/ajax/libs/Chart.js/2.7.2/Chart.min.js"></script>
    
    <script src="https://code.jquery.com/jquery-3.3.1.slim.min.js" integrity="sha384-q8i/X+965DzO0rT7abK41JStQIAqVgRVzpbzo5smXKp4YfRvH+8abtTE1Pi6jizo" crossorigin="anonymous"></script>
    <script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.6/umd/popper.min.js" integrity="sha384-wHAiFfRlMFy6i5SRaxvfOCifBUQy1xHdJ/yoi7FRNXMRBu5WHdZYu1hA6ZOblgut" crossorigin="anonymous"></script>
    <script src="https://stackpath.bootstrapcdn.com/bootstrap/4.2.1/js/bootstrap.min.js" integrity="sha384-B0UglyR+jN6CkvvICOB2joaf5I4l3gm9GU6Hc1og6Ls7i6U/mkkaduKaBhlAXv9k" crossorigin="anonymous"></script>

    </head>

    <body>
    <app>@(await Html.RenderComponentAsync<App>())</app>

    <script src="_framework/components.server.js"></script>

    </body>
    </html>
    '''

    sorry about the formatting
    Mladen Macanović
    @stsrki
    np
    so I guess you have also downloaded bundle.zip into your wwwroot right?
    Bryon Barnard
    @BarnyardTech
    I copied the files into css/blazorise folder