Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    kiyote
    @kiyote
    @stsrki Thanks, I'll look in to the theme stuff. 3.0 is no problem, it's embedded in to my Blazor app anyway. :)
    kiyote
    @kiyote
    Okay, so clearly I'm not understanding how to install this properly. I tried following the quick start guide, but I've not had any luck. I downloaded the bundle, put it in my wwwroot, added links to load those files, but nothing is themed. In fact, I can see that Blazorise is adding links in to the head to try to load similarly named files from the _content folder.... what am I missing?
    Previously, I just looked at how a demo was doing it, grabbed the material.min css and js and dropped them in my folder, loaded them manually and things seem to work
    Do I even need to drop the bundle in my wwwroot? It seems that Blazorise serves up generated files from the _content folder, which are fairly empty. So I still include the "real" material.min.css and material.min.js, and the blazorise stuff is in addition to that?
    Oh, god, I'm so stupid, that's for RC
    Mladen Macanović
    @stsrki
    Haha jep its just for RC
    So you managed to make it work?
    kiyote
    @kiyote
    Yeah, went back to just directly including the material.min css and js and things are nicely themed again.
    Still have no idea how to customize the colours, short of setting up sass and all that jazz.
    But I have some ideas.
    Mladen Macanović
    @stsrki
    I can try to figure something regarding the themeing. But that will probably take a long time.
    Its on a long term list
    kiyote
    @kiyote
    No worries, I'm pretty sure I can override :root{} in my own local css, that should work
    xAragornx
    @xAragornx
    Just FYI - Modals, dropdowns, and charts are not working on your online demo of Blazorise RC.
    Mladen Macanović
    @stsrki
    @xAragornx must be that something is missing on the server. On my dev PC it's working. tnx
    Mladen Macanović
    @stsrki
    it seems there is any issue with the jsRuntime when prerendering. aspnet/AspNetCore#8786
    Bryon Barnard
    @BarnyardTech
    image.png
    image.png
    I just went through your getting started page and I'm trying to implement your basic Line Chart. but I'm seeing both of the following at runtime.
    My app is razor components
    Mladen Macanović
    @stsrki
    @BarnyardTech Did you do this step? https://github.com/stsrki/Blazorise#razor-components
    Can you show me your index.cshtml code?
    Bryon Barnard
    @BarnyardTech

    '''@page "{*clientPath}"
    <!DOCTYPE html>

    <html>

    <head>
    <meta charset="utf-8" />
    <meta name="viewport" content="width=device-width, initial-scale=1.0" />
    <title>dgMetrics</title>
    <base href="~/" />

    <link href="css/bootstrap/bootstrap.min.css" rel="stylesheet" />
    <link href="css/site.css" rel="stylesheet" />
    <link href="css/kendo-themes/default/dist/all.css" rel="stylesheet" type="text/css" />
    <link href="css/kendo-themes/material/dist/all.css" rel="stylesheet" type="text/css" />
    <link href="css/kendo-themes/bootstrap/dist/all.css" rel="stylesheet" type="text/css" />
    
    <link rel="stylesheet" href="https://stackpath.bootstrapcdn.com/bootstrap/4.2.1/css/bootstrap.min.css" integrity="sha384-GJzZqFGwb1QTTN6wy59ffF1BuGJpLSa9DkKMp0DgiMDm4iYMj70gZWKYbI706tWS" crossorigin="anonymous" />
    <link rel="stylesheet" href="https://use.fontawesome.com/releases/v5.4.1/css/all.css" integrity="sha384-5sAR7xN1Nv6T6+dT2mhtzEpVJvfS3NScPQTrOxhwjIuvcA67KV2R5Jz6kr4abQsz" crossorigin="anonymous" />
    
    <link href="css/blazorise/blazorise.css" rel="stylesheet" />
    <link href="css/blazorise/blazorise.bootstrap.css" rel="stylesheet" />
    <link href="css/blazorise/blazorise.sidebar.css" rel="stylesheet" />
    <link href="css/blazorise/blazorise.snackbar.css" rel="stylesheet" />
    
    <script src="blazorise.js"></script>
    <script src="blazorise.bootstrap.js"></script>
    <script src="blazorise.charts.js"></script>
    <script src="blazorise.sidebar.js"></script>
    <script src="https://cdnjs.cloudflare.com/ajax/libs/Chart.js/2.7.2/Chart.min.js"></script>
    
    <script src="https://code.jquery.com/jquery-3.3.1.slim.min.js" integrity="sha384-q8i/X+965DzO0rT7abK41JStQIAqVgRVzpbzo5smXKp4YfRvH+8abtTE1Pi6jizo" crossorigin="anonymous"></script>
    <script src="https://cdnjs.cloudflare.com/ajax/libs/popper.js/1.14.6/umd/popper.min.js" integrity="sha384-wHAiFfRlMFy6i5SRaxvfOCifBUQy1xHdJ/yoi7FRNXMRBu5WHdZYu1hA6ZOblgut" crossorigin="anonymous"></script>
    <script src="https://stackpath.bootstrapcdn.com/bootstrap/4.2.1/js/bootstrap.min.js" integrity="sha384-B0UglyR+jN6CkvvICOB2joaf5I4l3gm9GU6Hc1og6Ls7i6U/mkkaduKaBhlAXv9k" crossorigin="anonymous"></script>

    </head>

    <body>
    <app>@(await Html.RenderComponentAsync<App>())</app>

    <script src="_framework/components.server.js"></script>

    </body>
    </html>
    '''

    sorry about the formatting
    Mladen Macanović
    @stsrki
    np
    so I guess you have also downloaded bundle.zip into your wwwroot right?
    Bryon Barnard
    @BarnyardTech
    I copied the files into css/blazorise folder
    Mladen Macanović
    @stsrki
    I see that js files are in the root folder
    also you have two bootstrap css versions, just fyi
    Bryon Barnard
    @BarnyardTech
    ahh let me check
    image.png
    That did the trick. One other issue is that I lose my left nav (as exists when creating a new razor components app). All my left nav aptions are missing.
    I'm not an experienced developer so my questions are noobie
    Mladen Macanović
    @stsrki
    you mean the default sidebar created by the Razor Component project template?
    Bryon Barnard
    @BarnyardTech
    yes
    I just dropped your line chart into a page in that default framework
    Mladen Macanović
    @stsrki
    I think you should place the site.css to be the last one
    Bryon Barnard
    @BarnyardTech
    Let me try
    Perfect. I'm up an running. I look forward to playing around with Blazorise.
    Mladen Macanović
    @stsrki
    Glad I could help :)
    Bryon Barnard
    @BarnyardTech
    Now I'm at home and trying to use Blazorise on another project. This time I get a build error: Error CS0029 Cannot implicitly convert type 'Microsoft.AspNetCore.Components.ElementRef' to 'Blazorise.Charts.LineChart<double>' Any ideas on this one?
    Bryon Barnard
    @BarnyardTech
    Never mind. I figured it out.
    kiyote
    @kiyote
    @BarnyardTech Don't be afraid of client-side either. Blazorise works great for that scenario too. I'm loving Blazorise, takes a lot of the pain out of getting a good looking and functional page together.
    Bryon Barnard
    @BarnyardTech
    Thanks @kiyote . I'm starting with server side because it is further along and it meets my needs well enough for now. I'm intrigued with Ed Charbeneaux's demo of the dual-mode and might play around with that too. Regarding Blazorise... I haven't used it before but like you said, I'm hoping it will speed me up on nice looking UI.
    Brett
    @brettwinters
    Question: i want to wrap the Blazorise Modal in a component along with data access etc. How to do this in Blazor? would I then expose a ref so i can load it from the parent?
    Mladen Macanović
    @stsrki
    @brettwinters Have a look at this answer. I think it could be similar to your problem.
    You can also try to handle modal by using the ref attribute, that should also work.
    Brett
    @brettwinters
    perfect! thanks @stsrki
    Brett
    @brettwinters
    hi @stsrki - Have you implemented the BS transitions / animations on the Collapse? It seems to expand/collapse instantly so I'm not sure if this is by design. How to slow things down a little?
    Mladen Macanović
    @stsrki
    @brettwinters It's little difficult to implement it because natively Bootstrap is using jquery to do the animation and I'm only switching the active class name on the collapse component. The other problem is that collapse content must have a defined Height so that animation could work. You can google around for some css so that animation will work for your own project.
    Brett
    @brettwinters
    ok, thanks @stsrki - I'll look into that. Another question. I want to implement a drawer (like a collapse on the vertical axis) but without the predefined styling of the sidebar. Any tips for that?