Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Mladen Macanović
    @stsrki
    you mean the default sidebar created by the Razor Component project template?
    Bryon Barnard
    @BarnyardTech
    yes
    I just dropped your line chart into a page in that default framework
    Mladen Macanović
    @stsrki
    I think you should place the site.css to be the last one
    Bryon Barnard
    @BarnyardTech
    Let me try
    Perfect. I'm up an running. I look forward to playing around with Blazorise.
    Mladen Macanović
    @stsrki
    Glad I could help :)
    Bryon Barnard
    @BarnyardTech
    Now I'm at home and trying to use Blazorise on another project. This time I get a build error: Error CS0029 Cannot implicitly convert type 'Microsoft.AspNetCore.Components.ElementRef' to 'Blazorise.Charts.LineChart<double>' Any ideas on this one?
    Bryon Barnard
    @BarnyardTech
    Never mind. I figured it out.
    kiyote
    @kiyote
    @BarnyardTech Don't be afraid of client-side either. Blazorise works great for that scenario too. I'm loving Blazorise, takes a lot of the pain out of getting a good looking and functional page together.
    Bryon Barnard
    @BarnyardTech
    Thanks @kiyote . I'm starting with server side because it is further along and it meets my needs well enough for now. I'm intrigued with Ed Charbeneaux's demo of the dual-mode and might play around with that too. Regarding Blazorise... I haven't used it before but like you said, I'm hoping it will speed me up on nice looking UI.
    Brett
    @brettwinters
    Question: i want to wrap the Blazorise Modal in a component along with data access etc. How to do this in Blazor? would I then expose a ref so i can load it from the parent?
    Mladen Macanović
    @stsrki
    @brettwinters Have a look at this answer. I think it could be similar to your problem.
    You can also try to handle modal by using the ref attribute, that should also work.
    Brett
    @brettwinters
    perfect! thanks @stsrki
    Brett
    @brettwinters
    hi @stsrki - Have you implemented the BS transitions / animations on the Collapse? It seems to expand/collapse instantly so I'm not sure if this is by design. How to slow things down a little?
    Mladen Macanović
    @stsrki
    @brettwinters It's little difficult to implement it because natively Bootstrap is using jquery to do the animation and I'm only switching the active class name on the collapse component. The other problem is that collapse content must have a defined Height so that animation could work. You can google around for some css so that animation will work for your own project.
    Brett
    @brettwinters
    ok, thanks @stsrki - I'll look into that. Another question. I want to implement a drawer (like a collapse on the vertical axis) but without the predefined styling of the sidebar. Any tips for that?
    Mladen Macanović
    @stsrki
    @brettwinters I think you should still be able to use collapse with a predefined width and then combine it with custom animation css. I would like to be of more help but I'm not that good with css.
    Brett
    @brettwinters
    ok, thanks for the tip. No, problem - I'm very grateful for your work on Blazorise!
    Ricardo
    @ricardoromaobr
    I'm looking the code, maybe I can help in some thing. Whats means HasCustomRegistration in the components?
    Mladen Macanović
    @stsrki
    @ricardoromaobr HasCustomRegistration checks if there is a replacement or custom implementation of that same component. For example Button will render just button element. But maybe Bulma CSS or some other provider must also render div around button. In that case the custom component implementation will be rendered instead.
    Ricardo
    @ricardoromaobr
    Great! And each provider Blazorize.Bootstrap, Bulma, Frolic and Material, provide a IClassProvider implementation and register each component at componentMapper.
    ?
    Mladen Macanović
    @stsrki
    Yes every provider must implement IClassProvider. But not every component needs custom implementation. Only the ones that have some specific structure. Most of the times they're all the same except for classnames or style settings.
    IVData
    @IVData
    Hey there. I'm wondering how with a blazorise linechart I can set the y-axis to begin at 0? It just starts near the lowest value in the chart.
    Closest thing I could find was setting AxeTicks.BeginAtZero to true but that didnt work
    Mladen Macanović
    @stsrki
    @IVData by looking at chartjs doc it seems it should work like that
    can you provide me with a sample code so maybe I can find a solution?
    IVData
    @IVData
    I dont really sorry I have to head out. But this is what Im using to set the option:
    var axe = new Axe() { Ticks = new AxeTicks() { BeginAtZero = true } };
    lineChart.SetOptions(new LineChartOptions() { Scales = new Scales() { YAxes = new List<Axe>() { axe} } });
    Sorry yeah its messy haha
    lineChart is defined like LineChart<double> lineChart;
    I also clear the chart (this is a live chart that scrolls, so I clear it to re-draw it). Does the axes need to be set each time I call AddDataSet()?
    Mladen Macanović
    @stsrki
    @IVData try to set OptionsJsonString attribute instead. Use this "{\"scales\": {\"yAxes\": [{\"ticks\": {\"beginAtZero\": \"true\"}}]}}" as value.
    IVData
    @IVData
    That worked thanks!
    So does that mean the other options aren't working properly?
    Mladen Macanović
    @stsrki
    It's not the problem with Options but with the default json serializer that Blazor is using. It is pretty buggy and it doesn't support inheritance. Also some required features are also missing. I thinking to write my own json serializer instead but that can take time. So that's why I introduced OptionsJsonString as a workaround.
    Mladen Macanović
    @stsrki
    Blazorise 0.8.5 is finally released. See release notes for a full list of changes.
    Github: https://github.com/stsrki/Blazorise
    Ricardo
    @ricardoromaobr
    Nice!
    Brett
    @brettwinters
    image.png
    Hi @stsrki - not sure if this is my issue - I remember playing around with my css (body, z-order) to try to get the toolips working
    Mladen Macanović
    @stsrki
    @brettwinters what is the problem here? Tooltips or modal backdrop?
    Brett
    @brettwinters
    the modal backdrop. But i’m not sure whats causing this issue. Are your demos working?
    Mladen Macanović
    @stsrki
    image.png
    Seems like they're working
    Brett
    @brettwinters
    Yeah I must have set something somewhere....🤔
    Mladen Macanović
    @stsrki
    .modal-backdrop { z-index: -1; }
    try this
    something should be wrong with z-index
    Brett
    @brettwinters
    Oh yes I think mine is showing about 1000 - I think that’s the BS setting. I’ve already closed my laptop. Will try tomorrow. Have a good evening !