Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Dec 09 18:17
    SuiteBot commented #9845
  • Dec 09 18:17
    SuiteBot commented #9844
  • Dec 09 17:26
    2xaronl edited #9845
  • Dec 09 17:26
    2xaronl edited #9844
  • Dec 09 17:18
    2xaronl opened #9845
  • Dec 09 16:35
    SuiteBot commented #3897
  • Dec 09 16:35
    SuiteBot commented #4017
  • Dec 09 16:34
    SuiteBot commented #4266
  • Dec 09 16:34
    SuiteBot commented #6009
  • Dec 09 16:33
    SuiteBot commented #7178
  • Dec 09 16:33
    SuiteBot commented #7256
  • Dec 09 16:33
    SuiteBot commented #7301
  • Dec 09 16:33
    SuiteBot commented #7296
  • Dec 09 16:33
    SuiteBot commented #7757
  • Dec 09 16:32
    SuiteBot commented #8043
  • Dec 09 16:31
    SuiteBot commented #8367
  • Dec 09 16:29
    SuiteBot commented #8736
  • Dec 09 16:29
    SuiteBot commented #8811
  • Dec 09 16:29
    pgorod commented #9839
  • Dec 09 16:26
    2xaronl edited #9844
Pedro Ribeiro
@pribeiro42
@derspatzvomdach_twitter I believe you don't need to run composer on that package....
Carsten Aevermann
@derspatzvomdach_twitter
ok - thx
Ashley Nicolson
@samus-aran
Yeah 7.11 isn't composer 2 compatible but we are aiming to be soon
Carsten Aevermann
@derspatzvomdach_twitter

other question tried to use beta 3 and the final installer throws a line like In MysqlManager.php line 524:

Attempted to call function "mysql_connect" from the global namespace. and fails any hints?

is there a file containing the db and environment settings which I can create manually without the installer?
Carsten Aevermann
@derspatzvomdach_twitter
found it - .env.local so the above complains didnt relay to not creating the conf file but the db connection dont work. Is there a working docker image or docker-compose.yml/Dockerfile for the beta available.?
Ashley Nicolson
@samus-aran
@derspatzvomdach_twitter There isn't one available just now, no. But we will be looking for one in the future.
There is a thread on the forums that a few folk have asked for help in installing, perhaps your issue is there?
https://community.suitecrm.com/t/suitecrm-8-beta-install-questions/79383/129
Ashley Nicolson
@samus-aran
I have been informed that a community member has created a docker image. Haven't tried it personally so be sure to give feedback to them when you can :+1:
https://community.suitecrm.com/t/suitecrm-8-beta-install-questions/79383/126?u=clemente.raposo
Carsten Aevermann
@derspatzvomdach_twitter
nice, thx I'll try this.
Carsten Aevermann
@derspatzvomdach_twitter
cool works. thx, made some very minor changes to make it work (path, permissions and www-data group) thx for the hint, rl appreciate it. https://github.com/jontitmus-code/SuiteCRM8_docker
Ashley Nicolson
@samus-aran
Good stuff :heart:
Maxim Lanin
@lmax85
Screenshot 2021-09-22 at 14.06.54.png
Hi everyone! As i understood from code - for now Notifications (Alert module) is static template in beta versions... Is it right? or maybe it is possible to change it for working with notifications like in v7 (https://community.suitecrm.com/t/how-to-create-notifications-by-using-workflows-logic-hooks/70809)?
Sayooj K S
@SayoojKS18_twitter
Hi, I tried to run command "'.\vendor\bin\robo configure:tests" in my windows for automaed testing . Getting an error like this, "'.\vendor\bin\robo' is not recognized as an internal or external command,
operable program or batch file."
plz anyone can help
holdusback
@holdusback
salesagility/SuiteCRM#9292 Am I the only one to still have this issue after the last update ? ...
Ashley Nicolson
@samus-aran
@holdusback Just picking up these messages :)
Ok, so even with this PR included you still get issues yeah?
Ashley Nicolson
@samus-aran

googleapis/google-api-php-client-services#384

I commented on it, but linking it here for quickness

Ashley Nicolson
@samus-aran
@lmax85 Will need to check this to be honest! I'll get back to you.
1 reply
Ashley Nicolson
@samus-aran
2 replies
Sayooj K S
@SayoojKS18_twitter
Thank you all for the help , i tried to do the command "php consolidation/robo/robo" now i am getting like this
ERROR: Uncaught Exception: SuiteCRM is not installed. Entry point needs an installed SuiteCRM, please install first. in C:\xampp\htdocs\suite\include\entryPoint.php:59
holdusback
@holdusback

googleapis/google-api-php-client-services#384

I commented on it, but linking it here for quickness

Just delete the folder fix the issue, hope it break nothing ahah, thanks for the help !

holdusback
@holdusback

Hey there, quick question : do someone know how to force advanced search for every search on the CRM ?

Some of my account don't appear on the normal search, when I press advanced search they appear. (Indexation have crashed ?)

2 replies
holdusback
@holdusback
image.png
I fixed it by only using the "advanced search" in the global search
So on the search there is no more the option to switch the search like here :
image.png
I forced this one :
image.png
Cause on the other some account dont appear and on this one everything appear ... I think the indexation crashed somewhere, but I have too much work on the CRM to do to look deeper, so that a quick fix ahah
Ashley Nicolson
@samus-aran
Haha
holdusback
@holdusback
Im migrating my entire instance of SuiteCRM
image.png
Inside thoses folder there is a backup of the CRM I think
But damn I have 7 version of my CRM, inside my CRM 🤣
It doesnt delete thoses after an amount of time ?
PGR Talked about thoses here, but no real explaination
Pedro Ribeiro
@pribeiro42
Do those upgrade packages appear on the Module Loader interface ? If so, i guess you can delete them from there....
So what I linked was a similar situation about the failure when upgrading and removing temp files. Work had been done on that, but it may need more.
Jan Siero
@JanSiero

Hi, an upgrade is regarded as a module and SuiteCRM maintains a copy of every file which is replaced as a restore for the case where you would want to uninstall a module, which doesn't make sense for upgrades.

The proper solution would be for SuiteCRM not to create restore files for modules that have the following property in the manifest:
'is_uninstallable' => false,

Deleting files from the module loader is only possible once they are first uninstalled which is not possible for upgrades. The delete function then deletes the installer package, not the restore files (which for uninstallable modules would have been restored by uninstalling the module).

For now you would delete these files manually after upgrading.

holdusback
@holdusback

Do those upgrade packages appear on the Module Loader interface ? If so, i guess you can delete them from there....

Was thinking the same, but if you click delete it only delete the .zip file, not the extracted folder...

Thanks a lot for the clarification @JanSiero , so I have to add this into my 'after update.doc' ahah, will check out the issue @samus-aran thanks you !
So I can safely delete all thoses folder ? It make my CRM goes over 2GB for the entire folder ahah
Khwaish Nagdev
@knagdev:matrix.org
[m]
How can we create a robo command to automate the installation process?
Is there any idea?