Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jan 18 10:55
    asijoumi edited #634
  • Jan 18 10:55
    asijoumi opened #634
  • Jan 12 06:05
    nohaapav commented #272
  • Jan 11 23:08
    Aneadiel commented #262
  • Jan 10 19:25
    nohaapav commented #633
  • Jan 10 08:36
    dhpowrhost commented #618
  • Jan 10 01:14
    lightningspirit commented #633
  • Jan 10 00:43
    lightningspirit opened #633
  • Jan 09 12:54
    lozhn commented #618
  • Jan 07 14:19
    mh3th commented #272
  • Jan 02 03:36
    kallsbo commented #630
  • Jan 02 02:20
    Leopere closed #630
  • Jan 02 02:20
    Leopere commented #630
  • Dec 31 2021 22:31
    kallsbo commented #630
  • Dec 27 2021 02:24
    ztimson edited #606
  • Dec 19 2021 15:04
    lumir-mrkva synchronize #632
  • Dec 19 2021 15:04

    lumir-mrkva on new-ci

    only upload jar (compare)

  • Dec 19 2021 14:57
    lumir-mrkva synchronize #632
  • Dec 19 2021 14:57

    lumir-mrkva on new-ci

    start dind (compare)

  • Dec 19 2021 14:52
    lumir-mrkva synchronize #632
Pavol Noha
@nohaapav
@ericbarber01_twitter not supported yet. See swarmpit/swarmpit#400
francis2211
@francis2211
I am playing with Swarmpit and I was wondering how can I add a new node to swarmpit?
Currently, I have 3 nodes running, and I just added another one how can I start the agent on that node
Pavol Noha
@nohaapav
You have to connect node via swarm api .. swarmpit has not such feature yet. To start agent just deploy agent service globally .. see swarmpit stack .. @francis2211
Matthias Baldi
@matthiasbaldi
@francis2211 as Pavel explained: You only have to add the node to your swarm cluster, then Swarmpit should automatically deploy the agent.
As example for a global agent service:
...
services:
 agent:
   image: swarmpit/agent:latest
   volumes:
     - /var/run/docker.sock:/var/run/docker.sock:ro
   logging:
     options:
       max-size: 5M
   deploy:
     mode: global
     resources:
       limits:
         cpus: '0.10'
         memory: 64M
       reservations:
         cpus: '0.05'
         memory: 32M
I Stevenson
@irstevenson

Hi All,

Are there any memory/resource leak issues known for AWS ECR registry support and/or autoredeploy? It might be a coincidence, but since I added a service in a private AWS ECR registry with autoredeploy I've had memory issues with the swarmpit container. I've just restarted the swarmpit container today (actually, had to restart manager node as it also used up all system threads, so I couldn't ssh in) and am monitoring for a few hours and then will be turning off the autoredeploy; but was just curious if others had seen this?

I Stevenson
@irstevenson
hmmm, initial indications after turning off the autodeploy one and a half hours ago is that memory usage on the node has stablised again. Indeed the memory usage looks to be slowly dropping (to potentially free resources from the first four hours but at a much slower rate).
image.png
And to show a longer term graph capturing the first restart and then subsequent repeat event:
image.png
Pavol Noha
@nohaapav
@irstevenson Hi, create an issue on github se we can track/discuss this over there please.
I Stevenson
@irstevenson
Sure thing @nohaapav -> swarmpit/swarmpit#471
Matthias Baldi
@matthiasbaldi
@nohaapav ty. ya nice one 😅✌
rwanito
@rwanito
Hi ! I would to know how I can configure CouchDB ? I have many errors like no db created...
Is it possible to have a configuration with docker-compose.yml to setup couchdb easily ?
And there is a diff between couchdb 2.3.0 and 3.0.0 ?
Thanks !!!
rwanito
@rwanito
EDIT :
I configure my stack like the docker-compose.yml in the git.
Just with COUCHDB_USER and COUCHDB_PASSWORD set.
rwanito
@rwanito
My log from swarmpt said : DB error status 412
rwanito
@rwanito
Okay , My stack works now... I don't know why, I use couchdb 3.0.
lumir-mrkva
@lumir-mrkva
@rwanito nice, can you send us yours stack? it would help us to potencially upgrade to couchdb 3
Luiz Júnior
@luizjr
image.png
Luiz Júnior
@luizjr
image.png
I'm having trouble with the dashboard chart.
Follows attached: https://i.ibb.co/3rJdyS6/image.png
Pavol Noha
@nohaapav
@luizjr Open an github issue and let's discuss the details over there ..
bboh
@bboh
Hi, I am running v1.8 and having trouble with compose file version 3.3. This swarmpit/swarmpit#376 suggests that 3.3 should work. Is this true for the 1.8. release?
In the compose file deploy.placement.preferences is ignored. docker stack deploy with the same file works fine
Pavol Noha
@nohaapav
@bboh Raise an issue on github. We support 3.3 however some functionality might be missing.
bboh
@bboh
@nohaapav I raised an issue with the feature request swarmpit/swarmpit#488
KernelWard
@kernelward_gitlab
Hi, I have a problem. I upgraded from swarmpit 1.6 to 1.9 with dockercompose file. Now while browsing volumes in swarmpit I get "Server request failed" and on /api/volumes "{"error":"Authentication failed"}"
what to do?
KernelWard
@kernelward_gitlab
opened up an issue
Strahinja
@kilgaloon
Hey guys i have some problem adding private registry to swarmpit, im getting Request timeout, but when i try access registry API by postman i get proper responses, anyone knows whats going on?
lumir-mrkva
@lumir-mrkva
@kilgaloon hi, are you sure that the registry is accessible from swarm cluster as well?
Shakeel Osmani
@shakeelosmani

@nohaapav I added a comment to the issue swarmpit/swarmpit#296

I have setup all the correct permissions I believe. But still I am having issues. Any suggestions?

dhinilkv956
@dhinilkv956
Hi is swarmpit is free to use or any price it cost?
Pavol Noha
@nohaapav
@dhinilkv956 Swarmpit is free of charge
Matthias Baldi
@matthiasbaldi
@nohaapav a question: Did I miss the possibility in Swarmpit to set the logger-driver to the default of the daemon or is this a wanted behavior?
Because I started to use Loki together with Swarmpit and it would be nice to have the possibility to log all containers directly to the logger configured in the daemon.json.
Should I open for that an issue or is it an intentionally decision? :) ty
Pavol Noha
@nohaapav
@matthiasbaldi you can set log-driver on service level .. you can't set log driver on daemon level yet in swarmpit
I have to check codebase if default log level is json-driver or we pick the one from daemon ..
anyway correct behaviour is that swarmpit should pick the one from daemon, if this is not the case raise an issue please ;)
Matthias Baldi
@matthiasbaldi
ok, I think your answer is correct and I can confirm that.
What I ment is, when I deploy manually a stack (like the Swarmpit stack) I get now an emtpy log drivers input field (because they are not configured in the docker-compose.yaml) and then it picks the default, configured in the deamon.json.
Now, when I configure a service or a stack in Swarmpit, the default is the json-driver, but I am not able to set "nothing" to let the service pick the default from the deamon.
Why do I ask this? I configured Loki with a password etc. in the daemon.json and it is much more complicated to enter the password etc. again in every service than just configure the service to "nothing" alias pick the default.
So I think, generally the behavior is correct but may it would be possible to add the possibility to set "nothing" or you could call it "take daemon default".
May that would be a "feature" not a bug :laughing:
1 reply
Shakeel Osmani
@shakeelosmani
Guys this is more of a how to question. What kind of metrics do you look at per service to know it's time to scale them up of course first if the hardware allows. But once thats the case what do you look for in the dashboard to decide on scale up. And what is the best way to scale up from UI, edit service and increase number of replicas and save without touching any other fields in the service editor?
2 replies
Shakeel Osmani
@shakeelosmani
@nohaapav another quick question/ No way to reset a user password. Have to delete and recreate?
4 replies
Mario Gabriell Karaziaki
@MarioGK
Hi guys, i am new to docker swarm and swarmpit, i tried to run the installer but i got "Starting swarmpit...FAILED!" and 192.168.1.120:888 (master ip) does not load, i searched in the issues but seems like no one is getting this error
1 reply
junebug12851
@junebug12851
How do I reverse proxy to Swarmpit, I'm trying to access it through the HTTPS protocol using NGINX and it's not working, I'm getting 404 and 401 errors, only the index.html loads but none of the assets. Is there something wrong with swarmpit or my config? and if it's my config can anyone help me correct it?
1 reply
mgutkin
@mgutkin
We are evaluating swarmpit but were not able to install it. swarmpit_app service repeatedly gets stuck in 'New' state with 0/1 replicas deployed. I tried to modify swarmpit_net network to use /16 mast to allow more IPs, but that didn't seem to make any difference. Any advice what can it be?
juanpvh
@juanpvh
Hello everybody, How are you?! I installed swarmpit using docker swarm + traefik. The problem is in the panel, the graphics are not loaded. imagem. my code https://pastebin.com/TFAdk2RL
Anotação 2020-07-03 134707.png
Pavol Noha
@nohaapav
@juanpvh create an issue please so we can discuss over there.