Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • 14:15
    giograno starred syl20bnr/spacemacs
  • 06:38
    perfectayush commented #14901
  • Jul 23 22:41
    emacs18 commented #14930
  • Jul 23 21:05
    sapristi commented #14926
  • Jul 23 16:54
    Trapez commented #14926
  • Jul 23 15:59
    NOTNOTsergey starred syl20bnr/spacemacs
  • Jul 23 08:22
    duianto commented #14941
  • Jul 23 07:28
    duianto synchronize #14935
  • Jul 23 03:23
    Hazeezie starred syl20bnr/spacemacs
  • Jul 23 03:08
    komali2 commented #14939
  • Jul 23 02:30
    jason--liu commented #14939
  • Jul 22 16:03
    mario-bermonti commented #14941
  • Jul 22 16:02
    mario-bermonti commented #14941
  • Jul 22 14:57
    kappa synchronize #14930
  • Jul 22 14:51
    kappa synchronize #14930
  • Jul 22 14:50

    JAremko on develop

    [docs] fix link issue (compare)

  • Jul 22 14:49
    yves-biener starred syl20bnr/spacemacs
  • Jul 22 14:46

    JAremko on develop

    [docs] cleanup (compare)

  • Jul 22 13:46
    komali2 synchronize #14939
  • Jul 22 13:46
    komali2 commented #14939
Daniel Nicolai
@dalanicolai
@adjarar Great that it works...
@nishadhsingh I don't know what is recommended, but you could just rename/backup your current dotfile and restart Spacemacs
ForrestHilton
@ForrestHilton
@nishadhsingh the recommended method is to use the command space lowercase f lowercase e uppercase D to transfer changes from the template to the active.
xSlendiX
@xslendix
Hello everyone, I am trying to do some C-C++ coding using the clang backend but the include path is wrong. How can I edit it or pass arguments to clangd?
qaristote
@qaristote
Hi ! I enabled the auto-completion and nixos layers, but when I open a .nix file company-mode isn't enabled even though nixos-mode is. And if I manually enable company-mode, it's as if it wasn't enabled (I don't even get an error message). My understanding was that auto-completion would be enabled by default. Am I missing something ? Thanks !
Alessandro Piras
@laynor
is there a way to have proper fuzzy matching in C-x 8 RET? when I search for "arrow", for example, RIGHT ARROW is not in the search results.
westrom
@westrom:matrix.org
[m]
I found recently that if I evaluate code that returns excessively long lines of text, (upwards 100000 lines), the native-comp branch totally shits itself and hangs indefinitely. Using spacemacs on emacs-plus@28 --with-native-comp. It happens when I use CIDER to evaluate Clojure code that returns very large values. Works okay on the non-native branch.
Now why do I need to evaluate 100000 lines of text at once? I guess I could break it up, but since it broke on an update while it was working before, I'd much rather find a solution than skirt around the issue.
Is there a way to replicate the issue on GNU emacs?
Chris Matzenbach
@cmatzenbach
is lsp-mode broken for anyone else? i've been trying it for typescript, javascript, and php, I have all of the completion engines installed (intelephense, typescript-lang-server, deno) and completions don't work at all for php (it says "no completions found" no matter what I try), even though it says it is connected to iph, and for typescript i have to manually M-x company-complete or else wait for ~7 seconds for a completion window to pop-up, and even then it's incredibly slow going through all the completions. It used to work just fine, I'm not sure what's going on
Chris Matzenbach
@cmatzenbach
hmm seems like i was able to fix it. if anyone else is having similar issues try installing a fresh copy of spacemacs develop. that worked for me
Marco Milanesi
@kpanic

hey folks, not sure how it happened but today I opened spacemacs develop (with emacs 28) and I got:

      An error occurred while post-configuring window-purpose in layer shell (error: (error Unknown type purpose-mode-alist))

    - 
      An error occurred while post-configuring window-purpose in layer erc (error: (error Unknown type purpose-mode-alist))

    - 
      An error occurred while post-configuring window-purpose in layer python (error: (error Unknown type purpose-mode-alist))

Happens only to me?

1 reply
ForrestHilton
@ForrestHilton
I just did a full update of spacemacs on emacs 27.2 and it works fine.
@kpanic
Marco Milanesi
@kpanic
@ForrestHilton I tried emacs 27 and indeed everything works. Looks like it is happening on emacs 28 only
Juan Pablo
@Perju
@kpanic I compiled emacs before this emacs-mirror/emacs@4c65544 commit and works well
Marco Milanesi
@kpanic
@Perju oh thanks for the info. I am using emacs-28 from the snap store (lazy me) under Ubuntu, although I will check that commit hash
milochadam
@milochadam
Should evil-numbers/inc-at-pt work out of the box with multiple-cursors? It's specified in evil-mc-known-commands so it technically should I think...
Lucius Hu
@lebensterben

Hello everyone, I am trying to do some C-C++ coding using the clang backend but the include path is wrong. How can I edit it or pass arguments to clangd?

See CompileFlags. One solution is to add a compile_comands.json in the root of the project. https://clangd.llvm.org/config

This is frustruating for many new users.
A much simpler alternative is compile_flags.txt https://clang.llvm.org/docs/JSONCompilationDatabase.html#alternatives
The Wayfarrer
@epixinvites
image.png
how do i cancel this dialog
can't find the keybind to do that
basaran
@basaran
@epixinvites, did you try popwin:close-popup-window comment ?
M-x, and then search for popwin
Ivan Yonchovski
@yyoncho
@epixinvites C-g
Lucius Hu
@lebensterben
ESC should work if evil-collections is enabled for it
The Wayfarrer
@epixinvites
thanks
C-g works
luyangliuable
@luyangliuable
Hi any clue on how to change project location?
3 replies
Florian | W3F
@florian:web3.foundation
[m]
@kpanic: Downgrading from 20210613 (b0d6886 on pgtk) to 20210519 (1f82c85 on pgtk) did it for me as well. So it must be caused by a recent addition to emacs master in the last month.
sektor
@sektor:matrix.hunterjozwiak.com
[m]
Is anyone receiving errors the likes of this?
Error (use-package): eyebrowse/:config: Unknown type purpose-mode-alist
1 reply
If so, what is the fix?
Deepak Tripathi
@gnumonk
In spacemcas how do I enable postgres with tab completion? so that statement should get complete while we use "TAB" , just like from psql terminal from xterm.
I cannot remember now
company-tng should allow you to use TAB for selecting completions
Florian | W3F
@florian:web3.foundation
[m]
Depends on how you installed your emacs how easy that is for you.
2 replies
Daniel Nicolai
@dalanicolai
@gnumonk Do you have sqls lsp server installed?
wztdream
@wztdream
Hi all, when I use org layer, there will be an error 'Error (use-package): Cannot load org-contrib'
I think it is due to below setting in org layer, there is no feature named 'org-contrib', so how can I clear this error
(defun org/init-org-contrib ()
  (use-package org-contrib)
  :defer t
  )
you seems to be running on a fork
the parentheses is wrong
wztdream
@wztdream
Sorry, for this confusing, the code above is due to my mistake,(I type it myself, the code in my spacemacs is correct), but the error is same with this right code:
(defun org/init-org-contrib ()
  (use-package org-contrib
    :defer t))
An this change is due to syl20bnr/spacemacs@6319701, and these seems no feature named org-contrib, it seems to me this setting is wrong.
@lebensterben you can reproduce this error by adding org layer, you should see this error too.
Deepak Tripathi
@gnumonk

@gnumonk Do you have sqls lsp server installed?

@dalanicolai Yes , I do have

Lucius Hu
@lebensterben
I just replied to your bug report