These are chat archives for symengine/symengine

15th
Aug 2015
Sumith Kulal
@Sumith1896
Aug 15 2015 12:58
@bluescarni What minimum gcc version do we need for Piranha?
Sumith Kulal
@Sumith1896
Aug 15 2015 13:11
Because for Piranha I was getting update gcc errors but the fix commit Sumith1896/csympy@d8915b7 gives a compiler not found travis error
Isuru Fernando
@isuruf
Aug 15 2015 13:55
@Sumith1896, I commented on the commit
Sumith Kulal
@Sumith1896
Aug 15 2015 14:33
Got it @bluescarni
@isuruf The testing in Travis seems to compile now https://travis-ci.org/Sumith1896/csympy/jobs/75732632
But is this the right way to do it?
It will be installing Boost and g++ for all cases in here, right?
Isuru Fernando
@isuruf
Aug 15 2015 14:36
Yes
you should do it for only that test case
To resolve the error you are getting, add WITH_MPFR=yes as well
Btw, as @certik said, you should stop compiling the tests and benchmarks of piranha.
Then you will only need the boost-serialization-dev dependency for which you don't need the boost-latest
Sumith Kulal
@Sumith1896
Aug 15 2015 14:39
Doesn't -DWITH_PIRANHA=yes imply -DWITH_MPFR=yes?
Isuru Fernando
@isuruf
Aug 15 2015 14:41
Sumith Kulal
@Sumith1896
Aug 15 2015 14:42
you mean add || [[ "${WITH_PIRANHA}" == "yes" ]] ?
Isuru Fernando
@isuruf
Aug 15 2015 14:42
yes
Sumith Kulal
@Sumith1896
Aug 15 2015 14:43
Cool
Francesco Biscani
@bluescarni
Aug 15 2015 15:08
@Sumith1896 yep GCC 4.8 is the minimum GCC version. For Clang, I think the minimum is 3.3, even if I usually just test with the latest clang. For GCC I make sure it works all the way back to 4.8.
Sumith Kulal
@Sumith1896
Aug 15 2015 15:09
Yes, I noticed in the docs
The latest reports https://travis-ci.org/Sumith1896/csympy/jobs/75735893
@isuruf Shall I squash commits here sympy/symengine#585 ?
Isuru Fernando
@isuruf
Aug 15 2015 15:17
Can you add install g++-4.8 only for the piranha tests? I'm not sure installing g++-4.8 would have effects
Isuru Fernando
@isuruf
Aug 15 2015 15:23
@bluescarni, I see that you have set required Boost Libraries version to 1.48.0 because timers are available from 1.48.0 and above. Does piranha require other libraries to be also 1.48.0 or above?
Sumith Kulal
@Sumith1896
Aug 15 2015 15:39
@isuruf Updated https://github.com/sympy/symengine/pull/585/files
How does it look now?
Francesco Biscani
@bluescarni
Aug 15 2015 15:39
sorry I have the usual gitter problems here
I don't think so. The timers are also only used in the performance tests, there's actually no trace of them in the library
1.48.0 is again kind of arbitrary
sorry gitter just plain does not work for me occasionally
I am trying to write things and they just come out as redded out
which I assume is a non-delivered chat message
Isuru Fernando
@isuruf
Aug 15 2015 15:42
Yes, I don't see any duplicated messages
Francesco Biscani
@bluescarni
Aug 15 2015 15:43
anyway I just wanted to say
I don't know which is the minimum boost version
I just picked a conservative choice at the time
I am using 1.57 I think right now
actually make it 1.56
Isuru Fernando
@isuruf
Aug 15 2015 15:44
Okay, I will take a look and see whether 1.46.1 is enough. (default version in Ubuntu 12.04)
Francesco Biscani
@bluescarni
Aug 15 2015 15:45
I am not using any library which was only added recently
the only problem I could see is that some of the libraries I use changed their behaviour over the time... such breaking changes sometimes happen in Boost
it's not frequent but it might happen
thanks for checking, I can add it into the docs once you confirm it
Sumith Kulal
@Sumith1896
Aug 15 2015 18:49
@certik I'm stuck with shivamvats/symengine#4. Could we discuss that?
Sumith Kulal
@Sumith1896
Aug 15 2015 18:54
Consider the instance of multiplying {x, y, z} polynomial with{p, q, r}
_normalize_polymul decodes the exponents of first poly (vectors of size 3), appends three 0s (corresponding to p, q r), same happens for second poly with three 0s at the front.
_mul_hashset is low level hash_set multiplication.
Sumith Kulal
@Sumith1896
Aug 15 2015 19:02
_normalize_polymul here
_mul_hashset here