These are chat archives for symengine/symengine

18th
Oct 2015
Sumith Kulal
@Sumith1896
Oct 18 2015 14:23
What python versions does symengine.py as of now support?
Isuru Fernando
@isuruf
Oct 18 2015 14:24
2.6, 2.7, 3.3 and 3.4 are supported and tested
Sumith Kulal
@Sumith1896
Oct 18 2015 14:25
Cool, thanks
Isuru Fernando
@isuruf
Oct 18 2015 14:49
Do you have a Python3.5 setup? I don't think we will have much to do to support Python 3.5
Sumith Kulal
@Sumith1896
Oct 18 2015 14:52
Give me a moment
Sumith Kulal
@Sumith1896
Oct 18 2015 15:00
Hi @isuruf
Yes I have Python 3.5 installed
Isuru Fernando
@isuruf
Oct 18 2015 15:01
Can you check whether symengine.py builds on Python 3.5?
Sumith Kulal
@Sumith1896
Oct 18 2015 15:02
Nope, doesn't
I'll gist the error log
Isuru Fernando
@isuruf
Oct 18 2015 15:02
Thanks
Isuru Fernando
@isuruf
Oct 18 2015 15:18
What's your cython version?
Sumith Kulal
@Sumith1896
Oct 18 2015 15:18
0.21
Isuru Fernando
@isuruf
Oct 18 2015 15:18
You'll need 0.23
Sumith Kulal
@Sumith1896
Oct 18 2015 15:19
Oh
Will update and try
Sumith Kulal
@Sumith1896
Oct 18 2015 18:13
@isuruf No change on updating Cython to 0.23
Sumith Kulal
@Sumith1896
Oct 18 2015 18:25
thewtex/cython-cmake-example#10 showed that I have to build Python 3.5 using
CFLAGS='-fPIC' ./configure
Sumith Kulal
@Sumith1896
Oct 18 2015 18:36
Apart from couple of minor issues, looks good in Python 3.5