These are chat archives for symengine/symengine

21st
Oct 2015
Sumith Kulal
@Sumith1896
Oct 21 2015 14:58
As @certik said, we do test Cython version in FindCython.cmake
But we never mention the minimum version needed anywhere
Isuru Fernando
@isuruf
Oct 21 2015 16:33
I think adding the check setup_requires makes it a requirement when installing via pip.
Sumith Kulal
@Sumith1896
Oct 21 2015 16:33
That should do it for the Cython version
Do we need a check for the minimum Python version?
Isuru Fernando
@isuruf
Oct 21 2015 16:35
Yes
Sumith Kulal
@Sumith1896
Oct 21 2015 16:46
@isuruf I don't know how to test this https://github.com/symengine/symengine.py/pull/10/files
But I think this is the way to go
Isuru Fernando
@isuruf
Oct 21 2015 16:50

+1,

One option to test is, you can change,
https://github.com/symengine/symengine.py/blob/686bff8bbbb4945d0dc826b6ff7485bf164b46e2/bin/test_travis.sh#L9
to
pip install . --install-option="--symengine-dir=$our_install_dir"
and not installing Cython via conda.

But I don't like this method, because installing Cython via pip would be slower than via conda

Sumith Kulal
@Sumith1896
Oct 21 2015 16:57
I've branched off and pushed in for test in my Travis https://travis-ci.org/Sumith1896/symengine.py/builds
Let's see how it goes
One thing, we can't pip install symengine can we?
Isuru Fernando
@isuruf
Oct 21 2015 17:01
Nope. We'll upload to PyPI once we do a release 0.1.0
Sumith Kulal
@Sumith1896
Oct 21 2015 17:02
Cool