These are chat archives for symengine/symengine

6th
Jan 2016
Sumith Kulal
@Sumith1896
Jan 06 2016 08:33
Could you get me the stack trace?
@isuruf I needed a help
Isuru Fernando
@isuruf
Jan 06 2016 08:33
where?
Sumith Kulal
@Sumith1896
Jan 06 2016 08:34
The test for whitespace is not working
What I find weird is that locally that script gives an error(plus a print statement)
It is not happening on travis
Have any clue?
Specifically this line
Isuru Fernando
@isuruf
Jan 06 2016 08:37
Nope
Sumith Kulal
@Sumith1896
Jan 06 2016 08:38
We need to debug this asap
Isuru Fernando
@isuruf
Jan 06 2016 08:58
Maybe because your repo name is csympy?
Sumith Kulal
@Sumith1896
Jan 06 2016 09:10
Oh I never faced that issue. That shouldn't be the case.
Let me still rename.
Abhinav Agarwal
@abhinavagarwal07
Jan 06 2016 09:25
abhinavagarwal07/symengine#8
abhinavagarwal07/symengine#9
see the grep code to check trailing whitespace
it can be very easily extended to other checks also
Srajan Garg
@srajangarg
Jan 06 2016 09:56
@abhinavagarwal07 , it's working on local machine
That's not the issue
Abhinav Agarwal
@abhinavagarwal07
Jan 06 2016 13:08
@srajangarg you are correct.
Ondřej Čertík
@certik
Jan 06 2016 15:01
@Sumith1896 to debug this, check what Python version Travis is running (I noticed the script fails in Python 3) and then put a print statement at the top of the script and then put a print statement every other line into the script, until you find out which line fails.
Abhinav Agarwal
@abhinavagarwal07
Jan 06 2016 15:36
I think travis is running the script in wrong directory.
if that's the case:
we should rather pass $SOURCE_DIR via command line arg to python
Pradyot Prakash
@pradyotprakash
Jan 06 2016 18:34
Hi! The travis build for symengine/symengine#735 failed on mac due to some missing header files. How to fix this?
Akash Trehan
@CodeMaxx
Jan 06 2016 18:41
@pradyotprakash refer to #152 . I did some searching on this. I guess there is no link.h file for mac. I ran into the same problem with #736
Pradyot Prakash
@pradyotprakash
Jan 06 2016 18:54
Well I did was merge the master into my branch.
Akash Trehan
@CodeMaxx
Jan 06 2016 19:08
I guess some changes have been made to the Teuchos_stacktrace file.
Ondřej Čertík
@certik
Jan 06 2016 21:06
@pradyotprakash that's because you added the Teuchos_config.h in your PR, probably by a mistake. This file enables BFD (so you probably checked it in on your linux), which doesn't work on a Mac.
Just remove this file from your PR and things will start working.