Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Lorenzo Sanzari
@ulisse73
;-) great job.
Lorenzo Sanzari
@ulisse73
The version 2 of admingenerator is compatible with SF 2.7 version?

because I have a conflict:

[Symfony\Component\Debug\Exception\ContextErrorException]
Runtime Notice: Declaration of Admingenerator\GeneratorBundle\Command\GenerateAdminAdminCommand::updateRouting() should be compatible with Sensio\Bundle\GeneratorBundle\Command\GenerateBundleComm
and::updateRouting(Sensio\Bundle\GeneratorBundle\Command\Helper\DialogHelper $dialog, Symfony\Component\Console\Input\InputInterface $input, Symfony\Component\Console\Output\OutputInterface $outp
ut, $bundle, $format)

Restless-ET
@Restless-ET
not sure
it is for 2.6 for sure
Lorenzo Sanzari
@ulisse73
mmm, ok
Restless-ET
@Restless-ET
don't know if 2.7 deprectaions have already been fixed or not
seems like there's an open PR for that
Lorenzo Sanzari
@ulisse73
Probably not.
I've added you to the GeneratorBundle chat room
Lorenzo Sanzari
@ulisse73
The problem is that: generator use QuestionHelper as first paramenter of updateRouting(), Sensio bundle use DialogHelper
Restless-ET
@Restless-ET
I guess the problem is with your version of sensio/generator-bundle
is it 2.4?
'cause version 2.5 is already correct
Lorenzo Sanzari
@ulisse73
{
"name": "sensio/generator-bundle",
"description": "This bundle generates code for you",
"keywords": [],
"type": "symfony-bundle",
"license": "MIT",
"authors": [
{
"name": "Fabien Potencier",
"email": "fabien@symfony.com"
}
],
"require": {
"symfony/framework-bundle": "~2.2",
"symfony/console": "~2.0"
},
"require-dev": {
"symfony/doctrine-bridge": "~2.2",
"doctrine/orm": "~2.2,>=2.2.3",
"twig/twig": "~1.11"
},
"autoload": {
"psr-0": { "Sensio\Bundle\GeneratorBundle": "" }
},
"target-dir": "Sensio/Bundle/GeneratorBundle",
"minimum-stability": "dev",
"extra": {
"branch-alias": {
"dev-master": "2.4.x-dev"
}
}
}
Must I update it to 2.5?
Restless-ET
@Restless-ET
I believe so
as generator bundle uses "sensio/generator-bundle": "~2.4"
which should install version 2.5 since it's been released
Lorenzo Sanzari
@ulisse73
What generator, Sensio or your Admingenerator?
I try update to 2.5...
Restless-ET
@Restless-ET
sensio one
should be at version 2.5
Lorenzo Sanzari
@ulisse73

This is my application composer.json:

"require": {
"php": ">=5.3.3",
"symfony/symfony": "~2.7@beta",
"doctrine/orm": "~2.2,>=2.2.3,<2.5", "doctrine/dbal": "<2.5", "doctrine/doctrine-bundle": "~1.4", "symfony/assetic-bundle": "~2.3", "symfony/swiftmailer-bundle": "~2.3", "symfony/monolog-bundle": "~2.4", "sensio/distribution-bundle": "~3.0,>=3.0.12",
"sensio/framework-extra-bundle": "~3.0,>=3.0.2",
"incenteev/composer-parameter-handler": "~2.0",
"friendsofsymfony/user-bundle": "2.0.*@dev",
"knplabs/knp-menu-bundle": "~2",
"doctrine/doctrine-fixtures-bundle": "2.2.*",
"symfony2admingenerator/generator-bundle": "^2.0@beta"
},
"require-dev": {
"sensio/generator-bundle": "~2.5.0"
},
"scripts": {
"post-root-package-install": [
"SymfonyStandard\Composer::hookRootPackageInstall"
],
"post-install-cmd": [
"Incenteev\ParameterHandler\ScriptHandler::buildParameters",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installAssets",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::removeSymfonyStandardFiles",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::prepareDeploymentTarget"
],
"post-update-cmd": [
"Incenteev\ParameterHandler\ScriptHandler::buildParameters",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::buildBootstrap",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::clearCache",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installAssets",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::installRequirementsFile",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::removeSymfonyStandardFiles",
"Sensio\Bundle\DistributionBundle\Composer\ScriptHandler::prepareDeploymentTarget"
]
},
"config": {
"bin-dir": "bin",
"component-dir": "web/components"
},
"extra": {
"symfony-app-dir": "app",
"symfony-web-dir": "web",
"symfony-assets-install": "relative",
"incenteev-parameters": {
"file": "app/config/parameters.yml"
}
}
}

I have update now sensio generator at 2.5 version
but it was 2.4
How I can get the LATEST versio of SF2, and all its dependencies?
setting "dev-master" version, instead "~2.7@beta"?
Now, all works fine! (installation and commands)
I'll try to generate some example bundle
Restless-ET
@Restless-ET
use "symfony/symfony": "2.7.*"
Lorenzo Sanzari
@ulisse73
ok
Restless-ET
@Restless-ET
to get latest SF 2.7 stable release
Lorenzo Sanzari
@ulisse73
admin:admin-generate command doesn't works fine

c:\wamp\www\sfbase>php app/console admin:generate-admin

Welcome to the Symfony2Admingenerator

Create controllers for a generator module
Generator to use (doctrine, doctrine_odm, propel)
[0] doctrine
1 doctrine_odm
2 propel

0
Notice: Undefined index: doctrine
Generator to use (doctrine, doctrine_odm, propel)
[0] doctrine
1 doctrine_odm
2 propel

Doesn't recognize doctrine option
(ORM)
inserting 0
Restless-ET
@Restless-ET
Please refer that on the other chat room I've added you to
as that seems related with version 2 of the generator bundle
and might be someone in there with better insight on that issue
Lorenzo Sanzari
@ulisse73
Ok, sorry.
Restless-ET
@Restless-ET
no need to be sorry ;)
it's just that in the other room you might get more help regarding that
Lorenzo Sanzari
@ulisse73
It's true. :-)
Spinei Dionis
@spdionis
Hi, is this bundle under active development? In the description it says (old-legacy).
St├ęphane
@sescandell
Hi @spdionis ,
that one is not in active development. We merge PRs, but we are more working on that one: https://github.com/symfony2admingenerator/GeneratorBundle