Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 28 2019 22:15

    bobvandevijver on master

    Fixed documentation indentation… (compare)

  • Jan 28 2019 22:13

    bobvandevijver on master

    Fixed documentation indentation… (compare)

  • Dec 18 2018 14:45
  • Aug 29 2018 12:36
  • Aug 28 2018 06:49
  • Aug 01 2018 18:20

    tobias-93 on v2.5.1

    (compare)

  • Aug 01 2018 18:18

    tobias-93 on master

    Add choice_translation_domain t… (compare)

  • Jul 17 2018 05:55
  • Jun 26 2018 12:41
    snuffer82 commented #322
  • Jun 26 2018 08:38
    bobvandevijver closed #322
  • Jun 26 2018 08:38
    bobvandevijver commented #322
  • Jun 12 2018 09:50
    snuffer82 edited #322
  • Jun 12 2018 09:40
    snuffer82 opened #322
  • May 31 2018 08:38
    bobvandevijver closed #321
  • May 31 2018 08:38
    bobvandevijver commented #321
  • May 30 2018 18:45
    bobvandevijver labeled #321
  • May 30 2018 18:45
    bobvandevijver opened #321
  • May 28 2018 15:52

    bobvandevijver on v2.5.1

    (compare)

  • May 28 2018 15:43

    bobvandevijver on v2.5.1

    (compare)

  • May 28 2018 15:36

    bobvandevijver on 2.5.0

    (compare)

Serg N. Kalachev
@ksn135
"Interesting" warning from insight.sensionlab.com:
Public directory should not contain PHP files
MajorSecurity
Public directory web contains PHP file web/admin/components/admin-lte/plugins/datatables/extensions/Scroller/examples/data/ssp.php.
Bob van de Vijver
@bobvandevijver
@sescandell @loostro We've got some PR's from @tobias-93 which require us to update the dependencies to newer versions (Twig 1.12 and Symfony 2.7). I do not see a problem to upgrade the dependencies to the latest Symfony version (currently we have 2.2, which is no longer supported)
And Twig 1.12 is also old enough to be the minimum
So, what do you think?
Tobias Feijten
@tobias-93
The Symfony 2.7 part is for the FormExtensionsBundle only, the other bundles are up-to-date in this matter
i'm having a problem with this code, because the deletion is broken because of that
if i try to delete first item of collection, the last one gets deleted instead of the first one
Bob van de Vijver
@bobvandevijver
@matejvelikonja Which Symfony version are you using?
I remember something about a change in a select that might have to do with this (change is 2.7 .something and above)
Matej Velikonja
@matejvelikonja
2.7 yes
actaully 2.7.6
@bobvandevijver
Bob van de Vijver
@bobvandevijver
Okay, so you are probably affected, let me find the correct doc about this
Matej Velikonja
@matejvelikonja
please do
Bob van de Vijver
@bobvandevijver
Can you try the choices_as_values from https://github.com/symfony/symfony/blob/2.8/UPGRADE-2.7.md?
Matej Velikonja
@matejvelikonja
will check, thx
but this effects choices, and not collection type
Bob van de Vijver
@bobvandevijver
Hmmm, you're right
Does your collection also contain the ids as hidden fields, and if not, could you try that?
(I've never used the reorder thing by the way)
Matej Velikonja
@matejvelikonja
i don't use reorder thing also, but it's there in any case
Bob van de Vijver
@bobvandevijver
@loostro @sescandell I would like to suggest to add a parameter to enable exceptions here: https://github.com/symfony2admingenerator/GeneratorBundle/blob/master/Resources/templates/CommonAdmin/EditAction/update.php.twig#L96
I've got an exception handler which emails all details of an exception directly, which I am currently missing. And enabling the kernel.debug is a little to much
Stéphane
@sescandell
Hi everyone
I updated FormExtensionBundle to require at least Symfony2.8
with "a little" effort
we can be compatible with 2.7
do you thing we should make the effort to support 2.7 ?
/cc @bobvandevijver
Bob van de Vijver
@bobvandevijver
Well, if return method_exists(AbstractType::class, 'getBlockPrefix') ? FormType::class : 'form'; in the getExtendedType() is the only thing that needs to be added, I would say go for it
But, on the other side, the switch from 2.7 to 2.8 is not that large, and 2.8 is the latest LTS of the 2.x branch
Tobias Feijten
@tobias-93
@bobvandevijver you know that you then shift the PHP requirement to 5.5?
Bob van de Vijver
@bobvandevijver
Good call, but there is probably also a way around that :)
Tobias Feijten
@tobias-93
@sescandell any thoughts on #226 ?
Stéphane
@sescandell
Well, if return method_exists(AbstractType::class, 'getBlockPrefix') ? FormType::class : 'form'; in the getExtendedType() is the only thing that needs to be added, I would say go for it
actually, it's a little bit more than that: form aliases, using form type, ...

with "a little" effort

This is not anymore valid :)... it might be annoying

Stéphane
@sescandell
I know I introduced many BCBreak fo 2.8 and 3.0 compatibility. But the thing is: all these bundles are not (yet) released: I think we could so make these BC Break. I'm open to any discussion, let me know if you think all of this IS annoying
My objectives are to validate 2.8 & 3.0 compatibilty
then create released tags
(and bugfix / complete the documentation then)
Bob van de Vijver
@bobvandevijver
I'm okay with that
If anyone does not use 2.8 or higher yet, than they should fix that or use an older tag
Stéphane
@sescandell
:+1:
ioleo
@ioleo
Check out my new project https://github.com/loostro/cryptomute :) Travis tests are still failing, but only becouse I don't know how to install php_gmp on 5.4 and 5.5 (on travis).
@sescandell @bobvandevijver maybe you know how to install php_gmp on php 5.4 and 5.5?
Bob van de Vijver
@bobvandevijver
apt-get install php5-gmp?
Not sure how that works on Travis though
Bob van de Vijver
@bobvandevijver
Oh, it is an old ubuntu and with the apt-get you do install it, but for the wrong version...