Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • 17:23

    evan-miller-jumpmind on 3.14

    0003960: Mapped Oracle NVARCHAR… (compare)

  • 17:06

    evan-miller-jumpmind on 3.14

    0003961: Mapped Oracle XMLTYPE … (compare)

  • 15:03

    evan-miller-jumpmind on 3.14

    0003964: Mapped Oracle REAL typ… (compare)

  • 14:29

    evan-miller-jumpmind on 3.14

    0003966: Mapped Oracle CLOB and… Merge branch '3.14' of https://… (compare)

  • 14:25

    erilong on 3.14

    0005411: After installing Swagg… (compare)

  • 14:04

    erilong on 3.14

    0005410: Cancel load and some b… (compare)

  • 13:29

    evan-miller-jumpmind on 3.14

    0003965: Mapped Oracle LONG typ… (compare)

  • Aug 15 19:59

    evan-miller-jumpmind on 3.14

    0004191: Prevented dbexport fro… (compare)

  • Aug 15 19:08

    evan-miller-jumpmind on 3.14

    0003419: Prevented SQLite from … (compare)

  • Aug 15 18:48

    evan-miller-jumpmind on 3.14

    0004001: Added null check for p… (compare)

  • Aug 15 18:31

    evan-miller-jumpmind on 3.14

    0004001: Fixed newid() and news… (compare)

  • Aug 15 17:37

    erilong on 3.14

    add server migration to appendix (compare)

  • Aug 15 13:14

    evan-miller-jumpmind on 3.14

    0005408: Added hashCode() and e… (compare)

  • Aug 12 19:45

    evan-miller-jumpmind on 3.13

    0005405: Fixed sym_trigger_hist… (compare)

  • Aug 12 19:41

    evan-miller-jumpmind on 3.14

    0005406: Fixed sym_trigger_hist… (compare)

  • Aug 12 15:48

    evan-miller-jumpmind on 3.14

    0005399: Renamed loadCustomJobs… (compare)

  • Aug 12 15:34

    evan-miller-jumpmind on 3.13

    0005399: Renamed loadCustomJobs… (compare)

  • Aug 11 20:18

    evan-miller-jumpmind on 3.14

    0005399: Adjusted JobManager.lo… (compare)

  • Aug 11 19:55

    evan-miller-jumpmind on 3.13

    0005399: Adjusted JobManager.lo… (compare)

  • Aug 11 15:39

    philipmarzullo64 on 3.14

    0005398: Batch Locking issue wh… (compare)

joshahicks
@joshahicks
default is the main change capture channel unless you setup your own
This would mean you are not capturing changes on the source
if changes are occurring
dikum
@dikum
@joshahicks How can I capture the changes. I'm sorry, these weren't created by me. I just took over the system. So it's a bit confusing at the moment.
joshahicks
@joshahicks

You need to make sure you have valid configuration in sym_trigger, sym_router, and sym_trigger_router.

There is also a professional version that provides a web console for maintenance like this and full support. If that is something you might be interested in we can start a direct chat to discuss those options

dikum
@dikum
@joshahicks Thanks for your time. I'll look into what you've mentioned and get back.
Zalman Lew
@zalmanlew
What is the db.driver for MS SQL Server? Would it be com.microsoft.sqlserver?
Zalman Lew
@zalmanlew

I'm trying out the demo, trying to run

../bin/symadmin --engine corp-000 create-sym-tables

I'm getting an error

Exception in thread "main" java.lang.NoClassDefFoundError: Could not initialize class oracle.jdbc.OracleDriver

(corp-000 is using sybase drivers )

joshahicks
@joshahicks
@zalmanlew you need to install the Oracle module
symadmin module install oracle
Zalman Lew
@zalmanlew
@joshahicks thanks, I tried that but got an error
ERROR: Invalid module specified
joshahicks
@joshahicks
@zalmanlew the demo uses H2 by default you may need to remove your engines files and start clean. What database types are you trying to replicate
There is a pro free trial for 30 days that might help you walk through the connection setup if you are having issues creating the engine files on your own
joshahicks
@joshahicks
@zalmanlew also are you running Java 8 or higher
Zalman Lew
@zalmanlew
I managed to download the oracle drivers and got it working. Now I'm just having trouble connecting to my Sybase source.
I'm trying to connect Sybase >> MS SQL
Zalman Lew
@zalmanlew
I'm getting a Connection refused error; I'm able to connect to Sybase via the CLI and run commands
isql -Usa -P{pass} -S{server}
joshahicks
@joshahicks
have you tried a pure JDBC client like Squirrel or DBeaver
Zalman Lew
@zalmanlew
@joshahicks yep, same issue. I think I'm doing something wrong in my Sybase configuration - but no idea what.
Zalman Lew
@zalmanlew

@joshahicks I managed to get connected using DBeaver on my Mac (through an SSH tunnel). However I'm still getting the connection refused error when running the following command

../bin/symadmin --engine corp-000 create-sym-tables

this is the configuration of corp-000 (yes, the actual database name is databasename)

db.url=jdbc:sybase:Tds:localhost:5000/databasename
I was able to successfully connect using jConnect as well as jTDS from DBeaver
Zalman Lew
@zalmanlew
Worth noting that SymmetricDS is installed and being run locally (on the machine with the Sybase install)
Zalman Lew
@zalmanlew
@joshahicks after hours of messing around, I managed to get it working by changing the DB to listen on 127.0.1.1 instead of localhost (note the 1 instead of the common 0).

I'm facing an issue now when trying to create-sym-tables - it's giving an error

java.sql.SQLException: JZ0SB: Parameter index out of range: 1.

Any ideas?

Zalman Lew
@zalmanlew
Also, what is the official db.driver for SQL Server? Would it be com.microsoft.sqlserver?
joshahicks
@joshahicks
@zalmanlew we use to ship the JTDS driver but have swithched to the MSSQL one with the latest releases finding it faster and more stable
3 replies
Are you using SQL Anywhere for the other issues above by the way
1 reply
joshahicks
@joshahicks
Could you send us a log
1 reply
susana prado
@susanap23640384_twitter
Hola alguien sabe por que no puedo escoger master o node
joshahicks
@joshahicks
@susanap23640384_twitter ¿Te refieres a la consola web? Cambiamos la redacción. "Configurar nuevo .." = "Maestro" y "Unirse a existente..." = "Nodo".
susana prado
@susanap23640384_twitter
Al darle clic en Open Web Console la siguiente pantalla no me deja escoger master , o nodo , dice que existe un error inesperado
joshahicks
@joshahicks
Mire logs/wrapper.log y vea qué error está teniendo al iniciarse. El siguiente lugar para verificar es logs/symmetric.log.
adamitsch
@adamitsch
I am using android client example and get this error when trying to transfer data (MSSQL)
https://pastebin.com/VS5Q0pm6
adamitsch
@adamitsch
I have tried disabling monitor job but it didn't help
adamitsch
@adamitsch
on server it only keeps registering node and nothing else
jmckgenerali
@jmckgenerali:matrix.org
[m]
Hi, there seems to be a bug in SymmetricDS. I've installed the latest Pro version (trial) on an ubuntu VM. It doesn't let me connect to Oracle DB in Cloud using an oracle wallet. https://i.imgur.com/Ue0vERN.png
what could be the cause?
Oracle SQL Developer connects successfully (tried from my windows desktop):
jmckgenerali
@jmckgenerali:matrix.org
[m]
@zalmanlew:
adamitsch
@adamitsch
Screenshot from 2022-07-12 11-18-28.png
Jyoti D
@jyotid1815_gitlab
hi,
SymmetricDS is taking a lot of time to sync the data. I'm able to see in logs the data is in process to sync . In log it is showing data of last 3 to 4 days is still pending to sync. Please help me out.
1 reply
jmckgenerali
@jmckgenerali:matrix.org
[m]
I've created a bug report regarding the jdbc issue. It includes logs with stack traces.
joshahicks
@joshahicks
@jmckgenerali:matrix.org thank you for submitting the issue we are trying to release 3.14 so that has been the focus most recently but we will look at it soon
joshahicks
@joshahicks
@adamitsch it looks like an issue with Android or a class loading issue with apache commons jar. Once we get this 3.14 released we will try to take a look. Please let us know if you find anything on your side that fixes it
@jyotid1815_gitlab do you have any nodes offline? Nodes that are registered but not actually running or connecting? This would backlog the data. Also make sure routing and purge jobs are not throwing any errors in the logs. Do you have any batches in error
Jyoti D
@jyotid1815_gitlab
Nodes are not offline. There is no error in the logs. The outgoing batches showing the status NE.