Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Nicolas Brassard
    @nitriques
    Or somthing like RewriteRule ^sub_dir - [L]
    Manaus
    @Manaus
    Thanks @nitriques
    Nicolas Brassard
    @nitriques
    @Manaus Did it worked ?
    Juraj Kapsz
    @jurajkapsz
    Hi guys, I am almost done implementing Email Newsletter Manager (ENM) for the first time, everything's great, only I neglected the prerequisites in the beginning, which I am solving now. I came to the point in which I need to create a symlink to the mysql socket. I got the socket at disposal within the hosting - let's say /tmp/db.sock - but I don't know how should the symlink look like - I guess what name should it have, and where to create it on the hosting; so it would be picked up by the mysqli_connect. I am clueless about this... Have you solved this in the past and could you give me a hand with this?
    michael-e
    @michael-e
    Is this a webhost or a local install? On a webhost, this should not be necessary. Have you tested to connect?
    Juraj Kapsz
    @jurajkapsz
    @michael-e webhosting. I have found in logs Warning: GenericErrorHandler 2: mysqli_connect(): (HY000/2002): No such file or directory on line 355 of file .../symphony/lib/toolkit/class.mysql.php, after hitting Send from the newsletter entry and nothing was being done. So I thought I have to create that symlink mentioned in ENM docs. But maybe this is caused because I had to put a path to the php executable so the php example header('Content-Type: text/plain'); echo shell_exec('php -v'); as one of the prerequisites would work, like header('Content-Type: text/plain'); echo shell_exec('/usr/php56/bin/php -v')? I ahve hardcoded that path into the php as of now, but probably I could create a symlink on that php executable...
    @michael-e I was told by the webhosting support I have to use that path with the "php" command in order to work.
    And afterwards it did work, I get returned php -v info
    @michael-e and sorry, what do you mean to test to connect? to the given mysql socket? And I would do that through a php script? I am bit lost in this..
    Juraj Kapsz
    @jurajkapsz
    On local install I did not tried to send e-mails. I uploaded the project on webhosting server were it will be run to test that step.
    Juraj Kapsz
    @jurajkapsz
    @michael-e DAMN I got it. I messed up with the config.php database settings... ah, facepalm once again. Thanks very much Michael. It works now.
    michael-e
    @michael-e
    OK, great!
    Manaus
    @Manaus
    @nitriques well not really, managed to adapt the line to my case, but I get still a 'mod_rewrite is not enabled' error. Gotta study better the htaccess syntax
    Nicolas Brassard
    @nitriques
    :(
    Phill
    @pixelninja
    Anyone using MySQL 8? I'm getting SQL syntax errors after Homebrew updated :(
    Phill
    @pixelninja
    Specifically the query starting on line 59 of symphony/lib/toolkit/class.extensionmanager.php
    This message was deleted
    screenshot
    Nicolas Brassard
    @nitriques
    @pixelninja SQL_CACHE is deprecated
    Phill
    @pixelninja
    ahhh brilliant, thanks @nitriques
    Manaus
    @Manaus
    Hello I'm stuck with Duration Field, I'd need to use some field for adding time and I guess this field could be the one, this is the error page I get when migrating to 2.7.6 https://cloudup.com/cFV3_hxSU7B/f
    (I could evaluate also paid intervention, in case)
    I don't understand a heck of OO-php :smile:
    Nicolas Brassard
    @nitriques
    @Manaus looks like a problem with how the field is being set
    on what Symphony were you before the upgrade ?
    Manaus
    @Manaus
    It was something like 2.3.x...
    without x actually, so it's 2.3
    Nicolas Brassard
    @nitriques
    oh boy that's old
    after line 85
    add
    $crtDurSettings = is_array($crtDurSettings) ? $crtDurSettings : array();
    Manaus
    @Manaus
    :)
    Nicolas Brassard
    @nitriques
    does it works ?
    Manaus
    @Manaus
    I'd say, gotta test it thoroughly but I get no more errors in the admin
    Thanks!
    Oh too earl victory, raising an error on adding a new duration field on a section
    Nicolas Brassard
    @nitriques
    @Manaus I cannot say if this is related to the Duration field or not
    it looks like the data in the database is not ok
    Are you able to re-save the section ?
    Phill
    @pixelninja
    Hello Symphony enthusiasts. I recently moved a site to a new server, and now the ordering/filtering is misbehaving. I can't order entries within Symphony by a date field, and the entries on the frontend which are being ordered by the same date field are not displaying correctly either. Anyone encountered this before?
    mysql 5.5.60, php 5.5.9
    The main difference is I'm using the cachelite plugin, so I wonder if this effects it at all... page has been excluded and cache has been flushed.
    Phill
    @pixelninja
    Oh and Symphony 2.7.0, Cachelite 2.1.1
    Nicolas Brassard
    @nitriques
    @pixelninja are you able to save the config.php file via the backend ? looks like the file is not writable
    Also, update your datefield to the latest version
    finally, cachelite should not be an issue for the backed
    Jonathan Mifsud
    @jonmifsud
    concur with @nitriques that’s a common issue when we put the config as a read-only on production. We have been going around it through an extension which stores this on a per user basis. (we don’t want our production configs to be writeable in 99% of cases)
    Phill
    @pixelninja
    Hi @nitriques and @jonmifsud, Yes the config is writeable. The config file wouldn't effect the front end would it? The datasource output is being effected too which is very weird. I'm not sure if it's date field specific as all table fields won't reorder (which would definitely suggest the config.php, but I can definitely save to it).