Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Nicolas Brassard
    @nitriques
    Are you able to re-save the section ?
    Phill
    @pixelninja
    Hello Symphony enthusiasts. I recently moved a site to a new server, and now the ordering/filtering is misbehaving. I can't order entries within Symphony by a date field, and the entries on the frontend which are being ordered by the same date field are not displaying correctly either. Anyone encountered this before?
    mysql 5.5.60, php 5.5.9
    The main difference is I'm using the cachelite plugin, so I wonder if this effects it at all... page has been excluded and cache has been flushed.
    Phill
    @pixelninja
    Oh and Symphony 2.7.0, Cachelite 2.1.1
    Nicolas Brassard
    @nitriques
    @pixelninja are you able to save the config.php file via the backend ? looks like the file is not writable
    Also, update your datefield to the latest version
    finally, cachelite should not be an issue for the backed
    Jonathan Mifsud
    @jonmifsud
    concur with @nitriques that’s a common issue when we put the config as a read-only on production. We have been going around it through an extension which stores this on a per user basis. (we don’t want our production configs to be writeable in 99% of cases)
    Phill
    @pixelninja
    Hi @nitriques and @jonmifsud, Yes the config is writeable. The config file wouldn't effect the front end would it? The datasource output is being effected too which is very weird. I'm not sure if it's date field specific as all table fields won't reorder (which would definitely suggest the config.php, but I can definitely save to it).
    I'm not much of a MySQL dev, would there be some compatibility issue with Symphony's sortable function perhaps?
    Jonathan Mifsud
    @jonmifsud

    @pixelninja no the config shouldn’t impact datasources at all.

    What error do you get in the datasource?

    Phill
    @pixelninja
    There is no error, it pulls through entries correctly but the sort order is ignored
    Phill
    @pixelninja
    But it's just the sort order. Datasources can be filtered fine, and entries within Symphony can be filtered fine.
    So it must be something in the Symphony sortable class right?
    Manaus
    @Manaus
    @nitriques Hi (sorry for the delay), I can resave the section if the field is not present, but I get the error otherwise...
    Nicolas Brassard
    @nitriques
    @pixelninja does the sort works if you delete all sorts from the config file ?
    @Manaus looks like the field is not working with the new Symphony and needs upgrading
    Phill
    @pixelninja
    It starts writing to the config correctly again but it's just not displaying correctly
    it's really weird. I'm stumped.
    Nicolas Brassard
    @nitriques
    @pixelninja I meant, editing the file manually and remove all the 'sorting' values
    Phill
    @pixelninja
    Yep that's what I did. Deleted it from the config file completely, and then tried to sort again in the backend and it wrote to the config file correctly.
    I don't get how the sort order in the config file correlates to the sorting of entries in a datasource though
    are they linked somehow?
    Nicolas Brassard
    @nitriques

    I don't get how the sort order in the config file correlates to the sorting of entries in a datasource though

    Yes they are if you do not specific a sort order, EntryManager will default to what's in the config file

    @pixelninja I was not under the impression that sorting was working AT ALL. But it works in the Backend but not in a DS ?
    Juraj Kapsz
    @jurajkapsz
    Hi guys, is there a way to "cid" embed an image with ETM? I am creating an ETM template with an email signature which includes a company logo. Currently I have the logo hosted (linked as external image), but thinking about to have it embedded inline using the "cid" way.
    michael-e
    @michael-e
    There has been a pull request and a longer discussion about adding the Content-ID header on attachments in the Symphony core: symphonycms/symphony-2#2617 — but as far as I know, it has only been pulled into the Symphony 3 branch.
    Juraj Kapsz
    @jurajkapsz
    Awesome, thanks @michael-e ! Speaking of developing email contents in general, it's a world of pain to do something elegantly there, but in the recent time I've settled with mjml and I would say it's quite nice to work with that.
    michael-e
    @michael-e
    Thanks for the tip, @jurajkapsz . How do you work with MJML? Do you just develop your HTML templates using MJML? Or do you create MJML code dynamically, then parse it to HTML for every single email? (I still write all email code manually — when I started with the web, table-based layouts were the only way to go, so I still remember how to do it.)
    Juraj Kapsz
    @jurajkapsz
    @michael-e Yes, it's still a matter of juggling with tables. I am using the official MJML App along with looking into the mjml language docs to create a mjml template of my own and generating the html from it. This is very convenient to do I would say.
    Then comes the tricky part, where my thug life ends, but I dig xslt so no problems there - to mariage the html with ETM's xslt email template, because there are quite a few condition statements in that html generated from mjml. But in the mean time I have those statements paired with corresponding xslt code that generates the same html output. I could share those snippets if you like.
    Finally, if I take some content from Symphony for the email content (usually a html - I use CKEditor for creating richtext content in Symphony; I know you guys prefer Markdown I think), I chew it with a xslt template to get a html that would mjml generate (and plain text alike for the plain text mail version). I can share that template too.
    Speaking of developing mjml, there are also other ways besides using the App, as mentioned in the docs, for example using nodejs/gulp (I am using nodejs, gulp, webpack etc. in every project for building my frontend assets), but I use the App for now, as I don't develop emails so often.
    michael-e
    @michael-e
    Thanks for sharing your workflow, I was simply curious. At the moment I won't change anything in my email stuff, so there's no need to see your templates; but thank you anyway!
    Juraj Kapsz
    @jurajkapsz
    You're welcome! Basically I switched from writting my own email template stuff from the scratch and testing it through Litmus or Email on Acid, to using a this-works-everywhere solution, which I hope MJML is. Anyways it's a MailJet project. But recently I've learned it still pays off to have a peak on final email template in various email clients.
    millie33
    @millie33
    I just installed Symphony and don't get an admin interface just a directory listing
    Wannes Debusschere
    @wdebusschere
    Do you get the website?
    Whats in your htaccess?
    Junior Lima
    @juniorlimajj
    Maybe rewrite mod?
    Wannes Debusschere
    @wdebusschere
    :+1:
    Ronald Vargas
    @RonVargas01
    Hi guys, I have a site that I'm optimizing for SEO built with symphony and I am unable to give a different title tag to each page they seem to be connected somehow. If anyone knows of an extension or has a useful resource I would appreciate it. Thanks
    Nicolas Brassard
    @nitriques
    @RonVargas01 Hi! You can try to change the page name in the CMS. If you want the title to be edited in the content, you need a simple field for that
    Jonathan Mifsud
    @jonmifsud
    @RonVargas01 it depends how it was set up. There’s a good chance that you have no SEO Fields created/set-up
    Assuming you want to do Meta and all you may need a developer to have a look and make the necessary tweaks so you could do all you need from the CMS
    Ronald Vargas
    @RonVargas01
    Ok thanks guys, I'm unable to get in touch with the dev so that might take a while. Does anyone have any resources or articles that would help to set up those SEO feilds, I normally work with Wordpress and magento and I've been looking but there don't seem to be many resources other than the main site.
    Jonathan Mifsud
    @jonmifsud
    @RonVargas01 no there aren’t much; usually depending on the structure you would create fields within an existing data section OR a separate section where the SEO fields go in. I’ve seen both approaches used. Unfortunately I don’t have it well documented from my end.
    If the Dev is completely unavailable ping us back - maybe someone can help you get it set up if you have the right access.
    Ronald Vargas
    @RonVargas01
    @jonmifsud Thanks for you help. I'll try to contact the dev again and hopefully get that set up.
    Ronald Vargas
    @RonVargas01
    image.png
    Hi I am back with the same issue as yesterday I was unable to get in touch with the dev and I am unable to give a different title tags and meta descriptions to each page and I am also unable to get a text module to appear on site I see this error every time
    Andrew Minton
    @andrewminton
    Are you uploading files to the site via FTP?
    Nicolas Brassard
    @nitriques
    @RonVargas01 that's a server configuration issue