Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Jan 31 2019 21:29

    nitriques on 3.0.x

    Redirect loggued in users to AP… Add documentation about unambig… Allow numeric values in schema … (compare)

  • Jan 29 2019 19:40
    timokleemann commented #2861
  • Jan 28 2019 10:50
    animaux commented #2574
  • Jan 25 2019 18:25
    nitriques commented #2865
  • Jan 25 2019 18:23
    wdebusschere closed #2865
  • Jan 25 2019 18:23
    wdebusschere commented #2865
  • Jan 25 2019 18:09
    nitriques commented #2865
  • Jan 25 2019 18:09
    nitriques commented #2865
  • Jan 25 2019 18:07

    nitriques on 3.0.x

    Avoid double insert (write) exe… (compare)

  • Jan 25 2019 18:07
    nitriques closed #2882
  • Jan 25 2019 18:06
    nitriques milestoned #2882
  • Jan 25 2019 18:06
    nitriques labeled #2882
  • Jan 25 2019 18:06
    nitriques assigned #2882
  • Jan 25 2019 18:06
    nitriques review_requested #2882
  • Jan 24 2019 22:06
    wdebusschere commented #2865
  • Jan 24 2019 21:58
    wdebusschere commented #2865
  • Jan 24 2019 21:10
    nitriques commented #2865
  • Jan 24 2019 20:33
    wdebusschere commented #2865
  • Jan 24 2019 20:33
    wdebusschere commented #2865
  • Jan 24 2019 17:57
    nitriques commented #2865
Wannes Debusschere
@wdebusschere
We could use a fork to start
Peter Skirenko
@petertron
Has anyone used my fork of Symphony 3?
Alexander Rutz
@animaux
Haven’t tried it yet.
cylkee
@cylkee
I can try it @petertron. Are specific tests I need to run, extensions to install, or just use it until it breaks?
Juraj Kapsz
@jurajkapsz
Hey guys, anyone using JIT with webp / has a webp JIT version? Or had tried and failed?
Juraj Kapsz
@jurajkapsz

Hey guys, anyone using JIT with webp / has a webp JIT version? Or had tried and failed?

It looks like with very little changes the JIT extension works just great with WEBP images. Awesome.

Alexander Rutz
@animaux

Hey guys, anyone using JIT with webp / has a webp JIT version? Or had tried and failed?

It looks like with very little changes the JIT extension works just great with WEBP images. Awesome.

Nice, you could send a PR … if only somebody would/could approve it. Which illustrates our current Symphony infrastructure dilemma.

Juraj Kapsz
@jurajkapsz

Hey guys, anyone using JIT with webp / has a webp JIT version? Or had tried and failed?

It looks like with very little changes the JIT extension works just great with WEBP images. Awesome.

Nice, you could send a PR … if only somebody would/could approve it. Which illustrates our current Symphony infrastructure dilemma.

Sure, I will do some more tests, these were just some quick tweaks. The repos I think we figure out, I think it's all great.

Peter Skirenko
@petertron
@cylkee There is nothing specific to do. It is there for anyone who wants a useable version of Symphony 3. You are welcome to test it thoroughly.
pavelradvan
@pavelradvan
@petertron Hi i could also do testing...where it is available?
pavelradvan
@pavelradvan
@petertron I see it is here https://github.com/petertron/symphonycms
pavelradvan
@pavelradvan
@petertron How to install it ? There is no /vendor directory...I need to install by old way...
Peter Skirenko
@petertron
@pavelradvan With Symphony 3 the vendor directory is deliberately left out because it is not meant to be under version control. Generate the vendor directory with "composer install".
Moritz Profitlich
@mprofitl
22 sites (single installations) plus 3 in the making. Currently talking to people about Node.js/Express and Craft CMS but still very much into Symphony CMS.
Wannes Debusschere
@wdebusschere
Craft cms is really great but not so fast to set up
Alexander Rutz
@animaux
@petertron just tried an update from v2.7.x to your v3-fork, but I get some errors after regular update procedure:
2021-02-15T14:25:35+01:00 602a76 > Fatal Error: SymphonyException 0 - 0: could not find driver on line 658 of /…/symphony/lib/core/class.symphony.php
2021-02-15T14:25:53+01:00 602a76 > Fatal Error: SymphonyException 0 - 0: could not find driver on line 658 of /…/symphony/lib/core/class.symphony.php
2021-02-15T14:26:02+01:00 602a76 > Notice: ErrorHandler 8: Trying to access array offset on value of type null on line 264 of file /…/symphony/lib/toolkit/class.lang.php
2021-02-15T14:26:03+01:00 602a76 > Notice: ErrorHandler 8: Trying to access array offset on value of type null on line 264 of file /…/symphony/lib/toolkit/class.lang.php
2021-02-15T14:26:20+01:00 602a76 > Fatal Error: SymphonyException 0 - 0: could not find driver on line 658 of /…/symphony/lib/core/class.symphony.php
2021-02-15T14:26:27+01:00 602a76 > Fatal Error: SymphonyException 0 - 0: could not find driver on line 658 of /…/symphony/lib/core/class.symphony.php
2021-02-15T14:26:29+01:00 602a76 > Fatal Error: SymphonyException 0 - 0: could not find driver on line 658 of /…/symphony/lib/core/class.symphony.php
Alexander Rutz
@animaux
I meant to say, after copying the regular files/folders to the old version.
Alexander Rutz
@animaux
No idea what’s going on there :(
Wannes Debusschere
@wdebusschere
@animaux I think i also encountered this
see if you have this
        'query_caching' => 'off',
        'query_logging' => 'off',
Alexander Rutz
@animaux
@wdebusschere in config.php? Seems no.
Alexander Rutz
@animaux
In the DB settings?
Peter Skirenko
@petertron
@animaux I have taken a look at the code involved. I don't know exactly what is going on.
Alexander Rutz
@animaux
@petertron thanks, I’m lost there too.
Sadie
@Sadie

I posted on 1/26/2021 requesting help with a site I did not develop running Symphony 2.6.1 and PHP 7.4, which @wdebusschere kindly and quickly pointed out is an incompatible combination. He also suggested updating might be easy.
Since that time, I've managed to go around the webhost's Control Panel and reinstate PHP 5.6 using .htaccess, so at least the site is up and running. I am now creating a plan to update to Symphony 2.7.10 so that PHP 7.3 (or 7.4) can be used. I have no Symphony experience, whatsoever, but have upgraded other CMS's, mostly Mura and Wordpress. I see no evidence that GIT was used in the past; I will be manually updating folders/files. I am planning to apply the upgrade(s) to a clone of the current site and database and am seeking your experienced input as to the best approach to this upgrade.

  • Should I attempt to upgrade from 2.6.1 to 2.7.10? Or upgrade one release at a time?
  • Is it proper to update the core first, then the extensions? (Image with extensions attached, some very outdated, I know.)
  • I have no idea how much, if any, customization the original developers did. Is there a specific place I should look for customizations?

alt

Thank you in advance for your thoughts and assistance.

Wannes Debusschere
@wdebusschere
@Sadie You have a lot of extensions, and some are old
= it will take some time to check all, update the php code
Try it in a test environment..
you can update symphony from 2.6.1 to 2.7.10
try core, then extensions
customizations: custom events or datasources? should not cause problems, maybe some php 7.. warnings
Sadie
@Sadie
@wdebusschere Thanks for the quick response. Yes, custom events. OK, I'll give it a go.
Peter Skirenko
@petertron
@animaux The error message "could not find driver" does not exist in the core, which means it must be coming from an extension.
Jason Anderson
@Jander76_gitlab
Hello, I was directed here to get an account for symphony
Alexander Rutz
@animaux
@Jander76_gitlab if you’re looking for an account on getsymphony.com and are interested in the Symphony CMS (not Symfony Framework), I can help you ;)
Alexander Rutz
@animaux

@animaux The error message "could not find driver" does not exist in the core, which means it must be coming from an extension.

Thanks, I’ll search for it!

It’s not in any of the extensions either. Maybe it’s a composite message?
Bildschirmfoto 2021-02-17 um 16.49.06.png
Peter Skirenko
@petertron
@animaux "could not find driver" is a PDO exception.
Alexander Rutz
@animaux
AH! So it might be a conflict with the mySQL strict mode?
Peter Skirenko
@petertron
@animaux I don't see how strict mode would make a difference in this case.
Alexander Rutz
@animaux
OK, I’m just guessing at this.
Alexander Rutz
@animaux
Problem is, I can’t go in to deactivate any extensions, since it wont even let me log in.
Alexander Rutz
@animaux
I guess it’s easier to test 3.0.0 on a system built from scratch. But the prospect of plenty of not-running-extensions makes me rather wish for a bug-patched and PHP8-compatible 2.7.x version. Of course most extensions would need some tweaks too, but a lot less.
Wannes Debusschere
@wdebusschere
You can deactivate an extension in the db
Alexander Rutz
@animaux
Ok, that might be worth a try.
Alexander Rutz
@animaux
disabling all the extensions doesn’t change a thing :(
Sadie
@Sadie

This is a continuation of my Feb 16, 2021 post.

I have successfully updated a clone of the site and its db from Symphony 2.6.1 to Symphony 2.7.10, and under PHP 5.6, I am able to view both the front- and back-ends of the updated site. All extensions have been updated to the extent possible.

Two issues noted on the backend under PHP 5.6:
Under System > Preferences, I get "Symphony Fatal Error: Could not find Email Gateway. If it was provided by an Extension, ensure that it is installed, and enabled." The default gateway is defined as sendmail in /manifest/config.php. [The cloned site is in a subfolder of the live site, so maybe a path issue, but I can't find it.]

alt text

Under System > Sitemap, I get "Symphony Warning: array_pad() expects parameter 1 to be array, string given."

alt text

Under PHP 7.3, I disabled the CKEditor and Import/Export CSV extensions, which seem incompatible wtih PHP7. I can log in and view the back-end, with the same issues described above, except that System > Sitemap generates a Breadcrumb error "Declaration of datasourceBreadcrumb::grab(&$param_pool) should be compatible with Datasource::grab(?array &$param_pool = NULL)" I get the identical Breadcrumb error when trying to view the front-end under PHP 7.3.

alt text

Of all these, the Breadcrumb issue seems the biggest stumbling block. The Breadcrumb extension was one of the few that had no updates. Unfortunately, it is integral to the site.

I appreciate anybody's thoughts and advice about any of these issues.