These are chat archives for sympy/sympy/optics

28th
Jun 2014
Sudhanshu Mishra
@debugger22
Jun 28 2014 02:05
There's something weird in the SymPyDeprecationWarning message
>>> from sympy.physics.gaussopt import *
sympy/physics/gaussopt.py:11: SymPyDeprecationWarning: 

Module sympy.physics.gaussopt has been deprecated since SymPy 0.7.6.
Use sympy.physics.optics.gaussopt instead.

  deprecated_since_version="0.7.6").warn()
>>>
Last line, deprecated_since_version="0.7.6").warn(), shouldn't be there.
Am I right?
Aaron Meurer
@asmeurer
Jun 28 2014 18:31
that’s just what the warnings module does
it shows the line of code that initiated the warning
in this case, it is line wrapped, so you only see the last bit with the warn() call