Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    justin.xie
    @caihemm
    @claudio4j_twitter I solved it with text convert extent for save json to ftp
    c5d
    @c5d
    hi guys - does AtlasMap support access to camel exchange properties? For example, is there a way to set exchangeId on a target object in data mapper?
    Lina Avendano
    @lina2358
    Unfortunately I'm lacking the java skills to submit a patch: syndesisio/syndesis#8920 - it should be dead easy to support recursiveness here....
    David Arnold
    @blaggacao
    Hi guys, I plan to implement a https://skaffold.dev base deployment workflow for syndesis, I hope everyone's fine with me leading the charge here... (somewhat)
    There will be a few simplifications required, I hope you bear with me...
    First blocking issue is that the operator binary build is going through the local filesytem. That's blocking a whole lot of stuff, aside from being incompatible with skaffold - unless I replay all bash scripts which defies the idea of simplification.
    Please help me out and do a quick review on: syndesisio/syndesis#8941
    @phantomjinx I hope we can kind of do a "async remote sprint light", I'm going to plow through it in the following days.
    justin.xie
    @caihemm
    Hi
    I have create a csv extension
    and create a pull request
    Claudio Miranda
    @claudio4j_twitter
    Hi @caihemm I will review your PR, thanks for the contribution
    @blaggacao, @phantomjinx is away and will come back only on Aug/31
    I will take a look on your PR next week
    DavHau
    @DavHau

    Hello guys. I'm trying to setup syndesis now for several days already without success.
    If I undestand the documentation correctly, a simple:
    ./tools/bin/syndesis minishift --install --open --nodev
    should lead me to a working installation of syndesis.
    After installation I'm able to reach the syndesis web interface, in my case via https://syndesis-myproject.192.168.42.163.nip.io/.
    The browser console is full of errors. For example:

    1. Strict-Transport-Security: The connection to the site is untrustworthy, so the specified header was ignored.
    2. Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://solution-explorer.192.168.42.163.nip.io/services

    I'm able to make a connection to google sheets under Connections. But as soon as I go to integrations and click on the google sheets button, nothing happens.
    In the browser console appears: Uncaught DOMException: The quota has been exceeded. main.88762cbc.chunk.js:1

    Help is much appreciated. Thanks!

    Claudio Miranda
    @claudio4j_twitter
    @DavHau what is the pods states oc get pods ?
    Also, is there any error on syndesis-server pod log ?
    Jarry
    @MingningShao
    hi team, how do you define the process(integration logic, flows) between different connectors ? Please tell me the source module. Thanks!
    DavHau
    @DavHau

    when starting syndesis via minishift I already get errors like:

    Cannot find command for opening URL:
    https://syndesis-myproject.192.168.42.163.nip.io
    ERROR: Failed to extract oc to /root/.syndesis/oc-v3.11.0-y2xr/

    If I use the oc binary from openshift and execute oc get pods is get:
    error: the server doesn't have a resource type "pods"

    Thanks for trying to help me, but you don't need to put any more time into it. I'm about to switch to open integration hub.
    To be honest , I don't have high hopes in the maintainability of a system if the setup is that complicated and such error prune.
    Maybe I was unlucky, but a quick glance inside the bash scripts tells me that there is a lot of code with the sole purpose of fighting against environmental differences.
    This is always a bad sign and means that there are tons of people with a lot of different problems.
    Despite all the code it fails in many different ways. I tried on different distros,. Even on debian it didn't work.

    If I would be asked for my opinion, I would propose to really base as much of the project (at least the dev environment) on nix. It is currently the only technology that allows reproducible environments without the need of virtualization layers. As one can see here, there are a lot of problems which cannot be solved by virtualization.

    If all devs work with the same environment you can get rid of 80% of bash scripts. You don't need any more code to fight against the differences is there are none.

    Alexey Rusakov
    @arusakov-rh
    Hi all - how much is https://syndesis.io/docs/development_quickstart/ up-to-date with respect to running without Kubernetes/OpenShift?
    c5d
    @c5d
    hi guys - im running into an issue when API provider has 20+ operations/flows. It looks like that may be a browser session limit? Im seeing it in chrome browser, but safari doesn't seem to have the same limitation... In safari though I don't see the data mapper option working... Any thoughts or ideas? 2.3938c1d8.chunk.js:102 Uncaught DOMException: Failed to execute 'setItem' on 'Storage': Setting the value of 'p3xczu' exceeded the quota.
    Claudio Miranda
    @claudio4j_twitter
    Hi @c5d , I have seen some connectors requires additional browser storage space, in firefox, the property is dom.storage.default_quota
    c5d
    @c5d
    @claudio4j_twitter that's good to know. let me try firefox. it looks like in chrome its fixed storage limit and cannot be increased.
    c5d
    @c5d
    One other issue i ran into is w/ syndesis server pod (1 Gi) running into OOM. Inspecting heap dump it looks like majority of objects are dao/LRU objects. It appears that on /api/v1/integrations call all data gets loaded from jsondb that includes all flows, steps, etc for each integration defined. I have several rest heavy rest/swagger integrations running. Bringing all that data seems to be putting pod into OOM condition. Perhaps one option is to only load basic information for each integration on /integrations page and pull in the details once we drill down/select each integration. Is this a known limitation or am I missing something?
    c5d
    @c5d
    what I am seeing is very similar to syndesisio/syndesis#5167
    Brett
    @bwburch
    Anyone have solution for this issue? https://syndesis-syndesis.192.168.42.168.nip.io
    The route is not accepting traffic yet because it has not been admitted by a router. I've added to /etc/hosts 192.168.42.168 192.168.42.168.nip.io syndesis.192.168.42.168.nip.io docker-registry-default.192.168.42.168.nip.io
    8 replies
    Stephen Newport
    @snoop244_gitlab
    Hi, evaluating the Debezium connector. We are using Debezium as a bridge between a SQL Server legacy application and a new microservices-based platform. The new platform is under development. Since Debezium seems to capture DB changes to topic-per-table, merging the topics back into a single topic is proving to be a major pain and is consuming way too much developer time (trying to do it KSQL/Streams). Could Syndesis help here? Specifically, could Syndesis (or AtlasMap) allow a trained Business Analyst to view the schemas of, say, 50 topics that come out of Debezium CDC and map it to a single Kafka topic? The blog post on the Connector maps a single topic to a single topic. I guess this would require the ability to automatically pull the schemas for the 50 topics on the source side of the AtlasMap so that they could be mapped to the schema on the Target side. We can convert our Avro schemas to a JSON-schema format, if that is required. Thx.
    Fuad Haque
    @fuadhaque
    Hi, everyone. Need to write a custom camel component and a "connector " extension for it. What is the recommended way? Build + deploy syndesis with the custom component first and then import the connector-extension jar OR include both the component and the connector-extension in the jar and import it in a running syndesis instance?
    5 replies
    rahul-sharma-js
    @rahul-sharma-js

    How can I connect to Kafka which is not hosted in same cluster as syndesis. Lets say I want to connect to cloudkafka.com kafka instance using below details. How can I do that?

    Username: xxxxxx
    Password: yyyyyy
    Topic prefix: hqwr3qei-
    Servers: tricycle-01.srvs.cloudkafka.com:9094, tricycle-02.srvs.cloudkafka.com:9094, tricycle-03.srvs.cloudkafka.com:9094

    There is no option to enter username and password in syndesis kafka connector

    rplescia
    @rplescia
    Are there any clear step-by-step instructions for setting up syndesis on RedHat CRC? All the documentation seems to be written for minishift which is effectivly obsolete.
    8 replies
    Alexander Haslam
    @indiealexh
    I can't seem to get Syndesis to run on CRC on Windows. Anyone have any instructions for that?
    3 replies
    Anand Kane
    @anandkane
    I do not find a 'file component' in Syndesis. I want to try out a simple integration, which copies a file from a source folder into a target folder. For that, I will have to open a connection to the file system. However, I do not find anything corresponding to the Camel 'file component' in Syndesis. In fact, I do not see most of the Camel components in Syndesis. Can someone please guide me on how to use the 'file component' in Syndesis? Will I have to create a connector extension?
    3 replies
    Rahul Tripathi
    @RahulTr98733570_twitter
    Hi...how can I connect LDAP application using syndesis
    1 reply
    there is no LDAP connector provided