These are chat archives for systemjs/systemjs

9th
Feb 2015
Mark Stickley
@markstickley
Feb 09 2015 14:00

Hiya, I'm using the same config in builder as I do in my app but I'm getting slightly different results...

...
    "meta": {
        "lib/angular@1.2.8-alpha-1/angular": {
            "exports": "angular"
        },
        "lib/angular@1.2.8-alpha-1/angular-resource": {
            "deps": [
                "lib/angular/angular"
            ]
        },
        "lib/angular@1.2.8-alpha-1/angular-cookies": {
            "deps": [
                "lib/angular/angular"
            ]
        },
        "lib/angular@1.2.8-alpha-1/angular-route": {
            "deps": [
                "lib/angular/angular"
            ]
        },
        "lib/angular@1.2.8-alpha-1/angular-animate": {
            "deps": [
                "lib/angular/angular"
            ]
        },
        "lib/angular@1.2.8-alpha-1/angular-sanitize": {
            "deps": [
                "lib/angular/angular"
            ]
        }
    },
    "versions": {
        "lib/angular": "1.2.8-alpha-1"
    }
...

Here when trying to resolve lib/angular/angular it almost gets it but not quite: lib/angular@1.2.8-alpha-1/angular.js. Of course it should be lib/angular/1.2.8-alpha-1/angular.js. It works fine when loading the app though! Seems a bit odd, has anyone else seen anything similar?

Mark Stickley
@markstickley
Feb 09 2015 15:53
Don't worry I've figured out what was going on - we were doing a server-side rewrite changing the @ to a -
Matthew James Davis
@davismj
Feb 09 2015 22:21
hey all, i have an open question on stackoverflow that i've opened a bounty on that probably involves systemjs
if you could take a look that would be awesome!