These are chat archives for systemjs/systemjs

1st
Jun 2015
matthew harwood
@matthewharwood
Jun 01 2015 01:26
when you say "top Level" what would be example of "bottom Level" or how should I mentally visualize this? If this makes no sense either I'm sorry. lol
Jami Pekkanen
@jampekka
Jun 01 2015 18:17
Is there a way to "revert" to the old default behavior of automatically appending the .js-suffix for some paths?
I'm trying to use system-npm with the master version and it can't find it's relative dependencies now
I have "system-npm/": "node_modules/system-npm/.js" in System.paths, but this doesn't seem to affect the relative requires (eg require("./npm-utils") within the system-npm directory
Chose McThing
@lilred
Jun 01 2015 19:00
"JavaScript runtime error: 'System' is undefined"
but I just imported system.js in script tags ;_;
Guy Bedford
@guybedford
Jun 01 2015 19:58
It sounds like a lot of people are having issues running the dist files off the master branch on GitHub. Please do download the tagged version - the master branch is not yet released. I will handle major changes on a separate branch in future to avoid this confusion.
@jampekka @lilred see above
Jami Pekkanen
@jampekka
Jun 01 2015 20:05
OK, thanks. I was trying to make it work with the master to use the non-! plugins
Chose McThing
@lilred
Jun 01 2015 20:10
@guybedford I'm using the npm version though!
Chose McThing
@lilred
Jun 01 2015 20:18
I think one issue is that /dist/system.js tries to load es6-module-loader.js from the same directory, while it's actually in a different one
Guy Bedford
@guybedford
Jun 01 2015 20:18
@lilred when using SystemJS you need to either ensure es6-module-loader.js is present in the same folder, or load it with a script tag first
Chose McThing
@lilred
Jun 01 2015 20:19
Wouldn't you consider that an issue with the NPM package? It pulls is es6-module-loader.js but doesn't put it in the dist folder
I feel like it should work OOTB with sensible defaults