These are chat archives for systemjs/systemjs

7th
Jun 2015
Maeoll Kim
@abyss-outpost
Jun 07 2015 05:00 UTC
I'm trying to upgrade traceur to 0.0.90 but jspm is stuck on 0.0.88 and when i change my package.json manually it says 0.0.90 is out of date: http://imgur.com/N2dXnRz
this is an issue because when opening a page in Safari the console output shows that it's looking for a file called "traceur.js.map" but the file has been changed to "traceur.min.map"
I'd be happy to file an issue but jspm's registry shows it's upgraded to 0.0.90 even though jspm dl-loader reverts traceur back
Rob Wormald
@robwormald
Jun 07 2015 06:06 UTC
@abyss-outpost any specific reason you're using traceur? i've more or less given up on it
Maeoll Kim
@abyss-outpost
Jun 07 2015 07:23 UTC
@robwormald it seems to be the default selection and if it's good enough for systemjs it's good enough for me ;-)
Rob Wormald
@robwormald
Jun 07 2015 07:25 UTC
:D doesn't matter i suppose.
Rob Wormald
@robwormald
Jun 07 2015 07:34 UTC
@abyss-outpost using the jspm beta i get traceur @0.0.89
Maeoll Kim
@abyss-outpost
Jun 07 2015 08:03 UTC
hey robwormald, any relation to the robdubya on freenode#angularjs?
Rob Wormald
@robwormald
Jun 07 2015 08:04 UTC
the same
i is he and he is me
Guy Bedford
@guybedford
Jun 07 2015 11:13 UTC
@abyss-outpost there were some source maps issues, but they were resolved in the repo. Perhaps try clearing the cache and see if you get the source map fix via jspm cc && jspm dl-loader.
Maeoll Kim
@abyss-outpost
Jun 07 2015 11:17 UTC
@robwormald thanks for plnkr.co showing me how to set up angular with systemjs!
skip to 0:46 for the funny part
this is se_busca_ayuda
@guybedford : Looking up github:jmcriffey/bower-traceur
Looking up github:jmcriffey/bower-traceur-runtime
Creating registry cache...
ok Up to date - traceur as github:jmcriffey/bower-traceur@0.0.88 (0.0.88)
ok Up to date - traceur-runtime as github:jmcriffey/bower-traceur-runtime@0.0.88 (0.0.88)
ok Loader files downloaded successfully
i used the cli command you provided but its still back in the eighties
Guy Bedford
@guybedford
Jun 07 2015 11:22 UTC
Right, yes only the recent versions of Traceur have the source maps fix
I'd suggest upgrading to the 0.16 beta then
Maeoll Kim
@abyss-outpost
Jun 07 2015 11:23 UTC
@guybedford : robwormald used the beta and got version 0.0.89. Still not a complete fix, but i'll try that
thanks
Maeoll Kim
@abyss-outpost
Jun 07 2015 11:36 UTC
Used the beta, here's the output grepping for traceur: ok Installed traceur as github:jmcriffey/bower-traceur@^0.0.90 (0.0.88)
ok Installed angular as github:angular/bower-angular@^1.4.0 (1.4.0)
ok Install tree has no forks.
ok Installed traceur as github:jmcriffey/bower-traceur@0.0.88 (0.0.88)