These are chat archives for systemjs/systemjs

14th
Aug 2015
Matt
@mattfysh
Aug 14 2015 02:42
hi! anyone around?
Peter Müller
@Munter
Aug 14 2015 11:41
@guybedford What is load.metadata.builderExecute? We're getting Object #<Object> has no method 'buildeExecute' when using jspm builder. Seems to come from systemjs/lib/amd
Guy Bedford
@guybedford
Aug 14 2015 11:47
@Munter any idea which line that is?
it's part of handling the amd layer in the builder without executing it
Peter Müller
@Munter
Aug 14 2015 11:48
I think it's here. The error doesn't have a full stack trace it seems https://github.com/systemjs/systemjs/blob/master/lib/amd.js#L71
Guy Bedford
@guybedford
Aug 14 2015 11:48
make sure you're using the latest patch of SystemjS builder
0.13.1
Peter Müller
@Munter
Aug 14 2015 11:49
We trigger it with module.exports = require('template!jst') with jst being https://github.com/podio/plugin-jst
using jspm 0.16.0-beta7
systemjs-builder 0.13.1
Guy Bedford
@guybedford
Aug 14 2015 11:50
ok, so the way that works
is when loading amd on the server, we run the AMD
so it uses the builderExecute function then
is underscore AMD?
must be here
Peter Müller
@Munter
Aug 14 2015 11:51
correct, it is amd
Guy Bedford
@guybedford
Aug 14 2015 11:52
if you can post an issue I'll look into it when I can
Peter Müller
@Munter
Aug 14 2015 11:52
we also get the same error if we use amd require('template!jst')
on systemjs-builder?
Guy Bedford
@guybedford
Aug 14 2015 11:52
yes
Peter Müller
@Munter
Aug 14 2015 11:52
:+1:
Guy Bedford
@guybedford
Aug 14 2015 11:52
thanks