These are chat archives for systemjs/systemjs

4th
Mar 2016
Guy Bedford
@guybedford
Mar 04 2016 12:29
@MeoMix I'm definitely getting common/css/foo.css on my version... which version of SystemJS are you using?
Sean Anderson
@MeoMix
Mar 04 2016 16:24
I will double-check in a little bit
Eros Stein
@eestein
Mar 04 2016 17:30

Hi fellas!
My first post here and it is to request for help :)

My current setup: SystemJS v0.19.23, JSPM, TypeScript, AngularJS

I was running JSPM 0.16 and it was fine, but now (we're dropping gulp) I updated to 0.17 and tried setting everything up (as usual npm install, jspm, etc) and it's throwing a CORS error on me =/

XMLHttpRequest cannot load npm:typescript@1.7.5.json. Cross origin requests are only supported for protocol schemes: http, data, chrome, chrome-extension, https, chrome-extension-resource.q @ system.src.js:4857(anonymous function) @ system.src.js:4857(anonymous function) @ system.src.js:4857(anonymous function) @ system.src.js:4857(anonymous function) @ system.src.js:4857(anonymous function) @ system.src.js:4857(anonymous function) @ system.src.js:4857(anonymous function) @ system.src.js:4857(anonymous function) @ system.src.js:4857(anonymous function) @ system.src.js:4857
system.src.js:4857 Uncaught (in promise) Error: XHR error loading npm:typescript@1.7.5.json(…)

unfortunately I couldn't find much information on the subject, and since it started to happen right after I migrated to 0.17 I thought maybe someone here would be able to help... any ideas?

Though I'm not sure if it's related to JSPM or SystemJS...

Thanks!

Sean Anderson
@MeoMix
Mar 04 2016 18:24
@guybedford Opened an issue for it to discuss further.
Jeff
@Jefftopia
Mar 04 2016 20:38

I'm on system JS 0.19, can't get default extensions to behave properly. I'd like to import a file and not set the extension explicitly. Is this possible?

The following does this, but I am warned, is deprecated:

        System.config({
            defaultJSExtensions: true,        
            packages: {
                'loghub': {
                    format: 'register',
                }
            }
        });
Jeff
@Jefftopia
Mar 04 2016 21:07
looks like I 1) do need defaultJSExtensions for legacy code, and 2) main is the correct way to configure the door to my app. I'm sure I'll find other breaking changes soon enough. Sigh