These are chat archives for systemjs/systemjs

24th
Jan 2017
Guy Bedford
@guybedford
Jan 24 2017 12:42
@/all SystemJS 0.20 has just bee released. See the release notes at https://github.com/systemjs/systemjs/releases.
It's a big change, please let me know if you have any issues with it at all.
Eugene Lishnevsky
@elishnevsky
Jan 24 2017 12:42
Cool. Thanks!
Jeremy Danyow
@jdanyow
Jan 24 2017 12:42
Nice!
Gert Sønderby
@gertsonderby
Jan 24 2017 12:47
@guybedford How would one best 'run SystemJS' as suggested in the release notes to check your config?
Guy Bedford
@guybedford
Jan 24 2017 12:49
@gertsonderby not sure what you mean here? Have you tried running 0.19 with warnings?
Gert Sønderby
@gertsonderby
Jan 24 2017 12:49
@guybedford That's exactly what I'm not sure how to do. :-) I tried running my app with warn: true inserted in the config, got no warnings, but is that what is asked?
Guy Bedford
@guybedford
Jan 24 2017 12:50
System.config({ warn: true }) yes
if there are no warnings, then you are good to upgrade, although there are breaking changes not warned, mainly just the use of named exports from legacy modules I think
Gert Sønderby
@gertsonderby
Jan 24 2017 12:52
Don't think I have any of those.
<npm upgrades>
Everything seems to run. :)
... Although. Seems I'm not actually using the node-installed SystemJS - I use JSPM.
Guy Bedford
@guybedford
Jan 24 2017 12:57
Yeah the jspm 0.17 upgrade is still to come
jspm 0.16 is now locked to SystemJS 0.19 though
Gert Sønderby
@gertsonderby
Jan 24 2017 13:01
I use 0.17, so that should be fine.
Guy Bedford
@guybedford
Jan 24 2017 14:13
@/all I put together a blog post describing the latest SystemJS release and general directions in more detail here - http://guybedford.com/systemjs-alignment
Gert Sønderby
@gertsonderby
Jan 24 2017 14:13
:+1: