by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Alan Shaw
    @alanshaw
    Installed guvnor@3.0.2 successfully with --unsafe-perm
    node v0.10.36 x86
    Alex Potsides
    @achingbrain
    @kanedauy can you check the npm output when you installed guvnor? if it can’t find the module, it probably means it failed to install

    sounds similar to the

    npm ERR! Error: No compatible version found: rc@'achingbrain/rc#guvnor'
    npm ERR! Valid install targets:
    npm ERR! ["0.0.1","0.0.2","0.0.3","0.0.4","0.0.5","0.0.6","0.0.7","0.0.8","0.1.0","0.1.1","0.1.2","0.1.3","0.2.0","0.3.0","0.3.1","0.3.2","0.3.3","0.3.4","0.3.5","0.4.0","0.5.0","0.5.1","0.5.2","0.5.3","0.5.4","0.5.5","0.6.0"]
    npm ERR!     at installTargetsError (/usr/share/npm/lib/cache.js:719:10)

    problem you were having earlier

    kanedauy
    @kanedauy
    when I try to install stylizer, puff
    Alex Potsides
    @achingbrain
    yeah - it’s not node 0.12 compatible - i’ve got an outstanding pull request to fix that here: latentflip/stylizer#6
    feel free to +1 on that thread..
    guvnor actually uses stylizer from here: https://github.com/achingbrain/stylizer
    which has that pull request applied
    but it’s another github url in the package.json - same as rc above
    which is why i figure it’s related
    Alex Potsides
    @achingbrain
    ooh, actually, this might be because i moved stylizer into the dev dependencies because it should only be necessary for development
    hang on, i’ll move it back
    3.0.3 incoming..
    kanedauy
    @kanedauy
    yep, issue with node 12
    Alex Potsides
    @achingbrain
    ok, 3.0.3 published, give that a go
    kanedauy
    @kanedauy
    yep, reinstalled with node v0.10.36 and all fine
    Alex Potsides
    @achingbrain
    the version of stylizer that guvnor uses has a patch to make it work with node 0.12
    the problem was that it was declared as a devDependency
    that’s fixed in 3.0.3
    so you should be good to go with node 0.12 in version 3.0.3
    kanedauy
    @kanedauy
    but I had bug with execsync with 0.12
    This message was deleted
    Alex Potsides
    @achingbrain
    execSync does not work with 0.12 - it’s there to shim in the functionality for 0.10
    0.12 and io.js have child_process.execSync
    kanedauy
    @kanedauy
    when I tried to instal guvnor in linux, the execsync was failing in native compilation, and I was tracing what was going on
    Alex Potsides
    @achingbrain
    yeah, it’s an optional dependency so it shouldn’t stop the install from succeeding - https://github.com/tableflip/guvnor/blob/master/package.json#L93
    kanedauy
    @kanedauy
    ok
    kanedauy
    @kanedauy
    Good morning everyone,
    Issue with guv-web, http://pastebin.com/gCeMMc0W, any ideas?
    Alex Potsides
    @achingbrain
    I think that's me prematurely optimising devDependencies again
    I've published 3.0.4, should sort it out
    kanedauy
    @kanedauy
    closer, but not there yet, http://pastebin.com/dpGehYep
    kanedauy
    @kanedauy
    "Failed to register mdns component. If running Linux, please run $ sudo apt-get install libavahi-compat-libdnssd-dev before installing guvnor."
    but mdns was installed, I have already done that package installation.
    Alex Potsides
    @achingbrain
    That error is more of a warning. It means compiling node-mdns failed, usually becase the header file dns_sd.h was not found on your system. It’s installed as part of avahi as you’ve discovered. It’s only a problem if you want to use mdns to discover guvnor instances on the local network.
    As for the actual error:
    Error: 139922519410560:error:14094418:SSL routines:SSL3_READ_BYTES:tlsv1 alert unknown ca:../deps/openssl/openssl/ssl/s3_pkt.c:1293:SSL alert number 48
    That’s a new one on me
    Apparently it means a server rejected a client ssl certificate
    kanedauy
    @kanedauy
    the page loaded ok, I assume is the time the browser ask you for add exception for the cert.
    :point_up: February 23 2015 11:35 AM but I have mdns installed
    kanedauy
    @kanedauy
    Alex Potsides
    @achingbrain
    @kanedauy looks like it’s a bug in node-mdns - agnat/node_mdns#125
    they’ve released the fix in 2.2.8 - about 9 hours ago
    if you remove and re-install guvnor it’ll pick up the new version
    kanedauy
    @kanedauy
    yes, working now, thanks @achingbrain
    Alex Potsides
    @achingbrain
    @kanedauy great, thanks for your patience & stack traces
    There’s a guvnor channel over at https://gitter.im/tableflip/guvnor/discuss
    This one will not really be monitored in the future