by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    lenchik-ponchik
    @lenchik-ponchik

    @artem-malko Привет. А как удалить полностью из системы tars-cli?
    Я обновил все до последней версии, все равно пишет tars-cli 1.9.5 - хотя сам tars 1.9.8

    Хочу полностью удалить из системы, и заново поставить.
    sudo npm uninstall -g tars / tars-cli пробовал

    Artem Malko
    @artem-malko
    @lenchik-ponchik по идее все верно. Можно еще попробовать скинуть npm cache
    Leopold Stotch
    @dshkdshk_twitter
    Не совсем понял из документации, достаточно ли установить только tars-cli для полноценной сборки верстки? Или tars тоже должен стоять одновременно с tars-cli?
    Stanislav
    @c01nd01r
    error tars-cli@1.9.6: The engine "node" is incompatible with this module. Expected version "^6.x.x".
    Восьмая нода не поддерживается?
    Вижу tars/tars-cli#80
    Stanislav
    @c01nd01r
    Сменил ноду через nvm на v6.14.3 - все ОК
    autor4n
    @autor4n
    Делаю в main.js import $ from 'jquery'; но jquery так и не подключается..
    В чем может быть проблема7
    rucomcode
    @rucomcode
    'It seems, that TARS in current project is not compatible with current TARS-CLI!' 'Package "browser-sync" is not available.' 'Update TARS-CLI via "tars update" and your project via "tars update-project"' 'Please, write to the tars.builder@gmail.com, if update did not help you.'
    🅃 🄰 🅁 🅂 : TARS-CLI version: "1.9.8"
    🅃 🄰 🅁 🅂 : TARS version in current project: "1.9.9"
    browser-sync в системе стоит, как глобально, так и в папке с проектом
    Artem Malko
    @artem-malko
    @rucomcode tars update помогает?
    @dshkdshk_twitter tars-cli — утилита для работы с tars. Через нее нужно работать. Она делает все нужные манипуляции. Tars — сам сборщик
    @autor4n какой флоу работы с js выбран в tars-config?
    Nikolay Evsukov
    @Nikolasgrizli

    Добрый день. При создании нового проекта с недавнего времени стала появляться ошибка.
    Порядок действий:
    новая папка
    tars init
    tars dev
    Выскакивает в консоли две строки -
    index.html:60 GET http://localhost:3004/static/js/main.js 404 (Not Found)
    Refused to execute script from 'http://localhost:3004/static/js/main.js' because its MIME type ('text/html') is not executable, and strict MIME type checking is enabled.

    танцы с бубном не помогают как и явное присвоение типа для скрипта:

    <script type="text/javascript" src="%=static=%js/main%=hash=%%=min=%.js"></script>

    natalia-ai
    @natalia-ai
    Привет.
    Собираю тарс на виндовс, поставила зависимости, windows build tools. При сборке скрипт говорит, что не может найти 'unistd.h'. В конце написал, что posix не установлен. Насколько он нужен для разработки статического сайта на Виндовс?
    Artem Malko
    @artem-malko
    @Nikolasgrizli нужно обновить до последних версий и tars, и tars-cli. Ошибка будет продолжать появляться, пока не будет создан хотя бы один не пустой js-файл в проекте.
    @natalia-ai совсем не нужен) Сборка запускается?
    rucomcode
    @rucomcode
    @natalia-ai у меня точно такая же беда
    Artem Malko
    @artem-malko
    @rucomcode у тебя другая проблема!)
    Sergey
    @sera-prokop
    Приветствую. При запуске dev или build режимов появляется 'It seems, that TARS in current project is not compatible with current TARS-CLI!' 'Package "uglifyjs-webpack-plugin" is not available.' 'Update TARS-CLI via "tars update" and your project via "tars update-project"' 'Please, write to the tars.builder@gmail.com, if update did not help you.' update не помогает, куда копать?
    Artem Malko
    @artem-malko
    @sera-prokop достаточно обновится до tars-cli последней версии. Также, можно обновить проект локально, после обновления tars-cli
    @/all рекомендую обновить tars-cli до 1.10.6 Была выявлена уязвимость в пакете flatmap-stream и он был удален из npm. В 1.10.6 все пофикшено)
    Shamsudinov
    @Shamsudinov
    Скриншот 14-12-2018 001443.png
    Здравствуйте.... подскажите пожалуйста, в чем может быть причина подобного поведения? Зависает на этом моменте, и нет никакого продолжения((
    pavel sharovatov
    @PavelHtml
    Почему некто не отвечает на последний вопрос?
    Artem Malko
    @artem-malko
    @PavelHtml @Shamsudinov не могу разобраться( Единственным решением пока что вижу переход на NodeJS 8.
    С ним все должно работать на Windows. Также, могу посоветовать работать с TARS через PowerShell
    На windows 10 лучше работать через unix-подобную командную строку
    pavel sharovatov
    @PavelHtml
    Я уже разобрался, поставил новую visual studio, обновил питон и node-gyp и заработало, еще сбросил кэш и перезагрузил. Но есть другая проблема теперь если я один раз добавляю svg изображение все ломается зависает и не запускается пока не перезагрузишь
    Artem Malko
    @artem-malko
    @PavelHtml предлагаю заюзать powerShell
    Artem Malko
    @artem-malko
    @/all все, кто сталкивался с ошибкой Package "gulp-sass" is not available. переустановите tars-cli, выкатил обновление, где баг пофикшен.
    npm un -g tars-cli
    npm i -g tars-cli
    Возможно потребуются права администратора.
    Georgei
    @TheRagnar
    Всем привет, обновил tars clie до последней версии, теперь при tars dev не наблюдает за изменениями scss и html файлов
    Artem Malko
    @artem-malko
    @TheRagnar подскажите версию nodejs и операционную систему
    Georgei
    @TheRagnar
    http://joxi.ru/eAOvMXoi9OwXl2 - на новых версиях node постоянно plase wait и никак не хочет дальше двигатся поэтому такие версии node стоят
    Georgei
    @TheRagnar
    заменил tars-cli до версии 1.10.1 - исправилось. Суть в том, что вот это вот не срабатывало: http://joxi.ru/zANv4noiv3J3EA
    Artem Malko
    @artem-malko
    @TheRagnar таки обновление помогло и все сейчас ок?
    @TheRagnar рекомендую еще с доками парой сообщений выше ознакомиться. Кажется, там есть полезная инфа
    Alexandr Zinoviev
    @ZinovievAlex
    Привет всем! Подскажите пожалуйста, выскакивает ошибка при установке пакетов "npm install". Использую node js v8.11.0, node-gyp 6.0.0, npm 6.12.1, tars-cli 1.11.1, tars 1.13.3

    npm ERR! code EINTEGRITY
    npm ERR! Verification failed while extracting gulp-svg-spritesheet@https://github.com/artem-malko/gulp-svg-spritesheet/archive/master.tar.gz:
    npm ERR! Verification failed while extracting gulp-svg-spritesheet@https://github.com/artem-malko/gulp-svg-spritesheet/archive/master.tar.gz:
    npm ERR! sha1-hg6H2krVkpHQQMIVJj1y74DpWVw= integrity checksum failed when using sha1: wanted sha1-hg6H2krVkpHQQMIVJj1y74DpWVw= but got sha512-E7+RewNDCgDMm0/Yv+v9OOt9cBas26sEgZk22KBPEQQABOyqhwjJWCBGJDLTmAcidWj3bSRAYa6QRzdPZj+0yQ== sha1-4Sb/6Qkqi+hssJACuYU+y9xzET8=. (35849 bytes)

    npm ERR! A complete log of this run can be found in:
    npm ERR! C:\Users\Sasha\AppData\Roaming\npm-cache\_logs\2019-11-01T07_23_22_051Z-debug.log
    Artem Malko
    @artem-malko
    @ZinovievAlex а где выполняется npm i? По идее, достаточно только tars-cli поставить
    Alexandr Zinoviev
    @ZinovievAlex
    Привет всем! Спасибо за ответ!! Тарс (последнюю венрсию) смог установить благодаря версии node.js 8.16.0. Честно говоря, команды npm выполнял из папки Program Files/nodejs
    Alexandr Zinoviev
    @ZinovievAlex
    Но есть другая проблема. Когда открыл проект, сверстанный на старой версии тарса (обновления примерно от середины 2017 года, tars-cli 1.9 вроде), то верстка запустилась, но появились ошибки в плагинах вроде слайдеров, маски для форм и т.д. Причём Jquery отрабатывает, новый тарс он как-бы видит ошибки, там где раньше не видел. С чем это может быть связано, может он как-то реагирует на отступы или на минифицированные версии плагинов? Скажу сразу, что eslint отключил, так как он нашел кучу error в размере 2140 штук. Но даже в отключенном виде, сборка ругается на скрипты/плагины
    При этом, на другом компьютере со старым тарсом проект запускается хорошо
    Artem Malko
    @artem-malko
    @ZinovievAlex предлагаю запустить tars update-project Должен обновить проект автоматически до последней версии. Старая версия сохранится в отдельной папке, так что можно не боятся, что что-то сломается в коде.
    Alexandr Zinoviev
    @ZinovievAlex
    @artem-malko хорошо, попробую так сделать! Спасибо
    Artem Malko
    @artem-malko

    @/all наконец-то выпустил обновление до Gulp v4! Вот такой вот подарок на 2020) Всем обновляться! Сначала обновляем tars-cli

    tars upgrade

    Затем, в папке с проектом

    tars update-project

    В общем, все как всегда) Если что — заводите issue на github.

    rucomcode
    @rucomcode
    Коллеги, вопрос, в WSL не хочет запускать пересборку при сохранении файла
    Artem Malko
    @artem-malko
    @rucomcode а WSL2 пробовали?