Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Aug 24 20:12

    17cupsofcoffee on master

    Remove frag data binding (not n… (compare)

  • Aug 24 18:35

    17cupsofcoffee on master

    Add wasm-bindgen feature to rand (compare)

  • Aug 24 15:52

    17cupsofcoffee on master

    Remove unused functions from we… (compare)

  • Aug 23 20:36

    17cupsofcoffee on wasm-ci

    (compare)

  • Aug 23 20:35
    17cupsofcoffee commented #129
  • Aug 23 20:35

    17cupsofcoffee on master

    Try to set up CI for WASM (compare)

  • Aug 23 20:26

    17cupsofcoffee on wasm-ci

    Try to set up CI for WASM (compare)

  • Aug 23 20:24

    17cupsofcoffee on wasm-ci

    Try to set up CI for WASM (compare)

  • Aug 23 20:24

    17cupsofcoffee on wasm-ci

    (compare)

  • Aug 23 20:11

    17cupsofcoffee on master

    Move audio into the platform la… (compare)

  • Aug 22 22:30

    17cupsofcoffee on master

    Make usage of ctx.running more … (compare)

  • Aug 22 22:12
    17cupsofcoffee commented #129
  • Aug 22 22:10
    17cupsofcoffee edited #129
  • Aug 22 21:53

    17cupsofcoffee on master

    Add the first stubs of a web ba… (compare)

  • Aug 22 20:54

    17cupsofcoffee on master

    Start rearranging things for th… (compare)

  • Aug 20 22:43

    17cupsofcoffee on cargo

    (compare)

  • Aug 20 22:43

    17cupsofcoffee on master

    Update image requirement from 0… (compare)

  • Aug 20 22:43
    17cupsofcoffee closed #130
  • Aug 20 22:43
    17cupsofcoffee synchronize #130
  • Aug 20 22:43

    17cupsofcoffee on cargo

    Update image requirement from 0… (compare)

Michael
@Skytrias
hey im off for now but just wanted to say tetra is very exciting, keep up the good work! just started using it and love how easy it is so far
Joe Clay
@17cupsofcoffee
@Skytrias Whoops, still haven't got notifications turned on for this! Thank you for the kind words :)
Reminds me, I've been meaning to check out Everpuzzle for a while, I must get around to that...
Michael
@Skytrias
haha dont worry i might make it in tetra :P ill have to use it more before that tho
Michael
@Skytrias
@17cupsofcoffee hey the 2.0 examples arent running, or rather im getting a black screen
Joe Clay
@17cupsofcoffee
@Skytrias Hm, that's annoying D: The most obvious culprit would be the changes I made to the shaders (some other people were getting black screens so I downgraded the syntax)
Here's the commit refs for before and after I changed them - could you try running an example on both versions?
Before: 522312b5908372d0971b0dde41f4b60fe3f8864b
After: db8bf0c3f3d79443319d989677acee307682dae6
Michael
@Skytrias
sure
Michael
@Skytrias
so the first commit ref works,
the other one doesnt
Joe Clay
@17cupsofcoffee
aha
I guess I need to figure out what's screwy with my shaders then
Michael
@Skytrias
haha funny how this got through to the release
Joe Clay
@17cupsofcoffee
it's like playing whack-a-mole - there's another guy who's been playing around with the engine, and he was getting a black screen before I made that change :p
Joe Clay
@17cupsofcoffee
@Skytrias Okay, I've hacked together a first draft of shader error reporting - if you pull the branch called shader_validation, hopefully you'll get something more helpful than a black screen! Let me know if anything interesting pops out in the logs
Joe Clay
@17cupsofcoffee
In fact I just merged it into master, seems like a good thing to have in general
Michael
@Skytrias
hmm still getting a black screen, ill download the new master and run the examples again
its worth noting that i have (i believe) a shitty graphics card
OpenGL Device: AMD Radeon HD 5700 Series
OpenGL Driver: 4.5.13417 Compatibility Profile Context 15.301.1901.0
OpenGL Vendor: ATI Technologies Inc.
Swap Interval: Immediate
but i mean everything worked in tetra 1.6 so hmm
Michael
@Skytrias
texture example also doesnt run
Joe Clay
@17cupsofcoffee
How frustrating :(
Do you get any error output on master? If the shaders fail to compile now it should just quit automatically and log out the reason
Michael
@Skytrias
no errors
Joe Clay
@17cupsofcoffee
🤔 dang
Joe Clay
@17cupsofcoffee
Try the shader_150 branch - I'm wondering if I downgraded the shaders too far
Michael
@Skytrias
still not working
Joe Clay
@17cupsofcoffee
Aaagghh
Michael
@Skytrias
guess it works on your side right
Joe Clay
@17cupsofcoffee
Yeah, like I say, both the old and new shaders have always worked fine for me
But someone else was getting a black screen with the ones that do work for you
And downgrading to shader level 130 fixed it for them without breaking it for me, so I was like
cool, must be fine
Michael
@Skytrias
still broken
we can write on discord there i atleast get the notifications
Joe Clay
@17cupsofcoffee
:thumbsup:
legendiguess 🍉
@legendiguess_twitter
Sup @17cupsofcoffee. Want to say about some typos in Tetra tutorials, cause if even it just simple mistakes - it can be painfull for newbies who want to start learning Rust from making some games on Tetra. So:
https://tetra.seventeencups.net/tutorial/getting-started.html
Here need to add Color to use tetra::graphics::{self, Text, Font, Vec2}; because of graphics::clear(ctx, Color::rgb(0.392, 0.584, 0.929)); line.
And here https://tetra.seventeencups.net/tutorial/loading-a-texture.html
need to fix from text: Texture::new(ctx, "./player.png")?, to texture: Texture::new(ctx, "./player.png")?, in GameState new function.
Also want to say thanks for good and simple game framework for Rust by you.
Joe Clay
@17cupsofcoffee
@legendiguess_twitter good spot! I'll fix those today and give the tutorial another proofreading, thanks for letting me know :)
Joe Clay
@17cupsofcoffee
@legendiguess_twitter fixed - should be live on the website as soon as the CI build finishes doing it's thing!
I definitely need to get things set up so the tutorial examples run as tests on Travis, would save people having to spot my typos for me :sweat_smile: