Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Mar 01 23:42
    sumibi-yakitori commented #245
  • Mar 01 23:41
    sumibi-yakitori commented #245
  • Mar 01 23:34
    sumibi-yakitori commented #245
  • Mar 01 22:38
    sumibi-yakitori commented #245
  • Mar 01 22:26
    sumibi-yakitori commented #245
  • Mar 01 22:15
    sumibi-yakitori commented #245
  • Mar 01 22:08
    17cupsofcoffee commented #245
  • Mar 01 22:06
    sumibi-yakitori commented #245
  • Mar 01 22:02
    sumibi-yakitori commented #245
  • Mar 01 21:45
    sumibi-yakitori commented #245
  • Mar 01 21:42
    sumibi-yakitori commented #245
  • Mar 01 14:36
    17cupsofcoffee commented #245
  • Mar 01 10:41
    sumibi-yakitori commented #245
  • Mar 01 01:40
    sumibi-yakitori commented #245
  • Mar 01 01:20
    sumibi-yakitori commented #245
  • Mar 01 01:20
    sumibi-yakitori commented #245
  • Mar 01 01:11
    sumibi-yakitori commented #245
  • Mar 01 00:45
    sumibi-yakitori commented #245
  • Mar 01 00:39
    sumibi-yakitori commented #245
  • Mar 01 00:24
    sumibi-yakitori commented #245
Michael Kutowski
@Skytrias
hey im off for now but just wanted to say tetra is very exciting, keep up the good work! just started using it and love how easy it is so far
Joe Clay
@17cupsofcoffee
@Skytrias Whoops, still haven't got notifications turned on for this! Thank you for the kind words :)
Reminds me, I've been meaning to check out Everpuzzle for a while, I must get around to that...
Michael Kutowski
@Skytrias
haha dont worry i might make it in tetra :P ill have to use it more before that tho
Michael Kutowski
@Skytrias
@17cupsofcoffee hey the 2.0 examples arent running, or rather im getting a black screen
Joe Clay
@17cupsofcoffee
@Skytrias Hm, that's annoying D: The most obvious culprit would be the changes I made to the shaders (some other people were getting black screens so I downgraded the syntax)
Here's the commit refs for before and after I changed them - could you try running an example on both versions?
Before: 522312b5908372d0971b0dde41f4b60fe3f8864b
After: db8bf0c3f3d79443319d989677acee307682dae6
Michael Kutowski
@Skytrias
sure
Michael Kutowski
@Skytrias
so the first commit ref works,
the other one doesnt
Joe Clay
@17cupsofcoffee
aha
I guess I need to figure out what's screwy with my shaders then
Michael Kutowski
@Skytrias
haha funny how this got through to the release
Joe Clay
@17cupsofcoffee
it's like playing whack-a-mole - there's another guy who's been playing around with the engine, and he was getting a black screen before I made that change :p
Joe Clay
@17cupsofcoffee
@Skytrias Okay, I've hacked together a first draft of shader error reporting - if you pull the branch called shader_validation, hopefully you'll get something more helpful than a black screen! Let me know if anything interesting pops out in the logs
Joe Clay
@17cupsofcoffee
In fact I just merged it into master, seems like a good thing to have in general
Michael Kutowski
@Skytrias
hmm still getting a black screen, ill download the new master and run the examples again
its worth noting that i have (i believe) a shitty graphics card
OpenGL Device: AMD Radeon HD 5700 Series
OpenGL Driver: 4.5.13417 Compatibility Profile Context 15.301.1901.0
OpenGL Vendor: ATI Technologies Inc.
Swap Interval: Immediate
but i mean everything worked in tetra 1.6 so hmm
Michael Kutowski
@Skytrias
texture example also doesnt run
Joe Clay
@17cupsofcoffee
How frustrating :(
Do you get any error output on master? If the shaders fail to compile now it should just quit automatically and log out the reason
Michael Kutowski
@Skytrias
no errors
Joe Clay
@17cupsofcoffee
🤔 dang
Joe Clay
@17cupsofcoffee
Try the shader_150 branch - I'm wondering if I downgraded the shaders too far
Michael Kutowski
@Skytrias
still not working
Joe Clay
@17cupsofcoffee
Aaagghh
Michael Kutowski
@Skytrias
guess it works on your side right
Joe Clay
@17cupsofcoffee
Yeah, like I say, both the old and new shaders have always worked fine for me
But someone else was getting a black screen with the ones that do work for you