Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
  • Jun 21 17:46

    dependabot[bot] on composer

    (compare)

  • Jun 21 17:46
    dependabot[bot] closed #579
  • Jun 21 17:46
    dependabot[bot] commented #579
  • Jun 21 17:46
    dependabot[bot] labeled #581
  • Jun 21 17:46
    dependabot[bot] opened #581
  • Jun 21 17:46

    dependabot[bot] on composer

    Bump guzzlehttp/guzzle from 6.3… (compare)

  • Jun 21 17:41

    dependabot[bot] on composer

    (compare)

  • Jun 21 17:41
    dependabot[bot] closed #578
  • Jun 21 17:41
    dependabot[bot] commented #578
  • Jun 21 17:41
    dependabot[bot] labeled #580
  • Jun 21 17:41
    dependabot[bot] opened #580
  • Jun 21 17:41

    dependabot[bot] on composer

    Bump guzzlehttp/guzzle from 6.3… (compare)

  • Jun 10 00:52

    dependabot[bot] on composer

    (compare)

  • Jun 10 00:52
    dependabot[bot] closed #577
  • Jun 10 00:52
    dependabot[bot] commented #577
  • Jun 10 00:52
    dependabot[bot] labeled #579
  • Jun 10 00:52
    dependabot[bot] opened #579
  • Jun 10 00:52

    dependabot[bot] on composer

    Bump guzzlehttp/guzzle from 6.3… (compare)

  • Jun 10 00:45

    dependabot[bot] on composer

    (compare)

  • Jun 10 00:45
    dependabot[bot] closed #576
Daniel André Eikeland
@zegenie
@sindresops I don't understand this question
winnes123
@winnes123
@zegenie , had a database crash and the database doesn't seem to respect targeted milestone anymore. Tried a database repair, but the issue still seems to be there. Any help would of course be greatly appreciated. Version is 4.20. Thanks
winnes123
@winnes123
@zegenie , false alarm. Seems the issue was due to a cache issue with Chrome. :.(
Frederick Henderson
@frederickjh
My web host is going to remove PHP 7.0 and 7.1 so I need to upgrade The Bug Genie to get PHP 7.2 compatability, as I am currently using PHP 7.0. I am currently on TBG version 4.1.13 with composer. The UPGRADE.md talks a lot about upgrading from version 3.2 but not how to upgrade from a 4.x version. Can anyone point me to directions for upgrading from 4.1.13 to 4.3.1?
Bonaya Mudda
@bmudda

@frederickjh I use the command line to upgrade

./tbg_cli upgrade

You can see all available commands for the TBG cli with

./tbg_cli help
Frederick Henderson
@frederickjh
@bmudda Thanks! Sorry it took me so long to get back to Gitter to see your response. I will try that.
Stefano M.
@McMazz
Hi there, after installing a clear 4.3.1 i got a 404 error /do/login. Anyone can help me?
Frederick Henderson
@frederickjh
I just upgraded from version 4.1.3 to 4.2.1. I set the Admistrator password during the install. I also reset a user password, but I cannot login. Any ideas what is going on?
Frederick Henderson
@frederickjh
I thought that tbg was now using composer. Any reason composer on the commandline is not used to update to the newest version? I did composer install --dry-run to check what would be done and found that it would install 12 packages, update 23 and remove 1. Somehow that does not seem right.
image.png
Frederick Henderson
@frederickjh
I just realized I upgraded from 4.1.13 not 4.3.1 as I wrote above.
Frederick Henderson
@frederickjh
I was hoping to upgrade to 4.3.x today my ISP is dropping PHP 7.1 support later today. @zegenie Do 4.3.x and above versions work with PHP 7.2? 7.3? 7.4?
Frederick Henderson
@frederickjh
I forgot to mention when trying to login, after entering the username and password, when I click the button then the green wheel spins, then stops and nothing else happens.
Frederick Henderson
@frederickjh
I was able to switch PHP to 5.6 as the web host did not continue that version yet. That happens at the end of the year. So I am stuck with a Bug Genie install that suposely upgraded from 4.1.31 to 4.2.1 and can no longer log in with either the admin or user accounts. Any suggestions as to how to troubleshoot? The logfile thebuggenie.log is empty.
$ ./tbg_cli
An error occured when trying to initialize the command line client:
A route that overrides another route must have an @Override annotation
Frederick Henderson
@frederickjh
Contents of installed:
4.2.1, upgraded 31.08.2020 07:53
4.1.13, upgraded 21.08.2017 21:40
4.1, installed 15.08.2017 23:38
Frederick Henderson
@frederickjh
When I try to login at /#tab_active, I type in my username and password and click the button the green wheel spins and then nothing. If I try to login at /login, after "logging in", it takes me to the /about page, but I am not really logged in. My username is not in the upper right corner nor can I access any projects.
Frederick Henderson
@frederickjh
image.png
OK, I switched to PHP 7.2.33 as I see that 5.6 is not supported. Now when I try to run the upgrade I get count(): Parameter must be an array or an object that implements Countable. See the screenshot above.
Same error without the upgrade.
Frederick Henderson
@frederickjh
image.png
Frederick Henderson
@frederickjh
This looks like it is related to Fails to run with PHP 7.2.4 count(): Parameter must be an array or an object that implements Countable . It says it is targeted for The Bug Genie 4.2. However I my install is saying it is on 4.2.1 and I am still seeing this error.
Frederick Henderson
@frederickjh
PHP is now 7.3.20 trying to upgrad to TheBugGenie 7.3.1 and I am still getting the same error. Any ideas?
image.png
Frederick Henderson
@frederickjh
Well, I have chased this back and found that the PHP ext-apc is not installed. Also figured out that it is not possible to use PHP 7.3 as it uses lib-pcre 10 and TheBugGenie requires 8.* I am now waiting on a support request to get ext-apc installed.
Frederick Henderson
@frederickjh
For anyone else wanting to troubleshoot an installation, TheBugGenie uses composer under the hood to install or update . Run composer install --dry-run to see what would be installed and if there are any errors. That is how I figured out what was going on.
Daniel André Eikeland
@zegenie
@frederickjh the pcre lib requirement is just >= 8, 10 should be fine. If that's stopping you, please let me know. The apc / apcu extension is required, though
Daniel André Eikeland
@zegenie
@/all we have set up a new chat on zulip for future discussions and talks about TBG and its relaunch under the new neame Pachno. You can find it at https://pachno.zulipchat.com - feel free to join there and continue any discussions 💌
Frederick Henderson
@frederickjh
@zegenie None of the webhostings my company has have the APC extension installed, so I am not sure where that leaves me, except with a broken The Bug Genie installation. Will Pachno also require APC?
Frederick Henderson
@frederickjh
image.png
phpinfo() in the browser shows this

@frederickjh the pcre lib requirement is just >= 8, 10 should be fine. If that's stopping you, please let me know. The apc / apcu extension is required, though

@zegenie I finally got back to this. I was able to get the hosting provider to add the installation of apcu to the control panel and it seems to be installed both for the webhosting and in the cli. If I run:

$ php -m |grep apc
apcu
Frederick Henderson
@frederickjh
image.png
But I am still getting this error:
count(): Parameter must be an array or an object that implements Countable in /thebuggenie/vendor/thebuggenie/b2db/src/Annotation.php, line 24
Frederick Henderson
@frederickjh
image.png
composer install --dry-run says "The requested PHP extension ext-apc * is missing from your system. Install or enable PHP's apc extension."
Frederick Henderson
@frederickjh
I tried to go back to 7.2.1 but this too is not working. Does anyone know what this error message means? A route that overrides another route must have an @Override annotation
The log ends with warning [i18n] 115.34 ms Cannot access the translation object until the i18n system has been initialized! Is that module causing the issue?
Frederick Henderson
@frederickjh
Well, I think I have just about given up hope that I will ever be able to upgrade The Bug Genie 4.1.13. I just tried a fresh install of 4.1.13 then tried to upgrade to 4.2.1. I set a new Administrator password, but am unable to login . Tried using tbg_cli resetpassword Administrator but even that password did not work. I have javascript errors: "Uncaught SyntaxError: expected expression, got '<'". Not promising when even a fresh install cannot be upgraded.
image.png
Branko Majic
@azaghal
@zegenie Guess who just hit the pcre 8 issue as well :)
haclong
@haclong
@zegenie the BugGenie upgrade is a nightmare, none is working after 4.1.13. I hit the count() issue and the APCU issue while my phpinfo DOES state the apcu extension is installed...
i do hope Pachno is going better because i was resolved to NOT migrate from 4.1.13 to 4.3 (rebuilt all the database manually)... but i can't even install 4.3 and if i am going through the manual rebuilt of the database, i'm not sure i'll be waiting for pachno because i'd like it ... like now and you said there will be no migration script between two pachno alpha versions...
i have to admit, i feel kinda stuck here... i really liked The Bug Genie though... really bad news for me
haclong
@haclong
ok... pachno built successfully
haclong
@haclong
image.png
:facepalm: nope...
though Composer says otherwise :
image.png
haclong
@haclong
ok, the lib-pcre requirements made it impossible to install 4.1.13 :(
Jhonier Gaviria
@yjgaviriam
image.png
Hi, I'm installing pachno and says this:
Why?
Version 1.0.3