Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Sören Domrös
@soerendomroes
yes, you can specify a path to a workspace, something like theia start --root-dir=../workspace
vinay badhan
@vinayb21
I meant the specific files in a workspace that you can provide as some additional parameters which will open those files when the workspace is selected.
Ex: If I open a workspace say sample and default file as app.js then app.js should open by default when Theia is loaded
realisation
@realisation
how large is the typescript language server that Theia uses?
realisation
@realisation
Where is the core code for Theia?
I'm looking in the repository, doesn't look like there's much there though
krd78
@krd78
hello everyone, i need help with my theia environment, the first load on browser never finish...
i'm behind a nginx proxy
Marc Dumais
@marcdumais-work
Hi @realisation , @krd78 : please ask your questions on our new chat system here: https://spectrum.chat/theia
krd78
@krd78
@marcdumais-work done, thanks
krd78
@krd78
@marcdumais-work can't you help me on spectrum ?
Marc Dumais
@marcdumais-work
Me personally, no. But I hope other might be able-to
realisation
@realisation
are there any browser extensions that use Theia?
Paul Maréchal
@marechal-p
@realisation you should share your questions on https://spectrum.chat/theia.
On the other hand, I do not understand you question, using Theia you would create a full web application, as in: backend server + IDE in your browser, loaded like any other website
vinay badhan
@vinayb21
Is the concept of appState still in Che7?
Paul Maréchal
@marechal-p
Sorry, I don't know, but this is Theia's Gitter, not Che's .
Vince Lynch
@vince-lynch
Hey, I'm struggling to get either plugins or extensions to work inside my browser based theia project
Marc Dumais
@marcdumais-work
Hi @vince-lynch . The community has moved to Spectrum: https://spectrum.chat/theia.
michealkd
@michealkd
just found theia-ide and ran a test. any way to add auth to it where a login is required before the user can use the app?
johannpickard
@johannpickard
Has anyone had any trouble with gitpod ?
Jan Koehnlein
@JanKoehnlein
@johannpickard please use https://spectrum.chat/gitpod
Stephen Raghunath
@raghunat
Hello Everyone!
I have created a plugin, and works fine in hosted mode. I take the .thea file, put it into a container with theia running, and a THEIA_PLUGINS variable set to the folder containing that .theia file, but theia doesn't see it? Am I missing something?
Stephen Raghunath
@raghunat
I also tried adding the plugins folder with the .theia file next to the package.json for the theia editor, but no luck
Marc Dumais
@marcdumais-work
Hi @raghunat we have moved to https://spectrum.chat/theia . Please ask over there :)
:-)
done
dingbig
@dingbig
Hello team!
I am building theia ide by runing "yarn"
I got errors:

yarn install v1.16.0
[1/5] Validating package.json...
[2/5] Resolving packages...
[3/5] Fetching packages...
warning monaco-languageclient@0.9.0: The engine "vscode" appears to be invalid.
warning vscode-base-languageclient@4.4.0: The engine "vscode" appears to be invalid.
info fsevents@1.2.4: The platform "linux" is incompatible with this module.
info "fsevents@1.2.4" is an optional dependency and failed compatibility check. Excluding it from installation.
[4/5] Linking dependencies...
warning " > istanbul-instrumenter-loader@3.0.1" has unmet peer dependency "webpack@^2.0.0 || ^3.0.0 || ^4.0.0".
warning " > tslint-language-service@0.9.9" has incorrect peer dependency "typescript@>= 2.3.1 < 3".
warning "workspace-aggregator-68e88639-6ce0-476f-8491-bbc5ebd23952 > @theia/application-manager > font-awesome-webpack@0.0.5-beta.2" has unmet peer dependency "font-awesome@>=4.3.0".
warning "workspace-aggregator-68e88639-6ce0-476f-8491-bbc5ebd23952 > @theia/debug > requestretry@3.1.0" has unmet peer dependency "request@2..".
warning "workspace-aggregator-68e88639-6ce0-476f-8491-bbc5ebd23952 > @theia/application-manager > font-awesome-webpack > less-loader@2.2.3" has incorrect peer dependency "less@^2.3.1".
[5/5] Building fresh packages...
[10/14] ⠂ find-git-repositories
[8/14] ⠂ oniguruma
[-/14] ⠂ waiting...
[11/14] ⠂ @theia/electron
error /home/d/theia/node_modules/@theia/electron: Command failed.
Exit code: 127
Command: node ./scripts/skip-replace-ffmpeg || (node ./electron-replace-ffmpeg && node ./electron-h264-test)
Arguments:

d@ide:~/theia$

what is that?
my node version is "v10.15.3"
thank you
Marc-Andre Laperle
@MarkZ3
@dingbig Check out https://spectrum.chat/theia
lihomahowareyou
@lihomahowareyou
Hi, does anyone know how to add a button with function on the left bar of theia? thx!
lihomahowareyou
@lihomahowareyou

Hi, I follow the example https://www.theia-ide.org/doc/Composing_Applications.html to create my own theia IDE. I want to add an extension to it but really don't know how to do.
After I copy the dependencies from package.json in https://www.theia-ide.org/doc/Authoring_Extensions.html example to my IDE's package.json, then using yarn to install the dependencies, it shows a lot of error message....
Does anyone know how to create an extension and add to IDE ? Thanks!

Error message:
"FATAL ERROR: Ineffective mark-compacts near heap limit Allocation failed - JavaScript heap out of memory"

lihomahowareyou
@lihomahowareyou
@lihomahowareyou I find what is the problem, I should add the extension to package.json and put the extension folder to node_modules folder, thx!!
marengaz
@marengaz
hi all -running theia in docker - is it possible to change the workspace default dir?
Marc Dumais
@marcdumais-work
Hi @marengaz . We have moved to: https://spectrum.chat/theia
alternatively you could open an issue here: https://github.com/theia-ide/theia-apps
Erwann Mest
@kud
Hello :)
I've got a question about https://github.com/theia-ide/typescript-language-server, how to specify your own .tsconfig file there?
Vincent Fugnitto
@vince-fugnitto
Hi @kud, we've moved discussions to https://spectrum.chat/theia. I see you already opened the issue on https://github.com/theia-ide/typescript-language-server
Erwann Mest
@kud
Yep :D
I'm on spectrum too now
logicmoo
@DouglasRMiles
Do nmost VSC plugins work on Theia?
Marc Dumais
@marcdumais-work
Hi @DouglasRMiles . Anecdotally, I would say yes. BTW, we have moved to Spectrum: https://spectrum.chat/theia?tab=posts . You should open a new topic there if you'd like to discuss this more.