Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Arnab sahoo
    @arnab15
    Hello Everyone I'm Arnab Sahoo. I'm interested to contribute to this project. I have good understanding knowledge of JavaScript,nodejs,MongoDB.I tried to setup devlopment environment but when i run docker-compose up i got some errors.and application is not running. plese give someme suggestions i tied all steps that are mentioned in doc but still it's not working.
    4 replies
    Arnab sahoo
    @arnab15
    dockernotrunning.png
    I don't know why this one container is not running @Yash911
    6 replies
    Aditya Prakash
    @prakashaditya369
    I am getting this errorERROR: No container found for web_1 while running docker-compose exec web bash. How to solve this??
    Christian Clauss
    @cclauss
    @adad20 Please try the instructions above for Fully Resetting Your Environment
    Itachi8374
    @Itachi8374
    Hi everyone!! I am Tanay. I love the concept of open library and how it is helping millions of people across the globe. I would be glad to contribute to this project. I have setup development environment. But I don't know what should be the next step. I am trying to fiddle with codebase right now. Any guidance is appreciated on how to proceed now is appreciated.
    Clifton McCallum
    @CliftonMcCallum
    Hello, friends! My name is Clifton. My team and I are looking to contribute to Open Library. We are final year students, taking a software engineering practicum. Like Itachi8374, we have setup the development environment and are looking for ways to contribute. We are eager to add meaningful contributions and actively participate. If there are any contributors who are willing to mentor our team, then we would love to meet you! Thank you for any tips or guidance that you can offer our team!
    Sumesh Thakur
    @SumeshT
    Hi everyone! My name is Sumesh and I was trying to contribute to openLibrary. After setting up a local development server and logged in as admin when I go to subjects page it shows /subjects does not exist. Is it just fault in my local server or does it really does not exist in development servers? Thanks for any help
    Sabreen-Parveen
    @Sabreen-Parveen
    Hi Sumesh!
    /subjects page is available on dev, staging, and production but not on a localhost instance.
    Yash Saravgi
    @Yashs911

    @SumeshT http://localhost:8080/subjects page can be generated, but first, you need to import it.

    $ python scripts/copydocs.py "/subjects"

    Sumesh Thakur
    @SumeshT
    Thanks @Yashs911 @Sabreen-Parveen
    Abhinav Tiwari
    @matrix101A
    Hi everyone ! My name is Abhinav Tiwari . I am an second year engineering undergraduate . I would like to contribute in the open library project . I have already set up the development environment and exploring the codebase. I have experience in frontend technologies like HTML, CSS, JavaScript, React also backend frameworks like node and Django. Please suggest a good starting point like some beginner issues to work upon . Thanks!
    Abhinav Tiwari
    @matrix101A
    Hello, so I was exploring the codebase and for some reason the changes on the template files(home/about.html) do not show on my localhost , instead an error is shown or the template disappears form the page completely, the changes to css and js files seem to be working fine . I read that this is due to some kind of caching but could not fix it. Can someone please explain the reason for this and how can I fix it ?
    MayankVir
    @MayankVir
    Hi everyone, I am Mayank Virmani, 3rd year undergrad at Chandigarh University pursuing BE in Computer Science. I have been doing development for an year and MERN stack is the one I focused upon. I figured out open source thing recently and want to dive into it. I would love if I can make even a small contribution to the organization as I am not an expert in development but I am very eager to learn new tech and frameworks. I would be grateful if anybody would guide me through this whole open source world. Thank you
    Harshita
    @mharshita
    image.png
    image.png
    Hi everyone! I am Harshita. I am trying to set up development environment for openlibrary. So, as per the instructions given in https://github.com/internetarchive/openlibrary/blob/master/docker/README.md ..... I have installed docker, cloned the repository using SSH and successfully build the images using docker-compose build. But when I am running docker-compose up -d , the app is not starting! Here are some of the screenshots : ScreenShot ScreenShot. Someone please help. Thanks !
    Yash Saravgi
    @Yashs911
    @mharshita You need to run docker commands in the project root directory
    1 reply
    Muhammed Ali
    @khabdrick
    Hello everyone
    will internet archive be in gsoc 2021
    1 reply
    Romi-776
    @Romi-776
    Hello Everyone!
    Initially I had cloned the git repo using https along with all other docker setup. The project was working but git pull isn't working. Now I cloned it using SSH but now the project isn't working. It is showing a message everywhere that pyenv version 3.9.1 isn't installed. I tried to install it using the steps given on this link
    https://gist.github.com/luzfcb/1a7f64adf5d12c2d357d0b4319fe9dcd
    but the pyenv version isn't updating. My pc is showing the verion of pyenv as 1.2.23.
    Can anyone tell me what should I do now?
    Thanks.
    Screenshot from 2021-02-20 07-08-34.png
    9 replies
    Screenshot from 2021-02-20 07-07-21.png
    These are some of the screenshots for reference.
    Vishwas Singh
    @infern018
    Screenshot (368).png
    Hello all, I was setting up the project using docker, but when i ran docker-compose up the these errors showed up
    3 replies
    can anyone guide me on this?
    Vishwas Singh
    @infern018
    Screenshot 2021-02-20 174302.png
    that worked something @Yashs911 , but it is stuck on this for so long :P
    why this can be showing up?
    4 replies
    Vishwas Singh
    @infern018
    while running docker-compose up i am getting this error : db_1 | FATAL: role "openlibrary" does not exist
    and the database is not loading up, can someone help me out?
    Jessica Zhang
    @jessicajzhang03
    Hi! I'm new here and just set up my docker environment. When I click some links, e.g., "subjects" in the dropdown menu (http://localhost:8080/subjects) and "suggesting edits" in the footer (http://localhost:8080/help/faq/editing), I get a 404 error. Is this supposed to be the case, or did I mess something up?
    Christian Clauss
    @cclauss
    Don’t use sudo.
    Vishwas Singh
    @infern018
    can anyone tell why when i am using ctx.user.is_admin() it is showing logged in as admin even when i am logged in by my normal credentials
    image.png
    I've tried using separate nested if conditon for <if ctx.user.is_admin()> but it is being called irrespective of who logs in
    Why this may be showing up?
    It is with ref to this pull (internetarchive/openlibrary#4652)
    @bsdlp
    Romi-776
    @Romi-776
    When I try to run "docker-compose up" I am getting an error like this:
    Screenshot from 2021-02-24 08-25-02.png
    6 replies
    ravenhaer
    @ravenhaer
    Hello everyone! I am Anwesha. I am new to Open library community. Can anyone suggest a good first issue or an urgent issue I can start working on
    Christian Clauss
    @cclauss
    @Romi-776 The Python print error means that you are using a really old infogami. In the /opt/openlibrary directory please do a make git and try to restart Open Library.
    Romi-776
    @Romi-776
    There's no openlibrary directory in my /opt directory.
    Christian Clauss
    @cclauss
    ls/opt
    ls /opt
    Romi-776
    @Romi-776
    Screenshot from 2021-02-27 08-13-21.png
    Christian Clauss
    @cclauss
    If you go into your openlibrary directory and type make git you should see:
    % make git
    git submodule init
    git submodule sync
    Synchronizing submodule url for 'vendor/infogami'
    Synchronizing submodule url for 'vendor/js/wmd'
    git submodule update