Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
    'State Chart' widget
    Hi everyone. I have installade thingsboard using docker with the image thingsboard/tb-postgres. I am trying to integrate OAuth2.0 using OAuth0 as explained in the documentation ( https://thingsboard.io/docs/user-guide/oauth-2-support/ ), but the login button doesn't show. I even tried using the new UI in the version 3.2.0 for OAuth2 but I have the same problem. From logs I get no errors. Does anyone have the same problem? Thank you
    Hi all. How do you aggregate values in telemetry that are already total? Let's say I have a power meter and that meter sends the current watts used but also the total kWh used for the day. The total kWh will increment and reset to 0 at midnight. I want to add up all the totals for a site (site can have 1 to x number of meters) and then all the sites to a region. If I use the samples I get a compounding problem as it does not reset the total to 0 before it adds them all together again, So the totals keep on growing with each set of telemetry. I do not want to calculate kWh used by using the watts, I already have the total as the meter calculates it, I just want to add all the meter totals together to get the total for a site and them all the sites together to get the total of the region. Any help or pointing me to a sample will be great.
    YC Hong
    Hi, does anyone getting disconnect and connect issue whenever the telemetry data pass through tb-gateway?
    Aaron Fulton
    Just a note regarding the installation instructions for kafa. The instructions only say to start the kafka and zookeepers services (not enable them so they start upon next boot). I wasted quite a bit of time working out what the issues were. Could the instructions be updated:
    sudo systemctl daemon-reload
    sudo systemctl enable --now zookeeper
    sudo systemctl enable --now kafka
    sudo systemctl status kafka zookeeper
    Just would like to know whether you have any experience of using indoor map instead of open Google/Tencent map. What kind of indoor maps can be supported? Does ThingsBoard support SLAM (Simultaneous Localization And Mapping)?
    Hi i am new here
    Merry Christmas
    Hello, im trying to load the database on powerbi for analytics and im wondering how are the telemetry tables arranged.
    Is the .ts_kv table the one with all the telemetry? i tried opening that table with dbeaver and apparently that table is 10 gb big, with a length of 10000000 and precision of 10000000
    Hi guys, i wondering can 2 instance of thingsboard co-exists on the same db? cuz i started 2 container on different ports but same volume and they seems separed... if 1 crush and go up it takes the devices created by the other one.. any tips?
    hi guys, i am working in old version of thingsboard 2.4.1 and gateway 1.4, i notice strange behavior , when i delete device from UI and send new payload using gateway the device will not created again ... did any one face issu like this ?
    @melkio95 r u running using microservice ?
    How does a thingsboard downlink look like for sending back data to a device with a T-mobile integration. Does anybody have experience with this?
    @ibnHamza yes sir, the tb-postgres image
    connected_devices.json is empty, pls give an example
    Anyone using the python client? I can't do s simple call to pull data without this error: AttributeError("'str' object has no attribute 'swagger_types'"). I am hitting a 3.2 PE instance and I installed the client with pip.
    I can otherwise use the API to add entities etc, just can't pull any data for example: get_user_devices()

    The response indicates data was found...total_elements = 2 but the data element is empty:

    {'data': [AttributeError("'str' object has no attribute 'swagger_types'"),
    AttributeError("'str' object has no attribute 'swagger_types'")],
    'has_next': False,
    'total_elements': 2,
    'total_pages': 1}

    hello! I'm just starting out using thingsboard cloud. I have a rule chain that uses the rest api call node. how can i see the response message of this api call? Can i write it to the log and then somehow access it via the frontend?
    Seiko Santana
    can i send a telemetry data with the ThingsBoard API for a specific timestamp?
    1 reply
    Screenshot from 2021-01-04 11-23-20.png
    Can someone tell me how to solve this error?
    how to make map widget access $rootScope?
    Marshall Richards
    Has anyone had problems with launching Thingsboard on Ubuntu 20.04 LTS?
    Muhammad Arsalan
    TB WS Error.png
    Hi guys, Is anyone facing the web socket issue with TB 3.2 PE
    Holger Brandl
    Hi there, I have telemetry data of the form
    "sensor_id": "foo",
    "sample": {
    "unit": "ma",
    "value": 11.098901
    How can I plot the value in a timeseries chart? I've tried a custom transformation function, but this does not seem to work (see screenshot).
    Tomas Mažvila
    Hello. I know what to connect device to thingsboard iot-gateway I need to edit configuration file and restart thingsboard-gateway service. Is there a way to do this without restarting thingsboard-gateway service?
    Tomas Mažvila

    Hello. I know what to connect device to thingsboard iot-gateway I need to edit configuration file and restart thingsboard-gateway service. Is there a way to do this without restarting thingsboard-gateway service?

    nvm i found it. It its possible by rtc requests. But requires a little bit of tinkering with python code :S

    Ayman mohammed zaki
    @holgerbrandl , json is not allowed in telemetry data , it is a key value in db .
    Holger Brandl
    @ayman.m.zaki_gitlab Thanks for the help. I did not know about this constraint. I've also tried to parse the value to extract the my readout with JSON.parse(value).value but this fails else well. Isn't the transformer supposed to allow taking the selected field value and applying some arbitrary post-processing to it?
    4 replies
    Guys someone can show me how to run thingsboard container using mqtts? even with simple self sign certificate.
    Hello there! I would like to ask if it is possible to have a HA setup with 2 standalone Thingsboard instances (monolith approach)? It is not clear from the documentation as HA is only mentioned to be there in microservices architecture.
    Hi everyone, is it possible to configure a Tenant level Domain so each domain can belong to a separate tenant and have browser show diff domains for each ?
    Hi guy hope you all good. I have à trouble and i don't see any post which could help me. I tried to get token access to API but I always have an authentification failed error. If anyone can get me support would be great
    Here you can see how I parse a JSON and just get the right value
    I m using it a lot, as almost all the telemetry I m getting is in JSON format
    By the way, I need to access to obtain the device profile Id in a Widget associated to a specific name (in this case, DEVICE PROFILE = "CAMERA"). Does any of you know how I can get it?
    Sergey Kurbanov
    Hi! Who use tb with kafka? I have strange problem, Kafka lag by consumer group constantly grow up. :(
    1 reply
    Sergey Kurbanov
    Oh! Thanks! I subscribe on this issue
    Sergey Kurbanov
    No I have installation in k8s, I update my Kafka server but this not help
    My lag still grow up
    Sergey Kurbanov
    If I use 2 tb-node , but I’d I use only one node Kafka working without problem... wtf consumer group grow up just only for second node “monolith”

    I am using a Knob Control in thingsboard to control something in RaspberyPI. I am using python for the device side coding. I am using HTTP Rest APIs for using RPC:

    When I do a GET on this URL https://app.iiotnext.com:443/api/v1/6QG455bxqHPChit753S5/rpc

    The response I get is :

    I know I should respond back with a POST on this URL:

    But what should the response message JSON?