Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
    Shane van Jaarsveldt


    @shanevanj I am using version 2.3.1 snapshot is the mqtt disconnecting issue found in 2.3.1 also?

    This is the issue I found relating to disconnects - AFAIK my 2.3 instance does not show this issue

    @shanevanj I was able to send data from a device to thingsboard and post that data to a third party application using rest api, Is it possible to send control commands back to the device from the third party application?
    This is the API section that shows it - I have never used so YMMV - http://<serverIP>:8080/swagger-ui.html#!/device-api-controller/postRpcRequestUsingPOST


    Hi guys. How to make the client able to add a device from the dashboard after self registering in the platform?


    Michael Hamburger
    @JarrodLodge @skc_shishir_twitter Thanks for your answer! I thought that developers do also read in gitter. We are a PE user but I am not sure if there is a dedicated PE support page.
    Hi all,
    how can share my dashboard in public along with devices and assest
    @shanevanj the disconnecting happens when I try to connect two devices using mqtt, so the two devices will try to connect with the same user name, isn't this allowed?
    Danilo Mota
    @hasikp1 When using MQTT, every device should connect with it's unique access key as username
    @harikrishna6050 Your dashboard, devices and assets have to be made available to the Public customer
    Shane van Jaarsveldt
    @hasikp1 Nope - you need to disconnect before connecting a new device - secondly there is no benefit to connecting using the same name as you will never be able to tell which telemetry cam from which device. I use the deviceID (if it has one) or the MAC address of the device (on ETH) as a username and then its always unique.
    Hi, I am trying to setup an Integration from PE to a Private TTN application with MQTT over SSL on port 8883. Wondering if anyone had the success. Here is the error I get.
    java.lang.RuntimeException: Failed to connect to MQTT broker at <mycompany>.thethings.industries:8883.
    at org.thingsboard.server.service.integration.mqtt.AbstractMqttIntegration.initClient(AbstractMqttIntegration.java:182)
    at org.thingsboard.server.service.integration.mqtt.basic.BasicMqttIntegration.init(BasicMqttIntegration.java:71)
    at org.thingsboard.server.service.integration.DefaultPlatformIntegrationService.initIntegration(DefaultPlatformIntegrationService.java:599)
    at org.thingsboard.server.service.integration.DefaultPlatformIntegrationService.getOrCreateThingsboardPlatformIntegration(DefaultPlatformIntegrationService.java:579)
    at org.thingsboard.server.service.integration.DefaultPlatformIntegrationService.lambda$createIntegration$0(DefaultPlatformIntegrationService.java:245)
    at com.google.common.util.concurrent.TrustedListenableFutureTask$TrustedFutureInterruptibleTask.runInterruptibly(TrustedListenableFutureTask.java:111)
    at com.google.common.util.concurrent.InterruptibleTask.run(InterruptibleTask.java:58)
    at com.google.common.util.concurrent.TrustedListenableFutureTask.run(TrustedListenableFutureTask.java:75)
    at java.util.concurrent.ForkJoinTask$RunnableExecuteAction.exec(ForkJoinTask.java:1402)
    at java.util.concurrent.ForkJoinTask.doExec(ForkJoinTask.java:289)
    at java.util.concurrent.ForkJoinPool$WorkQueue.runTask(ForkJoinPool.java:1056)
    at java.util.concurrent.ForkJoinPool.runWorker(ForkJoinPool.java:1692)
    at java.util.concurrent.ForkJoinWorkerThread.run(ForkJoinWorkerThread.java:157)
    The same error comes with the "TheThingsNetwork" Integration available in PE edition. I have allowed "All Traffic" from the AWS Instance running the TB PE Edition.
    Here is the error from the log file.
    2019-09-01 00:02:11,722 [nioEventLoopGroup-4-2] WARN i.n.channel.DefaultChannelPipeline - An exceptionCaught() event was fired, and it reached at the tail of the pipeline. It usually means the last handler in the pipeline did not handle the exception.
    io.netty.handler.codec.DecoderException: javax.net.ssl.SSLException: Received fatal alert: handshake_failure
    at io.netty.handler.codec.ByteToMessageDecoder.callDecode(ByteToMessageDecoder.java:472)
    at io.netty.handler.codec.ByteToMessageDecoder.channelRead(ByteToMessageDecoder.java:278)
    at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:359)
    at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:345)
    at io.netty.channel.AbstractChannelHandlerContext.fireChannelRead(AbstractChannelHandlerContext.java:337)
    at io.netty.channel.DefaultChannelPipeline$HeadContext.channelRead(DefaultChannelPipeline.java:1408)
    at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:359)
    at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:345)
    at io.netty.channel.DefaultChannelPipeline.fireChannelRead(DefaultChannelPipeline.java:930)
    at io.netty.channel.nio.AbstractNioByteChannel$NioByteUnsafe.read(AbstractNioByteChannel.java:163)
    at io.netty.channel.nio.NioEventLoop.processSelectedKey(NioEventLoop.java:677)
    at io.netty.channel.nio.NioEventLoop.processSelectedKeysOptimized(NioEventLoop.java:612)
    at io.netty.channel.nio.NioEventLoop.processSelectedKeys(NioEventLoop.java:529)
    at io.netty.channel.nio.NioEventLoop.run(NioEventLoop.java:491)
    at io.netty.util.concurrent.SingleThreadEventExecutor$5.run(SingleThreadEventExecutor.java:905)
    at io.netty.util.concurrent.FastThreadLocalRunnable.run(FastThreadLocalRunnable.java:30)
    at java.lang.Thread.run(Thread.java:748)
    Daya Naidoo
    Hi there, i have Thingsboard running on AWS and currently using the Capturs and SimplePack devices. I need direction with the Rules Chain. Basically when the device is triggered, i would need to send out a notification
    i think its problem with ssl handshake. with http, it works fine
    Sourav Ghosh
    Hiya!! Anyone faced issue while using the digital gauge (donut type)? I can see the gauge skips update every alternate value of the telemetry (i'm sending a simple temperature vale as JSON). The card type {simple card gadget} seems to work fine, in the same dashboard, with the same telemetry data (no skip). Thoughts?
    thank you yuva!
    Guillaume SOULERES
    Hi everyone ! On my dashboard, I am accessing the telemetry of my Entity Views by clicking on them on a hierarchy widget. Would it be possible to change the name of these Entity Views from the dashboard also ?
    Shane van Jaarsveldt

    Hiya!! Anyone faced issue while using the digital gauge (donut type)? I can see the gauge skips update every alternate value of the telemetry (i'm sending a simple temperature vale as JSON). The card type {simple card gadget} seems to work fine, in the same dashboard, with the same telemetry data (no skip). Thoughts?

    Have you checked the timescale. it needs to be a realtime not historical timescale?

    Sourav Ghosh

    @shanevanj Thanks, I checked it once again, it's realtime. The problem is, the gauge data does not update every 10 seconds (the frequency of telemetry push), rather every 20 second. The card display, on the other hand, updates every 10 sec. Tried changing the telemetry push frequency also (5 sec, 15 sec), the behavior stays same (gauge data updates every alternate value)


    image link

    Arthur Borges
    It's fine to have one physical device (PLC) sending a single topic containing energy meter information about several meters, or I have to separate one topic per energy meter? I'm having issues to separate the data, as TB PE Converters does not allow sending data from a single topic to multiple devices on the platform.
    I have a big problem... I have a huge private LORAWAN network of nodes for several flower and vegetable farmers for their Greenhouses and Transportation trucks etc... The network layout is as follows
    Jamon Douglas
    I am looking to provision a user and multiple sensors via Thingsboard's API. I have looked at the Swagger docs but there aren't detailed descriptions of what each endpoint does. Can some advise do I need to provision a user in order to register a sensor and send sensor data to the thingsboard api?
    Sourav Ghosh
    @jamondouglas You can try "POST /api/user{?sendActivationMail}" for user provision and "POST /api/device" for device creation. Once device is created, you can use "GET /api/device/{deviceId}/credentials" to get the device token and finally use "POST /api/v1/{deviceToken}/telemetry" to post the data. Hope this helps.
    @AfroJackal Did your post got cut off short?
    I have a problem, Can I create two connections with one access token of specific device?
    Maybe one connection for physical device and one for mobile phone.
    Does anyone know how to change the fontsize of a simple card?
    because the text doesn't fit in the container...
    Also...Does anyone know where can I get info about the valid parameters to use in the Simple Card->Settings tab->widget style?
    because using CSS does nothing
    Hello, i have been trying to achieve two communication using iot gateway with SERVER-SIDE RPC. I have followed the steps mentioned in https://thingsboard.io/docs/iot-gateway/mqtt/#server-side-rpc-commands. When I execute curl -v -X POST -d @rpc-request.json $SERVER_BASE_URL/api/plugins/rpc/twoway/$DEVICE_ID \
    --header "Content-Type:application/json" \
    --header "X-Authorization: Bearer $JWT_TOKEN" in command line, it shows > Content-Length: 78
    • upload completely sent off: 78 out of 78 bytes
      < HTTP/1.1 408
      < X-Content-Type-Options: nosniff
      < X-XSS-Protection: 1; mode=block
      < Cache-Control: no-cache, no-store, max-age=0, must-revalidate
      < Pragma: no-cache
      < Expires: 0
      < Content-Length: 0
      < Date: Tue, 27 Aug 2019 16:14:45 GMT
      < Connection: close
    and my node script does not show any message response.
    Please, any help is appreciated.
    Hey guys, I saw there is a limitation for number of devices for PE (e.g. up to 10 devices for Maker plan). Wondering what is it about exactly cause I have tried CE and found no limitation on number of devices i.e. I managed to add more than 10 devices.
    Sourav Ghosh
    @PAN001 That's how the PE is licensed. With any subscription of PE, you get extra features over CE, but based on your subscription plan, the number of devices and assets will be limited. You have enterprise and perpetual licenses which do not have this limitation on # of devices, though.

    Hiya!! Anyone faced issue while using the digital gauge (donut type)? I can see the gauge skips update every alternate value of the telemetry (i'm sending a simple temperature vale as JSON). The card type {simple card gadget} seems to work fine, in the same dashboard, with the same telemetry data (no skip). Thoughts?

    Any views on this one?

    not working in Desktop TB
    Khalid Almuraee
    Is there a documentation on deploying tb on cassandra cluster with docker ?
    Sourav Ghosh
    @nmahale10 What do you mean "not working"?
    Anyone has any list of supported fonts for TB CE version? I need to change some widgets fonts.
    Is there a way to deploy k8s environment with CassandraDB by kubeadm(not minikube)
    Just PV and PVC , not Storage class
    Hey all,
    i have a question, i wonder reason of mqtt broker chosen. Why did you prefer Netty broker?
    What are the lack of VerneMQ, EMQ or RabbitMQ?
    Could you help me?
    Msalah Bibars
    hi all,
    I am trying to logo in my account , but i can't , it give me the following message: Unable to acquire JDBC Connection; nested exception is org.hibernate.exception.JDBCConnectionException: Unable to acquire JDBC Connection