Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
    Sourav Ghosh

    @shanevanj Thanks, I checked it once again, it's realtime. The problem is, the gauge data does not update every 10 seconds (the frequency of telemetry push), rather every 20 second. The card display, on the other hand, updates every 10 sec. Tried changing the telemetry push frequency also (5 sec, 15 sec), the behavior stays same (gauge data updates every alternate value)


    image link

    Arthur Borges
    It's fine to have one physical device (PLC) sending a single topic containing energy meter information about several meters, or I have to separate one topic per energy meter? I'm having issues to separate the data, as TB PE Converters does not allow sending data from a single topic to multiple devices on the platform.
    I have a big problem... I have a huge private LORAWAN network of nodes for several flower and vegetable farmers for their Greenhouses and Transportation trucks etc... The network layout is as follows
    Jamon Douglas
    I am looking to provision a user and multiple sensors via Thingsboard's API. I have looked at the Swagger docs but there aren't detailed descriptions of what each endpoint does. Can some advise do I need to provision a user in order to register a sensor and send sensor data to the thingsboard api?
    Sourav Ghosh
    @jamondouglas You can try "POST /api/user{?sendActivationMail}" for user provision and "POST /api/device" for device creation. Once device is created, you can use "GET /api/device/{deviceId}/credentials" to get the device token and finally use "POST /api/v1/{deviceToken}/telemetry" to post the data. Hope this helps.
    @AfroJackal Did your post got cut off short?
    I have a problem, Can I create two connections with one access token of specific device?
    Maybe one connection for physical device and one for mobile phone.
    Does anyone know how to change the fontsize of a simple card?
    because the text doesn't fit in the container...
    Also...Does anyone know where can I get info about the valid parameters to use in the Simple Card->Settings tab->widget style?
    because using CSS does nothing
    Hello, i have been trying to achieve two communication using iot gateway with SERVER-SIDE RPC. I have followed the steps mentioned in https://thingsboard.io/docs/iot-gateway/mqtt/#server-side-rpc-commands. When I execute curl -v -X POST -d @rpc-request.json $SERVER_BASE_URL/api/plugins/rpc/twoway/$DEVICE_ID \
    --header "Content-Type:application/json" \
    --header "X-Authorization: Bearer $JWT_TOKEN" in command line, it shows > Content-Length: 78
    • upload completely sent off: 78 out of 78 bytes
      < HTTP/1.1 408
      < X-Content-Type-Options: nosniff
      < X-XSS-Protection: 1; mode=block
      < Cache-Control: no-cache, no-store, max-age=0, must-revalidate
      < Pragma: no-cache
      < Expires: 0
      < Content-Length: 0
      < Date: Tue, 27 Aug 2019 16:14:45 GMT
      < Connection: close
    and my node script does not show any message response.
    Please, any help is appreciated.
    Hey guys, I saw there is a limitation for number of devices for PE (e.g. up to 10 devices for Maker plan). Wondering what is it about exactly cause I have tried CE and found no limitation on number of devices i.e. I managed to add more than 10 devices.
    Sourav Ghosh
    @PAN001 That's how the PE is licensed. With any subscription of PE, you get extra features over CE, but based on your subscription plan, the number of devices and assets will be limited. You have enterprise and perpetual licenses which do not have this limitation on # of devices, though.

    Hiya!! Anyone faced issue while using the digital gauge (donut type)? I can see the gauge skips update every alternate value of the telemetry (i'm sending a simple temperature vale as JSON). The card type {simple card gadget} seems to work fine, in the same dashboard, with the same telemetry data (no skip). Thoughts?

    Any views on this one?

    not working in Desktop TB
    Khalid Almuraee
    Is there a documentation on deploying tb on cassandra cluster with docker ?
    Sourav Ghosh
    @nmahale10 What do you mean "not working"?
    Anyone has any list of supported fonts for TB CE version? I need to change some widgets fonts.
    Is there a way to deploy k8s environment with CassandraDB by kubeadm(not minikube)
    Just PV and PVC , not Storage class
    Hey all,
    i have a question, i wonder reason of mqtt broker chosen. Why did you prefer Netty broker?
    What are the lack of VerneMQ, EMQ or RabbitMQ?
    Could you help me?
    Msalah Bibars
    hi all,
    I am trying to logo in my account , but i can't , it give me the following message: Unable to acquire JDBC Connection; nested exception is org.hibernate.exception.JDBCConnectionException: Unable to acquire JDBC Connection
    could you help me please, with many thanks

    Hi all,

    I have another question again about mqtt broker:) What is the supported mqtt version (3.1, 3.1.1 or 5.0) ? I can not find a information about this matter in the web. The web says only Qos 0 and Qos 1 supports. Anyone know the supported mqtt version?


    Hi all, my trip animation widget crashes the browser when I load more than seven days history

    Hi everyone,

    I have installed thingsboard PE on window 10. I did all the steps given and it was working last week..but now from last 3 days its showing server is up and running and dashboard is not opening.

    Kindly help..
    I am not getting how to fix this issue..
    @techiesourav_twitter Thanks Sourav.
    Is it possible to make a gateway/hub with a raspberry and connect it to an app
    Smartlife/Tuya smart for example
    Hi, I'd like to report an error on a Gateway running at RaspberryPi
    o.t.gateway.GatewayApplication - Unable to start embedded container; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'tomcatEmbeddedServletContainerFactory' defined in class path resource [org/springframework/boot/autoconfigure/web/EmbeddedServletContainerAutoConfiguration$EmbeddedTomcat.class]: Initialization of bean failed; nested exception is org.springframework.beans.factory.UnsatisfiedDependencyException: Error creating bean with name 'org.springframework.boot.autoconfigure.web.HttpEncodingAutoConfiguration': Unsatisfied dependency expressed through constructor parameter 0; nested exception is org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'spring.http.encoding-org.springframework.boot.autoconfigure.web.HttpEncodingProperties': Initialization of bean failed; nested exception is java.lang.NoClassDefFoundError: javax/xml/bind/ValidationException
    what could it be?
    my java version is: openjdk version "11.0.3" 2019-04-16
    Hi, I have some doubts in email notification in thingsboard.
    I am created one rule chain. And set some conditions. if success means get email notification. How to check its working or not.
    how to get historical data in PDF/EXCEL format in Thingsboard Desktop version..
    Sourav Ghosh
    @Naveenkumarg24 What do you mean how to check? Can you not simulate the condition you have set for the email notification and check whether the email is being received? Did you try that already and it did not work? Please explain a bit more for better understanding.
    @nmahale10 Good Question, let me know if you get the answer.
    Hi. I am created one Rule Chain. If condition is success means create a email notification.