Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
    I am created one rule chain. And set some conditions. if success means get email notification. How to check its working or not.
    how to get historical data in PDF/EXCEL format in Thingsboard Desktop version..
    Sourav Ghosh
    @Naveenkumarg24 What do you mean how to check? Can you not simulate the condition you have set for the email notification and check whether the email is being received? Did you try that already and it did not work? Please explain a bit more for better understanding.
    @nmahale10 Good Question, let me know if you get the answer.
    Hi. I am created one Rule Chain. If condition is success means create a email notification.
    How to configure email notification? any example or tutorials available kindly share the link
    EXCEL/PDF expoert is possible in PE cloud vesrion ..but same is not applicable in PE desktop..
    Geir Andersen
    Hi, I'm trying to avoid triggering alarm when there are already an active alarm for the same device and alarm type. Any ideas?

    Hey everyone,
    I am not getting message value in my device application script when I send a post command to the device. I followed the exact sample from mqtt extension configuration's server side rpc example https://thingsboard.io/docs/iot-gateway/mqtt/#server-side-rpc-commands
    I am running a node script which sends a connect message to gateway. I am able to see devicesOnline = 1 in Latest Telemetry, but when I am send a post command like this one curl -v -X POST -d @rpc-request.json $SERVER_BASE_URL/api/plugins/rpc/twoway/$DEVICE_ID
    --header "Content-Type:application/json"
    --header "X-Authorization: Bearer $JWT_TOKEN" my device application's node script gives the output:
    request.topic: sensor/SN-001/request/echo/5
    response.topic: sensor/SN-001/response/echo/5

    '5' is the request id that increments after every post command, but the request.body always shows empty, i take it should display 'Hello' as per the request body's "method.params" but nothing appears.
    I also installed Thingsboard IoT gateway 2.2.1 release.
    Any help is appreciated.

    Has anyone had success in platform integration with MQTTS?
    Hi.. How to enable or set Email Notification in thingsbaord
    How to add Rule Node in Create/Clear Alarm & Send Email.
    Deploy cassandra cluster in K8s environment, I find the instruction https://github.com/IBM/Scalable-Cassandra-deployment-on-Kubernetes
    Hi there, is there anybody working with RPC capabilities of thingsboard? I need help.
    @skc_shishir_twitter do you know?
    Sourav Ghosh
    @Naveenkumarg24 Check the tutorial in https://thingsboard.io/docs/getting-started-guides/helloworld/, if you have any specific issue, please let us know.
    hi i am check the tutorial in https://thingsboard.io/docs/user-guide/rule-engine-2-0/tutorials/send-email/ , email notification
    SMTP settings sendgrid is free or cost
    Hi, I am not able to run thingsboard behind nginx proxy ..
    Eg. /thingsboard/login is redirected to /login always
    Any help ??
    I am alreday using thingsboard professional version. and enable email notification option in that portal.
    Do we have any aggregated widgets to show on dashboard to represent no.of devices active/inactive?
    Mujahed Altahle

    Hello everybody,
    I have wrote a tool for load testing for Thingsboard’s MQTT for the company I work for. I’m a system administrator and coding is not my main focus so we have decided to make this tool open source


    The main difference between this one and the the by thingboard development team that their tool doesn’t offer away to bulk remove/ delete the testing devices if a big test fails at any point, and if you have thousands of devices created you have to delete them manually. but in this script I’m using an external MySQL db to store created devices IDs and token so it is easier to deal with devices as you want
    I hope I find any contributors here and all feedback are very appreciated

    @directcontrol I was looking for this too, but did not find a way to achieve it using only Thingsboard - in the end we used a mosquitto broker for MQTTS and the Thingsboard gateway connects to it on a non-secure port but is running on the same server (or a private network). Maybe this will be supported in newer Thingsboard versions?
    Adile Çetinkaya
    Hii everybody. Has anybody tried RAK833 gateway with thingsboard?
    Hii.... How to sent mail notification in thingsboard.
    Hi! Does anyone know how to work with DOWNLINK messages in LoRaWAN and The Things Network?
    hhow to send data to pdf or excel in TB PE..
    desktop version
    Tihomir Tonchev

    Hi guys, I am trying to use kafka extension following this tutorial https://thingsboard.io/docs/samples/analytics/spark-integration-with-thingsboard/#step-1-kafka-plugin-configuration
    But when I added the dependance to application/pom.xml and build the project I get

    [ERROR] Failed to execute goal on project application: Could not resolve dependencies for project org.thingsboard:application:jar:2.4.1: Failure to find org.thingsboard.extensions:extension-kafka:jar:2.4.1 in http://repo.jenkins-ci.org/releases was cached in the local repository, resolution will not be reattempted until the update interval of jenkins has elapsed or updates are forced -> [Help 1]

    The dependancy is really not in repo.jenkins-ci.org. Has somebody else encountered this problem

    Hi... how to bind data in widgets using API?
    Tihomir Tonchev
    if somebody else is fighting with the same problem: It looks like the kafka-extension has been removed after v 1.4 and now it is part of rule engine -> external
    hi. need some wisdom. i have install professional edition with 10 licenses for testing. using docker i downloaded and its working. when i restart. it keeps on failing because Terminating application due to critical License Error ACTIVE_INSTANCES_CAPACITY_EXCEEDED(104) ... i have to go a manually disable or delete the instance from the control panel. am i able to reset these instance licences for reuse when i restart the container ? thank you in advance
    ^having the same issue here using AWS EC2.
    @adilecetinkaya I use a number of RAK833 gateways. The actual gateway shouldn't have any bearing on thingsboard, however.
    I just deleted the instance in the thingsboard backend, restarted the AWS instance, and all good.
    Kino Chou

    Hi, I install tb-node by docker.
    It has error:
    Starting ThingsBoard installation ...
    Error: Could not find or load main class org.springframework.boot.loader.PropertiesLauncher

    I opened the jar. It is the same as other services like tb-http-transport, tb-mqtt-transport. They have the BOOT-INF/org/springframework/boot/loader/PropertiesLauncher.class
    Can anybody help me?

    Hey everybody, i'm looking for a solution, how to interrupt lines in the time series chart, if there is no data for e.g. 20 minutes. see for example picture above, where i want to remove the line between the two temperature curves. i tried to include NaN values, but that makes it worse. Does anybody has an idea? Thanks
    Hi everyone, how to bind data in widget(through API)?
    Danilo Mota


    Do we have any aggregated widgets to show on dashboard to represent no.of devices active/inactive?

    No, but you can use the standard cards and server variables to achieve this
    You will also need to create this count logic in the Rule Chains

    Hello, I am having an issue with a thingsboard professional demo instance, my trial expired, but it looks as if the instance is still trying to contact my mqtt broker. I would have assumed that when my trial expired that the instance would have been removed. Can anyone give me any help with this, or do I wait for support to get back to me?
    Guillaume SOULERES
    Hi everyone, we have been running our TB PE instance on AWS for a few months now. We only have a few dozens LoRaWAN sensors (small data packets), but it seems we have reached 20 GB on our EC2 instance...
    anyone has a clue to why it happens, and where I should check ?
    Guillaume SOULERES
    looks like my database is huge
    :/$ sudo du -sh ./var/lib/postgresql/9.5/main/base/16384
    16G ./var/lib/postgresql/9.5/main/base/16384
    Hi. I've set up a Thingsboard PE in my system. I followed the procedure given in the link https://thingsboard.io/docs/user-guide/mqtt-over-ssl/ for server configuration and I gave the DOMAIN_SUFFIX as "cloud.thingsboard"
    For client configuration I followed the procedure in https://thingsboard.io/docs/user-guide/certificates/ and I gave the DOMAIN_SUFFIX as "cloud.thingsboard" in client side also . I then changed my authentication type in WebUI to X.509 and added the mqttclient.pub.pem key there.
    I ran the python sample script give in https://thingsboard.io/docs/user-guide/certificates/ . I changed hostname in the socket.connect() function to cloud.thingsboard.io and changed the subscription topic according to my device specifications.
    I'm getting a timeout error and I could not see my data getting published.