Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Mujahed Altahle
    @mujahed1987

    Hello everybody,
    I have wrote a tool for load testing for Thingsboard’s MQTT for the company I work for. I’m a system administrator and coding is not my main focus so we have decided to make this tool open source

    https://github.com/wasslz/Thingsboard-Load-Test

    The main difference between this one and the the by thingboard development team that their tool doesn’t offer away to bulk remove/ delete the testing devices if a big test fails at any point, and if you have thousands of devices created you have to delete them manually. but in this script I’m using an external MySQL db to store created devices IDs and token so it is easier to deal with devices as you want
    I hope I find any contributors here and all feedback are very appreciated

    amber-aw
    @amber-aw
    @directcontrol I was looking for this too, but did not find a way to achieve it using only Thingsboard - in the end we used a mosquitto broker for MQTTS and the Thingsboard gateway connects to it on a non-secure port but is running on the same server (or a private network). Maybe this will be supported in newer Thingsboard versions?
    Adile Çetinkaya
    @adilecetinkaya
    Hii everybody. Has anybody tried RAK833 gateway with thingsboard?
    Naveenkumarg24
    @Naveenkumarg24
    Hii.... How to sent mail notification in thingsboard.
    tzeeth
    @tzeeth
    Hi! Does anyone know how to work with DOWNLINK messages in LoRaWAN and The Things Network?
    nmahale10
    @nmahale10
    hhow to send data to pdf or excel in TB PE..
    desktop version
    Tihomir Tonchev
    @ttonchev

    Hi guys, I am trying to use kafka extension following this tutorial https://thingsboard.io/docs/samples/analytics/spark-integration-with-thingsboard/#step-1-kafka-plugin-configuration
    But when I added the dependance to application/pom.xml and build the project I get

    [ERROR] Failed to execute goal on project application: Could not resolve dependencies for project org.thingsboard:application:jar:2.4.1: Failure to find org.thingsboard.extensions:extension-kafka:jar:2.4.1 in http://repo.jenkins-ci.org/releases was cached in the local repository, resolution will not be reattempted until the update interval of jenkins has elapsed or updates are forced -> [Help 1]

    The dependancy is really not in repo.jenkins-ci.org. Has somebody else encountered this problem

    Naveenkumarg24
    @Naveenkumarg24
    Hi... how to bind data in widgets using API?
    Tihomir Tonchev
    @ttonchev
    if somebody else is fighting with the same problem: It looks like the kafka-extension has been removed after v 1.4 and now it is part of rule engine -> external
    geeyen88
    @geeyen88
    hi. need some wisdom. i have install professional edition with 10 licenses for testing. using docker i downloaded and its working. when i restart. it keeps on failing because Terminating application due to critical License Error ACTIVE_INSTANCES_CAPACITY_EXCEEDED(104) ... i have to go a manually disable or delete the instance from the control panel. am i able to reset these instance licences for reuse when i restart the container ? thank you in advance
    tteague
    @illperipherals
    ^having the same issue here using AWS EC2.
    @adilecetinkaya I use a number of RAK833 gateways. The actual gateway shouldn't have any bearing on thingsboard, however.
    tteague
    @illperipherals
    I just deleted the instance in the thingsboard backend, restarted the AWS instance, and all good.
    Kino Chou
    @choudh2011

    Hi, I install tb-node by docker.
    It has error:
    Starting ThingsBoard installation ...
    Error: Could not find or load main class org.springframework.boot.loader.PropertiesLauncher

    I opened the jar. It is the same as other services like tb-http-transport, tb-mqtt-transport. They have the BOOT-INF/org/springframework/boot/loader/PropertiesLauncher.class
    Can anybody help me?

    ebmsh
    @ebmsh
    temp.PNG
    Hey everybody, i'm looking for a solution, how to interrupt lines in the time series chart, if there is no data for e.g. 20 minutes. see for example picture above, where i want to remove the line between the two temperature curves. i tried to include NaN values, but that makes it worse. Does anybody has an idea? Thanks
    Naveenkumarg24
    @Naveenkumarg24
    Hi everyone, how to bind data in widget(through API)?
    Danilo Mota
    @danilomota_gitlab

    @laxmiprasannaBorigi

    Do we have any aggregated widgets to show on dashboard to represent no.of devices active/inactive?

    No, but you can use the standard cards and server variables to achieve this
    You will also need to create this count logic in the Rule Chains

    Jared
    @HansSanitizer
    Hello, I am having an issue with a thingsboard professional demo instance, my trial expired, but it looks as if the instance is still trying to contact my mqtt broker. I would have assumed that when my trial expired that the instance would have been removed. Can anyone give me any help with this, or do I wait for support to get back to me?
    Guillaume SOULERES
    @gsouleres_gitlab
    Hi everyone, we have been running our TB PE instance on AWS for a few months now. We only have a few dozens LoRaWAN sensors (small data packets), but it seems we have reached 20 GB on our EC2 instance...
    anyone has a clue to why it happens, and where I should check ?
    Guillaume SOULERES
    @gsouleres_gitlab
    looks like my database is huge
    :/$ sudo du -sh ./var/lib/postgresql/9.5/main/base/16384
    16G ./var/lib/postgresql/9.5/main/base/16384
    harish2297
    @harish2297
    Hi. I've set up a Thingsboard PE in my system. I followed the procedure given in the link https://thingsboard.io/docs/user-guide/mqtt-over-ssl/ for server configuration and I gave the DOMAIN_SUFFIX as "cloud.thingsboard"
    For client configuration I followed the procedure in https://thingsboard.io/docs/user-guide/certificates/ and I gave the DOMAIN_SUFFIX as "cloud.thingsboard" in client side also . I then changed my authentication type in WebUI to X.509 and added the mqttclient.pub.pem key there.
    I ran the python sample script give in https://thingsboard.io/docs/user-guide/certificates/ . I changed hostname in the socket.connect() function to cloud.thingsboard.io and changed the subscription topic according to my device specifications.
    I'm getting a timeout error and I could not see my data getting published.
    med01
    @zeroun01_gitlab

    Hi,

    I want to use websocket API to get device telemetry values.

    By following the documentation, I connected successfully to server using wss:\

    Then I sent this message :
    {
    tsSubCmds: [
    {
    entityType: "DEVICE",
    entityId: "my-device-id",
    scope: "LATEST_TELEMETRY",
    cmdId: 11,
    keys: "VALVE1,VALVE2,VALVE3,VALVE4,VALVE5,VALVE6," // my telemetry keys
    }
    ],
    historyCmds: [],
    attrSubCmds: []
    }

    I am getting this message as response :
    {
    "subscriptionId": 0,
    "errorCode": 1,
    "errorMsg": "Session meta-data not found!",
    "data": null,
    "latestValues": {}
    }

    Doesn't anyone have any idea about this error ?
    Is there any thing missing in my connection ?

    Thanks,

    Hi,

    I want to use websocket API to get device telemetry values.

    By following the documentation, I connected successfully to server using wss:\

    Then I sent this message :

    {
      tsSubCmds: [
                   {
                    entityType: "DEVICE",
                    entityId: "my-device-id",
                    scope: "LATEST_TELEMETRY",
                    cmdId: 11,
                    keys: "VALVE1,VALVE2,VALVE3,VALVE4,VALVE5,VALVE6," // my telemetry keys
                    }
                 ],
       historyCmds: [],
       attrSubCmds: []
    }

    I am getting this message as response :

    {
      "subscriptionId": 0,
      "errorCode": 1,
      "errorMsg": "Session meta-data not found!",
      "data": null,
      "latestValues": {}
    }

    Doesn't anyone have any idea about this error ?
    Is there any thing missing in my connection ?

    Thanks,

    Naveenkumarg24
    @Naveenkumarg24
    Hii Gud Morning..
    Thingsboard type any admin template available...
    User how to create a our own widgets in new template
    giuseppemr
    @giuseppemr
    Good Morning to everyone. Do you know if there is a place where people upload their custom widgets?
    dongjp
    @dongjp
    Hello, in the CE version, when transport. type = remote is configured in thingsboard. yml, can port 1883 of thingsboard not be monitored?
    Jett Jackson
    @J-tt
    Anyone had to process a totaliser device through a rule chain? Curious how you handled it. (Trying to get amount per data point, eg: subtract data point from it's previous one).
    Ah scratch that, found some documentation on calculating deltas: https://thingsboard.io/docs/user-guide/rule-engine-2-0/tutorials/telemetry-delta-validation/
    Yidnekachew
    @yidnek
    Please Help Im stuck with HTTP responce 500
    image.png
    I'm new to thingsboard, and trying to follow starting guide. check the above image
    harikrishna6050
    @harikrishna6050
    hi everyone...
    can please tell me any one have to idea of...How to use "REFRESH TOKEN" API
    Naveenkumarg24
    @Naveenkumarg24
    hi everyone...
    can please tell me user can create a own template. How to create a new widgets?
    harikrishna6050
    @harikrishna6050
    @gsouleres_gitlab switch off the DEBUG mode option in all RULECHAIN,INTEGRATION,DATA CONVERTERS
    @J-tt the document is correct process to calculate the totaliser value....the process is subtract the present value to previous value , the output value is store in one variable and next packet is comes subtract formula and add the result to the previous result it comes output of the DEVICE TOTALISER
    ebmsh
    @ebmsh

    anybody knows how to update the deviceType in the rule chain and save it? I tried a script:
    IN
    {
    "deviceType": "unknownSensor",
    "deviceName": "JonDoe"
    }

    OUT
    {
    "deviceType": "NewSensor",
    "deviceName": "JonDoe"
    }
    i tried "save telemetry" and "save attributes", but the device is still of type "unknownSensor" afterwards

    Guillaume SOULERES
    @gsouleres_gitlab
    can't you do it in the Data Converter?
    ebmsh
    @ebmsh
    i need to do an API call to get the desired deviceType which exceeds the 100ms limit by far
    Mike2912
    @Mike2912

    Hi everyone,
    has someone ever tried to visualize "speed" or "height" or something else as a color on a route map?
    I'm searching for something like this: https://images.app.goo.gl/m6NiKBGtgiD7AT7p6

    Thanks a lot
    Mike

    pallavi Gaikwad
    @pallavip_gitlab
    Hi everyone,
    anybody knows how to publish value from rule chain to time series??
    Guillaume SOULERES
    @gsouleres_gitlab
    have you tried the "Save to timeseries" node ?
    pallavi Gaikwad
    @pallavip_gitlab
    No