Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
    how to use roundSwitch

    Ive just started using PE MQTT integration and autocreating new devices based on the message content. Issue I have is that new devices show up in the Customer Hierarchy with telementry data but not in the devices section. as they arent in the devices section, I cant add the telemetry to a dashboard.
    Has anyone had this issue or can recommend how to ensure new devices are created properly ?

    Just found out that I had to login as Customer admin for the Customer with the new created Devices assigned to see them in the Devices section of the menu (instead of being logged in as Tenant Admin). can now add to dashboards and see the Device telemetry during Alias setup.

    Hi guys, just found this group when searching for an iOT forum/community. Can one of you guide me in the correct direction? I have some very basic hardware and software questions related to a project I am currently working on
    hi all
    im new to tb
    Bryam Abril
    What is the difference between PE and to download the normal application for developers
    @hasikp1 ya possible In rule chain configurations use "latest time series" node
    @all/ hi all i am facing one problem in "Data converters" that is i already create one Data convertor is running very well but add some extra code in same DC, click "TEST" button it shows "javax.script.ScriptException: delight.nashornsandbox.exceptions.ScriptCPUAbuseException: Script used more than the allowed [100 ms] of CPU time." How can solve this problem
    Which version of tb-gateway is recommended for use currently? are the python implementations to be used or is it ?
    Hello, is there functionality to change timewindow from custom widget?
    • i mean to change timewindow interval from custom widget
    Mikael Falkvidd
    What can I do to troubleshoot this error message?
    can anyone help me with the best way to move a current thingsboard install from one computer to another with out having to rebuild all the devices and dashboards?
    Kino Chou
    Hi, I'd like to modify some code in dao project.
    How could I run test only dao project?
    I executed command: mvn test -pl dao
    Maven reported error:
    [ERROR] Failed to execute goal on project dao: Could not resolve dependencies for project org.thingsboard:dao:jar:2.4.2: The following artifacts could not be resolved: org.thingsboard.common:data:jar:2.4.2, org.thingsboard.common:message:jar:2.4.2, org.thingsboard.common:dao-api:jar:2.4.2, org.thingsboard.common:util:jar:2.4.2: Failure to find org.thingsboard.common:data:jar:2.4.2 in was cached in the local repository, resolution will not be reattempted until the update interval of central has elapsed or updates are forced
    Kino Chou
    @choudh2011 Hello, I solved this problem by executing: mvn install.
    Roen Ylagan
    Hi guys. I'm trying to understand where in thingsboard code is passing the environment variables LOADER_PATH and SQL_DATA_FOLDER. I cannot find in the applicable code a reference to where this is being used. Im just seeing the environment variable declarations.
    Geir Andersen
    @Chris-O2 Do you have any link to instructions how to autocreate new devices? I have Thingsboard PE.
    @mfalkvidd I got the same error message
    Info on autocreating devices is in the Integration docs (PE Edition).
    Read the whole doc but relevent section is in Convertor Output. When the Convertor output is processed by TB, a new Device or Asset is created if required for the telemetry/attributes to be assigned from the output message.
    If you are using TB CE, you will have to send a telemetry message to TB via the API
    Then use Rules engine to create required devices / assets via API.
    Does anyone know if Thingsboard supports Single Sign On / SAML / AD etc ? we have a customer that would like central user management.
    another question: is there a place I can switch off the Entity name breadcrumb at the top of the page for Dashboards ? as in image below
    Geir Andersen
    @Chris-O2, now I have something to learn during the christmas holyday :-) Thanks, and have a merry christmas!
    HI, there! Is some way for the customer to edit the device name some something similar? The customer send the devices to his clients and wants to personalize the devices to spot more easily their name
    Maybe use the Device Label field and show this field in the Device Admin Table ?
    I havent been able to use ${entityLabel} tag yet in the the Wiget name yet which is a problem for me building the UI.
    @Chris-O2 I do not know what is Device Admin table :( In the map Widget I'm able to customize the name of each marker
    ${entityName}: (${capacity} %, ${Firma_client}, ${Firma_client_1})
    Stefan Roßmann
    Hi everyone, I am looking for a solution to "Remote login" to Thingsboard. I would like to embed a Dashboard into a website without login to Thingsboard. I don't want to make the Dashboard and the Devices public.
    Kevin Cando
    Hi has anyone made a personalized widget??
    Hi EveryOne, Dashboard Import in to a thingsboard instance expects all "Entity Aliases" to be resolved. Is there a way to bypass the validations during the Import? Because I would like to Import the dashboard on a fresh thingsboard instance even before adding all assets and Devices .
    George Manthos
    Merry Christmas to everybody.
    I cant send more than 100 character from MQTT, how to increase this value?
    Anyone encountered below error in thingsboard?
    WARN o.apache.kafka.clients.NetworkClient - [Consumer clientId=tb-node-54dcbbb698-nfhg6, groupId=tb-node] 30 partitions have leader brokers without a matching listener, including [tb.transport.api.requests-0, tb.transport.api.requests-5, tb.transport.api.requests-10, tb.transport.api.requests-20, tb.transport.api.requests-15, tb.transport.api.requests-25, tb.transport.api.requests-26, tb.transport.api.requests-9, tb.transport.api.requests-11, tb.transport.api.requests-16]
    hello all :) I ahve a quick question. I am using sim7020E for mqtt conenction with thigsboard and succesfully connect to the mqtt broker. But, cannot subsribe or publish to a topic although using the sutrcutre required. Anyone achieved to connect with sim 7020E?
    @Chris-O2 Hi Chris, ever got an answer on this or did you find a solution/workaround ? I'm facing the same question.
    I'm referring to the CBOR format.
    Damian X. Garcia
    Hi all, does anyone know how to add different actions to a custom menu-like widget? What should I put in my self.actionSources function to publish one event per menu item and how should I bind them? I couldn't find anything in the documentation. Thank you
    @woff3d Hi, yes we did find a way re CBOR decoding although didntr find how to do this with an external library. Have a look at our code at
    We used code from
    @Chris-O2 Hi Chris, thanks. Great. Well documented. Interesting approach. I'll dig some deeper into it.
    Jesus Suarez
    How can I change port 8080 to 80 in an instance with ubuntu?

    says this: Connector configured to listen on port 80 failed to start

    but it is a totally new ubuntu installation, it has nothing else installed.

    Damian X. Garcia
    @JesusSuarez_twitter take a look at your /usr/share/thingsboard/conf/thingsboard.yml file. Update the line stating
    port: "${HTTP_BIND_PORT:8080}"
    with your preferred port
    Jesus Suarez

    @dexequiel87 How disappointed I am of this software.

    I just tried using this guide on a newly installed server with ubuntu.

    and when I change the port on thingsboard.yml does nothing

    it just says that the port is already in use, and there is nothing running in port 80

    Bad software and bad support. There is nothing on the internet about how to fix it.

    @dexequiel87 It was the first thing I did and it never works. It simply says that the port is already in use, but nothing is working on this port.
    Jesus Suarez
    Is there anyone on this planet able to help me solve this?
    Damian X. Garcia
    @JesusSuarez_twitter I am new to thingsboard too. I just installed it using the same guide on my local Ubuntu 18.04 and it worked. I suggest you to look at your ports by using the command
    nmap localhost
    Jesus Suarez
    This is what it says: Connector configured to listen on port 80 failed to start
    ThingsBoard installation failed!