Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
    George Manthos
    I cant send more than 100 character from MQTT, how to increase this value?
    Anyone encountered below error in thingsboard?
    WARN o.apache.kafka.clients.NetworkClient - [Consumer clientId=tb-node-54dcbbb698-nfhg6, groupId=tb-node] 30 partitions have leader brokers without a matching listener, including [tb.transport.api.requests-0, tb.transport.api.requests-5, tb.transport.api.requests-10, tb.transport.api.requests-20, tb.transport.api.requests-15, tb.transport.api.requests-25, tb.transport.api.requests-26, tb.transport.api.requests-9, tb.transport.api.requests-11, tb.transport.api.requests-16]
    hello all :) I ahve a quick question. I am using sim7020E for mqtt conenction with thigsboard and succesfully connect to the mqtt broker. But, cannot subsribe or publish to a topic although using the sutrcutre required. Anyone achieved to connect with sim 7020E?
    @Chris-O2 Hi Chris, ever got an answer on this or did you find a solution/workaround ? I'm facing the same question.
    I'm referring to the CBOR format.
    Damian X. Garcia
    Hi all, does anyone know how to add different actions to a custom menu-like widget? What should I put in my self.actionSources function to publish one event per menu item and how should I bind them? I couldn't find anything in the documentation. Thank you
    @woff3d Hi, yes we did find a way re CBOR decoding although didntr find how to do this with an external library. Have a look at our code at
    We used code from
    @Chris-O2 Hi Chris, thanks. Great. Well documented. Interesting approach. I'll dig some deeper into it.
    Jesus Suarez
    How can I change port 8080 to 80 in an instance with ubuntu?

    says this: Connector configured to listen on port 80 failed to start

    but it is a totally new ubuntu installation, it has nothing else installed.

    Damian X. Garcia
    @JesusSuarez_twitter take a look at your /usr/share/thingsboard/conf/thingsboard.yml file. Update the line stating
    port: "${HTTP_BIND_PORT:8080}"
    with your preferred port
    Jesus Suarez

    @dexequiel87 How disappointed I am of this software.

    I just tried using this guide on a newly installed server with ubuntu.

    and when I change the port on thingsboard.yml does nothing

    it just says that the port is already in use, and there is nothing running in port 80

    Bad software and bad support. There is nothing on the internet about how to fix it.

    @dexequiel87 It was the first thing I did and it never works. It simply says that the port is already in use, but nothing is working on this port.
    Jesus Suarez
    Is there anyone on this planet able to help me solve this?
    Damian X. Garcia
    @JesusSuarez_twitter I am new to thingsboard too. I just installed it using the same guide on my local Ubuntu 18.04 and it worked. I suggest you to look at your ports by using the command
    nmap localhost
    Jesus Suarez
    This is what it says: Connector configured to listen on port 80 failed to start
    ThingsBoard installation failed!
    22/tcp open ssh
    53/tcp open domain
    5432/tcp open postgresql
    Ubuntu 16.04.4 LTS
    Damian X. Garcia
    do you have root credentials? Try by running nmap as super admin
    sudo nmap localhost
    Jesus Suarez
    It is the same result.
    :'( I'm going crazy..
    Damian X. Garcia
    What level of expertise do you have using Ubuntu? I would suggest to run the command
    sudo service thingsboard status
    (but I don't know if you did that already)
    Jesus Suarez

    service thingsboard status
    ● thingsboard.service - thingsboard
    Loaded: loaded (/lib/systemd/system/thingsboard.service; enabled; vendor preset: enabled)
    Active: active (running) since lun 2019-12-30 04:35:58 CET; 17min ago
    Main PID: 2203 (thingsboard.jar)
    CGroup: /system.slice/thingsboard.service
    ├─2203 /bin/bash /usr/share/thingsboard/bin/thingsboard.jar
    └─2218 /usr/bin/java -Dsun.misc.URLClassPath.disableJarChecking=true -Dplatform=deb -Dinstall.data_dir=/usr/share/thingsboard/data -Xloggc:/var/log/thingsboa

    dic 30 04:37:27 ns377766 thingsboard.jar[2203]: "value" : 100,
    dic 30 04:37:27 ns377766 thingsboard.jar[2203]: "description" : "Devices amount limitation"
    dic 30 04:37:27 ns377766 thingsboard.jar[2203]: },
    dic 30 04:37:27 ns377766 thingsboard.jar[2203]: "whitelabeling" : {
    dic 30 04:37:27 ns377766 thingsboard.jar[2203]: "value" : true,
    dic 30 04:37:27 ns377766 thingsboard.jar[2203]: "description" : "White-labeling feature"
    dic 30 04:37:27 ns377766 thingsboard.jar[2203]: }
    dic 30 04:37:27 ns377766 thingsboard.jar[2203]: }
    dic 30 04:37:27 ns377766 thingsboard.jar[2203]: Initialized ThingsBoard License Client with instanceId [SRbew3mplIhFX1Ivzkl9]
    dic 30 04:38:40 ns377766 thingsboard.jar[2203]: Stopping ThingsBoard License Client...

    Damian X. Garcia
    it looks like the service is running already. That's why it fails to start again
    Jesus Suarez

    service thingsboard stop



    :: ThingsBoard Professional Edition :: (v2.4.2.1PE)

    Connector configured to listen on port 80 failed to start
    ThingsBoard installation failed!

    Damian X. Garcia
    were you able to stop the service without root credentials?
    Jesus Suarez
    yes, I use the root user.
    Damian X. Garcia
    we can continue trying to make it work in a private chat
    Jesus Suarez
    ok thanks.
    hi everyone
    i have a problem with sending rpc subscribe rest api
    it retruns 503 error Service unavailable but everything on server is ok
    any help?
    I am using a python code to connect via MQTT to my thingsboard server
    the code works with
    once I change the server and connect to a device made in my server, it is connecting and in my python code logs shows successful connection and start publishing, however I do not see data in "Latest Telemetry" Section,
    I do not know how to debug, any idea ?
    wow, this is i wanted ! amazing !
    my dashboard is showing GMT time tnstaed of local time
    pls suggest
    Performance issue: try to connect "10 thousands device && 3 telemetry resources && 2s interval" to thingsboard, the method validateCredentials in LocalTransportApiService cause performance issue. it cost about 5-10 ms to process the request. will it be fixed?
    The new release of the gateway in Python is not yet available for windows computers. how do i compile the gateway for windows?
    Bhargavi Rao
    Hi All,
    I have ThingsBoard server running on Ubuntu and just installed the latest python based gateway on another Ubuntu. I got the gateway connected to thingsboard.
    I am simulating some device Applications to send MQTT data to the gateway(as per the mqtt.json configuration). However, I dont see the device data getting reported to the server from the gateway. Is there a configuration that needs to be enabled for the data to be sent to the server.
    Thanks in advance
    Ilya Barkov

    Hi, @bhrao_gitlab

    Please write issue on github, with your config and "connector.log". MQTT connector can connect to an external broker, and subscribe to some topics for data collection. Did you check your logs? Logs folder location you can find here.

    Hi, @tachzuka

    You can use the new gateway with docker in Windows. We are going to release a docker image soon.

    Bhargavi Rao
    Thanks @zbeacon. I had already created a new issue(#2309) on github. I have updated the same with the logs and configurations used. I did check the logs, the gateway subscribes to the device data top mentioned in the mqtt.json config. When I publish data to the topic, the broker publishes it to the gateway but looks like the gateway is not receiving the message as the log file doesnt have any prints there after.
    Hello , can i somehow config tb , or tb-gateway to save only changes in states ?
    oh , sorry i found it