Where communities thrive

  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
    Pedro de Oliveira
    But they all fail in the same way, it seems to try to start a postgresql server, even in the cassandra version
    and then they always fail with the same error:
    Installing SQL DataBase schema part: schema-entities.sql
    Unexpected error during ThingsBoard installation!
    org.postgresql.util.PSQLException: FATAL: database "thingsboard" does not exist
    i've tried the data directory with every permissions, in host shared volumes, i even tried it with a docker volume, always the same problem. Is anyone running thingsboard ce on docker?
    Pedro de Oliveira
    Because i wasnt trying it on Ubuntu... Just tried it and the same happens - https://pastebin.com/mVBZSd6w
    Working on Chirpstack <> Thingsboard integration, anyone work with both?
    The default integration in chirpstack, very easy to use, but doesn't send all the details I need. so I am doing http integration and data converter.
    Interesting in hearing about downlink and sending messages integrations you've done
    2 replies
    Torsten Lauter
    I search a way, how can I transfer values from an incoming POST_TELEMETRY package to a alarm
    I wish to create a alarm with all properties from a alarm (creationtime,owner,typ,severity,status,details)
    Can I set it in the script of a create_alarm node?
    @ayman-sherief Did you also install all the required libraries for the report server? It needs quite a few for fonts, etc...
    @Ktysai You could add a 'refresh token' step before you make your API GET requests, so you always have a valid token. The MQTT approach does not require this kind of token. For MQTT things are different if using the PE or CE Thingsboard version, as PE has the integrations.
    @Collin01 Yes, you can. The docs show a good example. In your script, you need: var details = {};
    details.Param1 = msg.Param1;
    So your details will include Param1 from the msg payload. You can also do the same for the msg metadata fields.
    @t0mmyz7 - working with both on cloud. Using MQTT integration via Mosquitto broker with pubsub. Data converters decode the uplink, messaging seems to be reliable but its early days. Not tried downlink yet. What stage are you at?
    11 replies
    @amber-aw Yes, it turned out to be a problem with haproxy that prevented my report server to access the dashboard from localhost, fixed it by re-configuring haproxy, thanks
    Has anyone found a solution for the timezones? Everything server-side and device-side uses UTC, so that part is ok. The problem is when viewing the timeseries data from the dashboard. The dashboard assumes timeseries must be displayed using the local time from the browser. Also, any data exported from the timeseries widget is converted to the web browser's local time.
    Torsten Lauter
    @amber-aw But the question is, how can a Set the Alarm properties in the Script?
    alarm.id Alarm.owner???
    @Collin01_gitlab I think I understand. There is an option 'use message alarm data' under the test details function, but I am not sure if this is only in Thingsboard PE. Otherwise, maybe use the HTTP API saveAlarm?

    @amber-aw > @Ktysai You could add a 'refresh token' step before you make your API GET requests, so you always have a valid token. The MQTT approach does not require this kind of token. For MQTT things are different if using the PE or CE Thingsboard version, as PE has the integrations.


    @amber-aw Thank you! You recommend to stick with REST API, and not work with MQTT? On REST API can I use the 'refresh token' step every minute or so? The things change a lot if I use REST API & HTTPS?
    Has anyone found a way to send a msg by HTTP POST in an external rule node?
    1 reply
    Can Anyone tell me how I can bring THE THINGS NETWORK data to thingsboard community edition and make a dashboard on thingsboard? I have install the thingsboard CE on Ubuntu but not able to configure thingsboard IoT gateway correctly for sending the data from TTN over MQTT.
    Kapil Surendra Shinde
    service name is invalid for thingsboard on windows
    can some one resolve this issue on windows
    Joe Hughes
    Is there a known issue with the Azure Appliance for Thingsboard PE? I've followed the guide twice and on both occasions, the key is rejected for SSH.
    I spotted a couple of other people with similar issues.
    Holger Brandl

    Hi there, is there a way to process more structured data such as

      "site_id": "foo",
      "tool_id": "bar",
      "sensor_id": "osci",
      "timestamp": "34242323",
      "features": {
        "foo": 3.4,
        "bar": 3.0,
        "hu": 12

    in rules and dashboard?I've tried a postproc function value.foo in the datakey definition when building a dashboard, but no luck (yet). Thanks!

    Hello, i have successfully requested shared attribute via MQTT API, but the response took too long (20sec to 1 min range), I'm going to use the feature on a battery powered application to notif the device that there is an new firmware version. 20sec to 1 min is quite bad for a battery powered application. is there anyway to make the response faster? or someone has this problem too?
    @ktannady if you post telemetry how fast the server updates? Do you use NO SSL MQTT?
    Hello, I've dashboard functionnality's question.
    I have a system which take some measure each 10ms during a short period (10 seconds) and then stop measure during 1 hour.
    Is it possible to configure a dashboard to see the lasts 10 seconds measures (and not the last real time 10 seconds)?
    If yes how to do it? Someone has already do something like that?
    Can someone help me to integrade mqtt with tb gateway iot
    I connected chirpstack > thingsboard and can get telemetry in thingsboard, but can't figure out how to get downlinks to work. I get errors like "RPC Error: NO_ACTIVE_CONNECTION". Does anybody have any documentation on setting this up? Or where to go for debug help? I can't even figure out how thingsboard knows where to send the rpc request or by what protocol. Do I need to set up an additional mqtt server as a go between?
    Related - is this even possible in the community edition?

    @Ktysai Hello thanks for your reply, im using NO SSL MQTT and when i post the telemetry the server update quite fast within a second..

    here is some proof that the response took a long time :


    10:24:53.580 -> Connecting to ThingsBoard node ...connected
    10:25:42.328 -> Sleep Time = 57
    10:25:42.328 -> Error Sleep Time = 60
    10:25:42.367 -> latest firmware version = 100
    10:25:42.367 -> battery Calibration = 1.08


    10:26:44.536 -> Connecting to ThingsBoard node ...connected
    10:27:35.030 -> Sleep Time = 57
    10:27:35.072 -> Error Sleep Time = 60
    10:27:35.072 -> latest firmware version = 100
    10:27:35.072 -> battery Calibration = 1.08

    as you can see it took a long time, here is what i do :
    when I connected, I subscribed to the attribute response, and I publish a request and then I wait for the callback to be fired.

    I update a server attribute on an Asset. In rules, the message type switch is set for 'Attribute Updated' and sees the changed attribute. But the msg data only contains the attribute name & value, not the Asset name. how can I identify the asset that has been updated?
    @ktannady are we talking about Thingsboard Community Edition or Live Demo? In my case using my PC to request attributes status using SSL MQTT the response is less than 1sec. I din not use MQTT onmy mobile device yet, since now it seems it best for me to use REST API. In your case I'll try to use the mosquitto installed on your PC to check Thingsboard parameters and than to port it to your mobile device.
    @Ktysai Hello, I'm using Thingsboard CE that I install on my VPS, did you mean that I shall try to use mosquitto to perform the request to see if the response faster or not?
    @Hopper-2901 You can grab the Asset details from the metadata and put them in the msg.details using a script. This is an example using the script transform node:

    @Hopper-2901 [ctd]
    msg.details.myField = metadata.myField;

    return {msg: msg, metadata: metadata, msgType: msgType};

    2 replies
    Zeynel Abidin Fincan

    I have installed thingsboard on my windows pc successfully. thingsboard service is running. Last line in the log file is "2020-09-21 13:05:52,455 [main] INFO o.t.s.ThingsboardServerApplication - No active profile set, falling back to default profiles: default". "http://localhost:8080/" link does not open a WebUI. When I try the link, the service stops. I see an exception in the log file as below:

    Caused by: java.lang.IllegalArgumentException: No enum constant org.thingsboard.server.common.data.EntityType.RULE_CHA?N
    at java.lang.Enum.valueOf(Unknown Source)
    at org.thingsboard.server.common.data.EntityType.valueOf(EntityType.java:21)
    at org.thingsboard.server.dao.audit.AuditLogLevelFilter.lambda$new$0(AuditLogLevelFilter.java:31)
    at java.util.HashMap.forEach(Unknown Source)
    at org.thingsboard.server.dao.audit.AuditLogLevelFilter.<init>(AuditLogLevelFilter.java:30)
    at org.thingsboard.server.config.ThingsboardSecurityConfiguration.auditLogLevelFilter(ThingsboardSecurityConfiguration.java:233)
    at org.thingsboard.server.config.ThingsboardSecurityConfigurationEnhancerBySpringCGLIBEnhancerBySpringCGLIB4d27f379.CGLIB$auditLogLevelFilter$7(<generated>)
    at org.thingsboard.server.config.ThingsboardSecurityConfigurationEnhancerBySpringCGLIBEnhancerBySpringCGLIB4d27f379FastClassBySpringCGLIBFastClassBySpringCGLIB5c478970.invoke(<generated>)
    at org.springframework.cglib.proxy.MethodProxy.invokeSuper(MethodProxy.java:244)
    at org.springframework.context.annotation.ConfigurationClassEnhancer$BeanMethodInterceptor.intercept(ConfigurationClassEnhancer.java:331)
    at org.thingsboard.server.config.ThingsboardSecurityConfigurationEnhancerBySpringCGLIBEnhancerBySpringCGLIB4d27f379.auditLogLevelFilter(<generated>)
    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
    at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
    at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
    at java.lang.reflect.Method.invoke(Unknown Source)
    at org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:154)
    ... 112 common frames omitted

    What is this about?
    Zeynel Abidin Fincan