Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
Timo Furrer
@timofurrer
The pypa
They can use it
thanks for that
David Torrens
@grayerbeard
I have got temperature readings working (had been using other methods for over a year not sure why when you have this simpler approach). However cannot get the precision change to work with some DS18B20s either from Python3 script or the command line.
and also I have great difficulty understanding the required format to call functions for w1thermsensor from python3. There seem to be various data available such as 'hwid', 'temperature', 'type' etc. and I cannot find any documentation that explains how to get the different parameters simply from within code that is scanning through a set of sensors. Is there some document somewhere or an explanation. On git hub the item that says "docs" is written in some sort of format I cannot understand at all.
David Torrens
@grayerbeard
Having said that I have managed, largely by trial and error, to adapt my prog to read in temperatures using w1thermsensor. A more complex python3 example reading multiple sensor (and changing their previsions) would be a great help, do you know where I can find?
Timo Furrer
@timofurrer
Hi David
The README file in the official GitHub repository https://github.com/timofurrer/w1thermsensor contains enough documentation to get you started
David Torrens
@grayerbeard
Thanks Timo. I had managed the "get started" fine based on what is on github. See http://www.smalle.uk/temps. I can see that the initial call scans for the sensor files and then the get temp gets a sensor only if it's actually active. I managed to integrate that with my old code OK but I wo
Oops. But I sti
But I am not sure I am making best use of your code.
Timo Furrer
@timofurrer
hmm, hard to tell without seeing the actual code
You are welcome to post some code snippets, if you like
David Torrens
@grayerbeard
The whole prog is on pastebin at.
Four sensors used with their data in a csv file. Config file has address of the sensor used for control. So w1thermsensor gets addresses and data and then addresses compared to file. If new sensors found or sensors not responding I have trid to make sure prog responds ok.
Amir Khan
@whiplash01
Hey there! Does anyone has experience with calibrating DS18B20?
Timo Furrer
@timofurrer
I do not, but would be happy to hear about year experiences!
Timo Furrer
@timofurrer
@mikespolk let me know when you are online!
mikespolk
@mikespolk
Hi, online now
Timo Furrer
@timofurrer
cool
so, you've updated w1thermsensor, right?
mikespolk
@mikespolk
Happy new year from Finland :)
Timo Furrer
@timofurrer
Thanks, same to you!
mikespolk
@mikespolk
Yes, updated it an hour ago
I was thinking to once again doublecheck, by installing the owfs library, and seeing if the sensors Still enumerate
but what would you advise now?
Timo Furrer
@timofurrer
let's do some debugging:
ls -l /sys/bus/w1/devices
what's the output of this command?
mikespolk
@mikespolk
I have a TightVNC session on my PC now
Timo Furrer
@timofurrer
It's fine if you just execute the commands and post the output :)
mikespolk
@mikespolk
image.png
Timo Furrer
@timofurrer
what sensor type do you have?
DS18B20 ?
mikespolk
@mikespolk
DS18B20, but just a second, I will doublecheck it now
Timo Furrer
@timofurrer
The problem I see is that your sensor files all start with the 00- prefix
however, DS18B20 sensors usually start with 0x28
and 00 is not one of them
mikespolk
@mikespolk
The one that was now connected, was DS18B20. There is another, which was disconnected, is DS1820
I will next connect the latter, too, and then rerun the command, right?
Timo Furrer
@timofurrer
DS1820 ?
do you mean DS18S20 ?
mikespolk
@mikespolk
just a moment...
It is DS1820. Connected now both sensors, and will next rerun the ls command
image.png
So, there is no difference, whether there are one or two sensors connected
Timo Furrer
@timofurrer
yeah, at least no in the family codes
hmmm