by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Sep 14 13:32
    linusmmueller closed #97
  • Sep 14 13:32
    linusmmueller commented #97
  • Sep 13 17:31
    timofurrer commented #97
  • Sep 13 15:52
    linusmmueller labeled #97
  • Sep 13 15:52
    linusmmueller opened #97
  • Sep 13 13:56
    timofurrer closed #96
  • Sep 13 13:56
    timofurrer commented #96
  • Sep 13 13:48

    timofurrer on v2.0.0a2

    (compare)

  • Sep 13 13:48

    timofurrer on master

    release: v2.0.0a2 (compare)

  • Sep 12 08:35
    AlexShten starred timofurrer/w1thermsensor
  • Sep 07 04:42
    jlollis starred timofurrer/w1thermsensor
  • Aug 31 17:09
  • Aug 31 07:57
    timofurrer reopened #96
  • Aug 31 07:57
    timofurrer closed #96
  • Aug 31 07:57
    timofurrer commented #96
  • Aug 31 07:53

    timofurrer on master

    Correctly handle empty data in … (compare)

  • Aug 30 11:28
    vollbier opened #96
  • Aug 24 13:04
    timofurrer closed #75
  • Aug 24 13:04
    timofurrer commented #75
  • Aug 24 13:03
    timofurrer closed #94
David Torrens
@grayerbeard
Thanks Timo. I had managed the "get started" fine based on what is on github. See http://www.smalle.uk/temps. I can see that the initial call scans for the sensor files and then the get temp gets a sensor only if it's actually active. I managed to integrate that with my old code OK but I wo
Oops. But I sti
But I am not sure I am making best use of your code.
Timo Furrer
@timofurrer
hmm, hard to tell without seeing the actual code
You are welcome to post some code snippets, if you like
David Torrens
@grayerbeard
The whole prog is on pastebin at.
Four sensors used with their data in a csv file. Config file has address of the sensor used for control. So w1thermsensor gets addresses and data and then addresses compared to file. If new sensors found or sensors not responding I have trid to make sure prog responds ok.
Amir Khan
@whiplash01
Hey there! Does anyone has experience with calibrating DS18B20?
Timo Furrer
@timofurrer
I do not, but would be happy to hear about year experiences!
Timo Furrer
@timofurrer
@mikespolk let me know when you are online!
mikespolk
@mikespolk
Hi, online now
Timo Furrer
@timofurrer
cool
so, you've updated w1thermsensor, right?
mikespolk
@mikespolk
Happy new year from Finland :)
Timo Furrer
@timofurrer
Thanks, same to you!
mikespolk
@mikespolk
Yes, updated it an hour ago
I was thinking to once again doublecheck, by installing the owfs library, and seeing if the sensors Still enumerate
but what would you advise now?
Timo Furrer
@timofurrer
let's do some debugging:
ls -l /sys/bus/w1/devices
what's the output of this command?
mikespolk
@mikespolk
I have a TightVNC session on my PC now
Timo Furrer
@timofurrer
It's fine if you just execute the commands and post the output :)
mikespolk
@mikespolk
image.png
Timo Furrer
@timofurrer
what sensor type do you have?
DS18B20 ?
mikespolk
@mikespolk
DS18B20, but just a second, I will doublecheck it now
Timo Furrer
@timofurrer
The problem I see is that your sensor files all start with the 00- prefix
however, DS18B20 sensors usually start with 0x28
and 00 is not one of them
mikespolk
@mikespolk
The one that was now connected, was DS18B20. There is another, which was disconnected, is DS1820
I will next connect the latter, too, and then rerun the command, right?
Timo Furrer
@timofurrer
DS1820 ?
do you mean DS18S20 ?
mikespolk
@mikespolk
just a moment...
It is DS1820. Connected now both sensors, and will next rerun the ls command
image.png
So, there is no difference, whether there are one or two sensors connected
Timo Furrer
@timofurrer
yeah, at least no in the family codes
hmmm
it's strange that those files start with 00-
that shouldn't be the case for DS18B20 sensors
there should be 28-
mikespolk
@mikespolk
Maybe they are entries for I2C base enumerator?
Timo Furrer
@timofurrer
can you do a cat /sys/bus/w1/devices/<one of your sensors>/w1_slave ?
where are <one of your sensors> is one of the 00- files from the ls output
mikespolk
@mikespolk
Little confused, as there are no w1_slave's visible:
Timo Furrer
@timofurrer
hmmm