by

Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    DennisMitchell
    @DennisMitchell
    @Gelbpunkt Pulled. mamba --version says 0.2.0.
    @Helen0903 Pulled.
    Helen
    @Helen0903
    @DennisMitchell Fixed some more bugs if you don't mind pulling
    DennisMitchell
    @DennisMitchell
    @Helen0903 Pulled.
    Helen
    @Helen0903
    @DennisMitchell Rewrote everything and added some new functionality (sorry for so many frequent updates)
    DennisMitchell
    @DennisMitchell
    @Helen0903 Frequent updates are no problem. The Hello World now prints numbers instead of characters; is that expected?
    Helen
    @Helen0903
    Didn't test the flags after the rewrite
    Helen
    @Helen0903
    @DennisMitchell Alright fixed! Thanks for pointing that out
    Saved me a lot of confusion later on
    DennisMitchell
    @DennisMitchell
    @Helen0903 Pulled.
    Tesla Ice Zhang‮
    @ice1000
    Can we have a updated Agda?
    DennisMitchell
    @DennisMitchell
    @ice1000 TIO is running the latest version from Fedora's repos. How outdated is it?
    Tesla Ice Zhang‮
    @ice1000
    Actually the version I want is the development version. I'd say it's better to update it when it's released, I'll tell u then.
    It's released
    Helen
    @Helen0903
    @DennisMitchell Pushed some changes to fix input problems in tio if you don't mind pulling
    stasoid
    @stasoid
    @DennisMitchell Can we change DOBELA implementation to this one? Old asm interpreter doesn't follow the spec
    in some cases, which has bitten me once already. I believe new implementation is better in many respects, including maintainability, following the spec and
    handling many corner cases which dobelx64 doesn't. Currently DOBELA answers exist only in Hello World and Add a language to a polyglot threads.
    Changing the interpreter will break several old polyglot answers (207-210, all of them are mine) and the program provided in the comments of Hello World answer.
    All these breakages are due to dobelx64 not following the spec. If this is a problem I can fix all those answers for new interpreter, but I see no point in doing this.
    If that is fine, I'll write a pull request.
    Tesla Ice Zhang‮
    @ice1000
    Requesting Agda 2.6.0.1 release, and a stdlib update
    This example does not typecheck due to old compiler impl
    DennisMitchell
    @DennisMitchell
    @stasoid I could host both implementations, but if dobelx64 just deviates from the spec in undocumented ways, it's probably not worth it and we should just switch to your implementation.
    @ice1000 I'll have to update to Fedora 30 to update Agda (so it will take a while), but even Fedora 30 is still on Agda 2.5.4. When was Adga 2.6 released?
    stasoid
    @stasoid
    @DennisMitchell No, dobelx64 behaves strangely due to bug(s?), not because it deliberately deviates from spec. The author of dobelx64 is actually the one who wrote the spec.
    Now that I think of it, dobelx64 has some value of being a "classical" implementation, so it's better to keep it. I will write a PR today or tomorrow.
    Tesla Ice Zhang‮
    @ice1000

    When was Adga 2.6 released?

    According to github it's released on 11 Apr.

    EdgyNerd
    @EdgyNerd
    Suggestion for a programming language: the esolang UBFIM (https://esolangs.org/wiki/Ultimate_bf_instruction_minimalization!). The only current interpreter there is is one wrote in Basic (https://esolangs.org/wiki/UBFIM_interpreter) so it'd be useful to have it on here
    Dev Mohammed Othman
    @devmohammedothman
    hello every body, is there api to use tryitonline to compile code and run it for specific language
    Landon Gravat
    @RailRunner166
    yo i made a language, you guys should add it :) (i can help with setup if need be)
    (if you want to add it, friend me on Discord (i'm more active there, and probably won't get notifs here), my tag is RailRunner16#7053)
    DennisMitchell
    @DennisMitchell
    @RailRunner166 I don't use Discord. What language is it?
    Landon Gravat
    @RailRunner166
    it is Caboose :)
    i can send you a link @DennisMitchell (if you want)
    DennisMitchell
    @DennisMitchell
    @RailRunner166 Sure, let's take a look.
    Landon Gravat
    @RailRunner166
    DennisMitchell
    @DennisMitchell
    @RailRunner166 OK, I'll try to add it when I have some time. I have a bit of request backlog...
    Landon Gravat
    @RailRunner166
    awesome :)
    DennisMitchell
    @DennisMitchell
    @RailRunner166 https://tio.run/#caboose
    ahmed_ais
    @ahmed-ais
    It would be great to add syntax colouring at least for the most used languages.
    Taylor Scott
    @TaylorAScott
    Hey there, I was hoping that we could get the version of Yabasic updated from 2.81 (Oct 2019) to the current verion 2.85 (Nov 2019). There are quite a few feature differences that are really important for golfing
    (namely the additions of bitwise shifting functions, removal of parens from while statements and the addition of the chomp$ function)
    Yorick Peterse
    @YorickPeterse
    What's the process for adding/requesting the addition of a new language, in particular when it's not in any distro package repositories?
    hex96
    @hex96
    I have an esolang for tio, its called Tttt, https://github.com/hex96/Tttt/tree/master
    Thx dennis if you do put it on the site
    Mek
    @wooden-utensil
    @DennisMitchell I have a language, it's called 32. Can you guys please add it. The "Hello, World!" program is either IU or "Hello, World!"U. It uses Python as it's parent language.
    LebsterFace
    @LebsterFace

    @DennisMitchell I also have a language called StupidStackLanguage, the hello world program is as follows:

    aviiiaiglbmfavdaiiiglbmlblbgifviiffiiifavdaviiimfaiiimwwifbbbbbfiiifwdfwdddfbvfbb

    There is a python interpreter on the wiki page

    thanks!

    Landon Gravat
    @RailRunner166

    hey @DennisMitchell just to keep you in the know, there have been some major updates concerning Caboose, if you could update it to master (I overwrote the old code with the latest version, which is v2) that would be great :)

    I can help with any setup needed and since there's a package manager coming out soon for it i can help you with setting that up as well when its ready :)

    FYI Caboose v2 is still indev, I have just a couple of things to add then the basics will be complete, and I can notify you of updates to the completed lang

    William
    @williamistGitHub
    @DennisMitchell you should add Argh! Its interpreter is in javascript and is available at http://argh.sha-bang.de/
    Tesla Ice Zhang‮
    @ice1000
    I request Agda 2.6.1
    Dmitry Lyssenko
    @ldn-softdev
    Team, may I kindly request to consider including jtc (json parser tool - https://github.com/ldn-softdev/jtc) in TIO?
    bigyihsuan
    @bigyihsuan
    Hi, I'd like my esolang International Phonetic Esoteric Language added to TIO
    Esolangs page: https://esolangs.org/wiki/International_Phonetic_Esoteric_Language
    Interpreter repo: https://github.com/bigyihsuan/International-Phonetic-Esoteric-Language
    Jaeyong Sung
    @buttercrab
    Hi, I've made a compiler for "hyeo-ung" language. It's a korean-based esolang (If you can read korean, gist link). The compiler is in this repo. Could you add this language to tio.run?
    8Dion8
    @8Dion8
    Hi! I've made an esolang in my off time, wondered if adding it to TIO would be much effort if the "compiler" I made is in python 3. https://github.com/8Dion8/MAWP