Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Dec 20 2018 12:11
  • Nov 09 2018 10:14
  • Aug 12 2018 15:23
  • Mar 06 2018 01:17
    soleverlee commented #17
  • Feb 14 2018 11:29
    Xianguang-Zhou starred tunnelvisionlabs/antlrworks2
  • Dec 21 2017 08:51
    debashish2014 starred tunnelvisionlabs/antlrworks2
  • Dec 07 2017 09:04
  • Sep 04 2017 02:44
    tvkit opened #68
  • Sep 01 2017 03:32
    ooinfo commented #17
  • Aug 21 2017 05:26
    Proudmary01 commented #17
  • Jul 19 2017 02:47
    sharwell labeled #67
  • Jul 19 2017 02:47
    sharwell labeled #67
  • Jul 19 2017 02:47

    sharwell on master

    Fix off-by-one error when navig… Merge pull request #67 from sha… (compare)

  • Jul 19 2017 02:47
    sharwell closed #67
  • Jul 19 2017 02:46
    sharwell opened #67
  • Jul 19 2017 02:43

    sharwell on master

    Improved cost estimation for pr… Merge pull request #66 from sha… (compare)

  • Jul 19 2017 02:43
    sharwell closed #66
  • Jul 19 2017 02:43

    sharwell on master

    Update to NetBeans 8.2 Merge pull request #63 from sha… (compare)

  • Jul 19 2017 02:43
    sharwell closed #63
  • Jul 19 2017 02:43

    sharwell on master

    Fix Go To Definition for channe… Fix smart indent of the first I… Merge pull request #64 from sha… (compare)

Alexander Schell
@Quurz
Yep, this looks familiar...
Sam Harwell
@sharwell
I submitted a pull request (#50) to fix it. But I don't have a non-Windows system so I don't know if it works.
You can apply those changes to your copy of build.xml (or download the file and overwrite the one you have).
Alexander Schell
@Quurz
Okay...I'll try this...
Sam Harwell
@sharwell
downloading is the best option, then I know we're on the same code
When someone can confirm that it works, I'll merge #50 and then it will be working for everyone. :smile: Or at least that part will be working.
Alexander Schell
@Quurz
Just downloaded it...
I give it a try now.
Ojwej...I've done something wrong...Let's see...
I got this error: Target "projectized-common.clean" does not exist in the project "org.antlr.works.editor". It is used from target "clean".
I'm trying to find the cause
Sam Harwell
@sharwell
oops, I sent you the right link but you need to save it as org-antlr-works-editor/build.xml
Sounds like you overwrote the root build.xml. Do you still have a copy of that file in the downloaded source code, or do you need a link to it?
Alexander Schell
@Quurz
Yay...And didn't make a backup of this file...I could bite myself... :/
Sam Harwell
@sharwell
After you have this working, you can spend some time with some Git tutorials and then you'll never be worried about things like this happening :D
Alexander Schell
@Quurz
Mhm, I'll clean up my playground, unzip 'antlrworks2-bfee49a9b029625ef3bffeaa1b026d2bbc95b61d.zip' again and then I'll have restored the right file- and directory-structure, I think...
It's the first time I'm playing around with git...I'm coming from subversion... :)
Sam Harwell
@sharwell
I used subversion for everything in the past. All of my subversion repositories are now Git repositories
And not just because GitHub. It just works that much better.
Alexander Schell
@Quurz
My company is on the move to Git too; I'm overude to take a look at it...
Okay...I've now downloaded the build-file to the correct folder - Well, I hope so...
Next try...
Yay! Build successful! :D
Sam, would you like to have a copy of the generated output?
Sam Harwell
@sharwell
Can you post a comment in #50 saying the build now works for you?
Alexander Schell
@Quurz
There a lot of warnings and I thought, you might be interested in it...?
Posting the comment right now...
Sam Harwell
@sharwell
@Quurz I believe you needed to edit platform.properties for the build to work. Is that correct?
Alexander Schell
@Quurz
Yes, I had...
Gimme a second...I'm looking for the changes...
Sam Harwell
@sharwell
#52
^^ That was the change
Alexander Schell
@Quurz
Ah: I just send you the output generated by the build by mail...
Sam Harwell
@sharwell
Yes, it looks mostly as expected. I forgot to include the step for setting Tools → Java Platforms so it could find JDK 1.7 (x64). Like this:
blob
Alexander Schell
@Quurz

I have these entries in my build.properties file:
nbplatform.default.harness.dir=/home/Alexander/Spielwiese/netbans_harness
nbplatform.default.netbeans.dest.dir=/home/Alexander/Entwicklung/NetBeans/netbeans-8.0.2

nbplatform.nb801.harness.dir=/home/Alexander/Spielwiese/netbans_harness
nbplatform.nb801.netbeans.dest.dir=/home/Alexander/Entwicklung/NetBeans/netbeans-8.0.2

Mhm, I don't know. I built agains Java 8. Could this be a problem?
+t
Sam Harwell
@sharwell
define "problem"
if it works for you, I wouldt' call it a problem :)
Alexander Schell
@Quurz
Well, you're right... :D
Only Problem I have at the moment is that I'm not able to find the *.nbm file...
Maybe I'm blind...
Sam Harwell
@sharwell
it didn't create them
ant nbms
the normal build is enough to use ant run, but doesn't create nbms for distribution
Alexander Schell
@Quurz
Ah, Okay...Thanks... :)
I'm using Maven as build/comprehension tool and I'm unfamiliar with ant...
Sam Harwell
@sharwell
This isn't normal ant. This is a heavily customized script specifically for building NetBeans (and NetBeans extensions)
Not customized by me. I prefer Maven, but for creating a NetBeans extension you go with what you have. :)
Alexander Schell
@Quurz
Well, that I can unterstand... :)
Oops? '-nbm-prompt-for-storepass'? What kind of black magic is this?
Sam Harwell
@sharwell
oh right
You have to sign the nbms or Oracle won't let you upload them to the gallery
Do you have a file nbproject/private/platform-private.properties?
Alexander Schell
@Quurz
I've to do this although I'm not thinking about uploading the module? Funny...
I only wanted to see, if it's possible now to plug it into 8.0.2...