Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
  • Oct 18 18:23

    kailuowang on v0.30

    (compare)

  • Oct 18 18:23

    kailuowang on master

    Setting version to 0.30 Setting version to 0.31-SNAPSHOT (compare)

  • Oct 16 22:54

    mergify[bot] on master

    Update specs2-core, specs2-mock… (compare)

  • Oct 16 22:54
    mergify[bot] closed #182
  • Oct 16 22:54

    mergify[bot] on master

    Update sbt-release to 1.0.12 (#… (compare)

  • Oct 16 22:54
    mergify[bot] closed #181
  • Oct 16 22:04
    scala-steward opened #182
  • Oct 16 22:04
    scala-steward opened #181
  • Oct 15 03:46

    mergify[bot] on master

    Update sbt, scripted-plugin to … (compare)

  • Oct 15 03:46
    mergify[bot] closed #180
  • Oct 15 03:45

    mergify[bot] on master

    Update sbt-updates to 0.5.0 (#1… (compare)

  • Oct 15 03:45
    mergify[bot] closed #179
  • Oct 15 02:15
    scala-steward opened #180
  • Oct 15 02:15
    scala-steward opened #179
  • Oct 11 16:46

    kailuowang on master

    update scalaatest (#178) (compare)

  • Oct 11 16:46
    kailuowang closed #178
  • Oct 11 15:31
    kailuowang opened #178
  • Oct 11 15:31

    kailuowang on kailuowang-patch-2

    update scalaatest (compare)

  • Oct 08 00:32

    kailuowang on v0.29

    (compare)

  • Oct 08 00:32

    kailuowang on master

    Setting version to 0.29 Setting version to 0.30-SNAPSHOT (compare)

Kai(luo) Wang
@kailuowang
I am not super familiar with maven, that should be specified in the POM no?
BennyHill
@BennyHill
Yes, of course, but it's one part that I haven't physically confirmed works as I imagine...so just confessing that now ;)
Having a "new" library (no classifier) will of course be OK
Kai(luo) Wang
@kailuowang
i see.
BennyHill
@BennyHill
But I can look later tonight, should have some time, it won't take long
Kai(luo) Wang
@kailuowang
@/all typelevel/sbt-catalysts#67 super quick review needed.
BennyHill
@BennyHill
Looking now, on mobile....build is failing
Any ideas why? Difficult for me to see on phone
Kai(luo) Wang
@kailuowang
value %%% is not a member of String hmmm.
Rob Norris
@tpolecat
Is there any documentation for catalysts?
I remember there being some at some point.
Kai(luo) Wang
@kailuowang
I am not aware of any. But given the fact that it already supports 2.13-M4 I suspect that it’s just a matter of upping that to M5 and see which dependency is missing.
for both sbt-catalysts and catalyst
Kai(luo) Wang
@kailuowang
one tricky issue is that cats is on scalacheck 1.13.5 and we don’t have a plan to upgrade to the binary breaking 1.14 yet.
but since 1.13.5’s 2.13-M3 binary worked fine with cats on 2.13-M4 it might be okay for 2.13-M5 too.
Kai(luo) Wang
@kailuowang
releasing catalyst
Kai(luo) Wang
@kailuowang
actually I need to release sbt-catalyst first and update catalyst to the newly release sbt-catalyst version
Kai(luo) Wang
@kailuowang
turns out there is some work to be done. I will spend the next 10-20 minutes on it, but will need to take kids to halloween party after.
Kai(luo) Wang
@kailuowang
I left a WIP PR typelevel/catalysts#24 , will go offline
Alistair Johnson
@Alistair-Johnson
@kailuowang A while back you looked at doing a cats release with sbt-release and using a maven classifier, and you had no luck. Can you remember the exact issue you had?
There is the cat s
... cats issue on this, I'm just after a bit more detail, maybe you still have the failing code?
I'm asking in case we could add the cross building of scalacheck 1.4 to cats release 1.5
Kai(luo) Wang
@kailuowang
@Alistair-Johnson I don’t remember the details. but now I think about it, I don’t know why we can’t just in the cross module
add set version := (Global/version).value + “-scalacheck1.4”
Alistair Johnson
@Alistair-Johnson
Right. So just copy-snd-pastr the existing law projects to new projects and add that code.
And make the build SBT
Kai(luo) Wang
@kailuowang
yeah, something like that worth a try
Alistair Johnson
@Alistair-Johnson
... pretty later
Ok.
Alistair Johnson
@Alistair-Johnson
I'll try to look tomorrow.
Alistair Johnson
@Alistair-Johnson
The version of discipline changes as well. For completeness, should we append that too?
“-discipline0.10-scalacheck1.4”
Alistair Johnson
@Alistair-Johnson
And for testkit, we can add the scalatest version as well
Might seem OTT, but I guess we should...
And final question before bed.... If we do want to name all 3 deps, would abbreviations be better?
Eg. "-disc0.10-sc1.14-st3.0"
Alistair Johnson
@Alistair-Johnson
Do according to https://semver.org/#spec-item-10. We actually want "cats-laws-1.5.0+disc0-10.sc1-14.st3-0"
Kai(luo) Wang
@kailuowang
Personally I don’t see much need for cross publishing discipline, it’s already on scalacheck 1.4 (0.10). I’d say let’s keep things simple.
Also I am not sure if we should make testkit that complicated. I kind of feel it’s safe to assume that lib modules cats-testkit have no downstream deps, and thus not much need for BC.
BTW 1.5.0 is already out. I planned to only include bug fixes post RC0.
this would go 1.6.0.
but we have a faster release cadence now.
so 1.6.0 could be just 1-2 month away.
so my vote will be we have cats-laws 1.6.0 and cats-laws 1.6.0-scalacheck1.4
and for cats-testkit we simply release it with scalacheck 1.4 + scalatest 3.0
but we probably want to discuss on that scalacheck issue or maybe a new issue.
Alistair Johnson
@Alistair-Johnson
My main point of discussion here, before moving to the general audience in the issue, is really just the format as per Denver - makes sense to keep to the standard in their build modifier. So thats a
'+' followed by "." Delimited groups of alphanumerics and "-"
Kai(luo) Wang
@kailuowang
i see.
that is fine by me.
Oscar Vargas Torres
@oscarvarto
Hi! I am getting acquainted with typelevel libraries.
  1. I was looking a web page with some documentation on https://github.com/typelevel/catalysts
    Something like https://typelevel.org/cats/
    Is there any?
  2. Is catalysts the same than sbt-catalysts? (Github page on https://github.com/typelevel/catalysts sent me here) I would think they are related, but not sure if they are the same
Kai(luo) Wang
@kailuowang
@oscarvarto catalyst is developed to be a modular utility library for FP libraries. sbt-catalysts is a tool box for writing sbt build files. The two have no overlaps. catalyst has mostly been close to be abandoned. sbt-catalysts are still used and maintained, but as far as I know, I am the only active user. I used it in several OSS projects that I maintain. And I plan to continue use it in the future.