Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Urs Zeidler
    @UrsZeidler
    @MichaelWes What eclipse version do you use? I think this is compiled for neo with 1.8 java. The project wizard don't work, you can open solidity files with the solidity editor. So this is quite fine. (In a way) Currently there is no explicit solidity project, simply make a java or simple project.
    Urs Zeidler
    @UrsZeidler
    Maybe I remove this in a next release as it is misleading but I don't build the editor often.
    To the maven archetype: I have configured my 'Remote Archetype Catalog' with http://opensource.urszeidler.de/maven/archetype-catalog.xml as catalog file this works well for me.
    Swarmxcy
    @Swarmxcy
    @UrsZeidler I have just got a problem.
    oh. how to cut the screen?
    image.png
    image.png
    it can not work
    image.png
    image.png
    Swarmxcy
    @Swarmxcy
    what's wrong?
    Urs Zeidler
    @UrsZeidler
    Looks like papyrus is not fully installed, maybe try to install missing papyrus features or update the papyrus installation. Also I have not updated the marketplace (my bad) the current version is 1.1.1. You could try to install with the repo updatesite http://urszeidler.github.io/uml2solidity/uml2solidity-updatesite/ normally the dependencies, to papayrus for example, should be resolved by p2. In the next days I will publish another release to update the generated java code to ethereum-propeller. In the evening I will be back home. Maybe them I can help you more.
    Swarmxcy
    @Swarmxcy
    Thank you @UrsZeidler
    Urs Zeidler
    @UrsZeidler
    I would be here now for about two hours.
    Swarmxcy
    @Swarmxcy
    hello. @UrsZeidler
    hmmm. It seems you were left.
    I reinstalled uml2solidity with the url from eclipse help, but got the same.
    Urs Zeidler
    @UrsZeidler
    I have to go now(work), would be back in the evening. You could check the plugins and featues in the 'eclipse about' meanwhile.
    Urs Zeidler
    @UrsZeidler
    Bildschirmfoto vom 2017-06-09 09-16-33.png
    I could reproduce your problem, and to solve it you will need to install papyrus sdk. Funny that not all dependencies are resolved automatically. I will check this for the next release.
    Swarmxcy
    @Swarmxcy
    Thank you @UrsZeidler
    image.png
    I only got the above screen when checking the installed software.
    Urs Zeidler
    @UrsZeidler
    You will need to install the 'papyrus sdk'. Which is part of the neon software site, see my attached screenshot
    Swarmxcy
    @Swarmxcy
    got it. thank you very much
    Urs Zeidler
    @UrsZeidler
    Great to hear. Don't mind if you have questions.