Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Stiff Roy
    @stiffroy
    @alanpilloud the URL is a route defined in my personal routing (using annotation). The route seems to be ok. But still nothing is happening. My action looks like this:
    /**
     * @Route("/webhook", name="test_webhook")
     */
    public function webhook($params)
    {
        $filesystem = new Filesystem();
        $filesystem->touch(__DIR__ . "/file.txt");
    }
    Alan
    @alanpilloud
    @stiffroy I'm not much of a Symfony expert, maybe @stefan-kamsker has an advice ?
    Stiff Roy
    @stiffroy
    I have a general question, has anyone or is anyone using the Webhook? An example would be really great!!!
    Milan Felix Šulc
    @f3l1x

    Hi guys. How can I install v0.9.1? Standard project seems bumped with v0.8.

    Is 0.9 ready to test or should I wait?

    Thanks.

    Stiff Roy
    @stiffroy
    @f3l1x did you try
    composer create-project unite-cms/standard:0.9.1 unitecms --stability dev
    Milan Felix Šulc
    @f3l1x
    @stiffroy Well, I don't. There are constraints at modules at ^0.8 (https://github.com/unite-cms/standard/blob/v0.9.1/composer.json#L26-L30). So version 0.9.1 of modules is not installed.
    Stiff Roy
    @stiffroy
    @f3l1x but ^0.8 would mean versions from 0.8 to the next major version, i.e. 1.0.0
    Stiff Roy
    @stiffroy
    It seems like it is still stuck in 0.8.2
    Milan Felix Šulc
    @f3l1x
    @stiffroy Nope, ^0.8 does not mean 0.8 to 1.0.0
    Jens Köhler
    @eltomato89
    Hi, quick question: I have made a change on a vue js component (the File.vue in the storrage-bundle)
    Can someone give me a hint how I can compile this?
    Joey de Vries
    @xJoeyv

    I keep getting this error when creating a entry or viewing settings tab:

    The class 'Gedmo\Loggable\Entity\LogEntry' was not found in the chain configured namespaces UniteCMS\CoreBundle\Entity

    Also, can I update automatically some fields on each update or insert? For E.G created_at or updated_at

    Jens Köhler
    @eltomato89
    @xJoeyv you need to update the doctrine.yaml
    Chudylo
    @Chudylo

    I keep getting this error when creating a entry or viewing settings tab

    Hi! Confirming the error. Unitecms (v0.8.2), doctrine config is fine and up to date.

    Jens Köhler
    @eltomato89
    @Chudylo @xJoeyv
    Chudylo
    @Chudylo
    Thanks, Jens! I'm using the exact same doctrine config with no luck. :(
    Stiff Roy
    @stiffroy
    @xJoeyv I hope you already figured it out, but in case if you are still fighting with it, just add the doctrine configuration for the Gedmo Logables as I mentioned in https://github.com/unite-cms/unite-cms/issues/679#issuecomment-518644734
    @Chudylo Are you sure then you are using proper indentation as it is a very silly but crucial thing in YAML files.
    Chudylo
    @Chudylo
    @stiffroy Indentation was good, but looks like your fix works just fine. Thanks!
    Joey de Vries
    @xJoeyv
    I figured it out, Thanks!
    Chudylo
    @Chudylo
    Hey guys! I have a small question. Can I add subpages functionality (with parent id field) to the system without forking the cms itself? Any ideas? Thanks in advance!
    Stiff Roy
    @stiffroy
    @Chudylo What do you mean by sub page? Can't you create a child with the same content type? Like: Page->(collection)->Page[] ?
    Chudylo
    @Chudylo
    I want to be able to create page tree from admin panel where one page can have multiple child pages recursively. It should be the fullsize page, not a part of parent one.
    Franz Wilding
    @franzwilding
    Hey! You can create a reference field "parent" and a reference_of field "children" to get a tree
    Chudylo
    @Chudylo
    Yes, I guess it's just what I need. Should I just add those fields to the DB with mysql relations?
    Chudylo
    @Chudylo
    Found it in docs, thank you for pointing!
    Franz Wilding
    @franzwilding
    @Chudylo pefect. So you dont need to add a mysql DB column, this feature is already included in unite cms and can be easily added with a unite cms reference and reference_of field. :-)
    Alan
    @alanpilloud
    @franzwilding Hello ! My co-workers are asking about the future of Unite, do you still put effort in this project and is it still a good idea to use it ?
    Franz Wilding
    @franzwilding
    Hey! Actually we are working very hard on version 0.10. This will a complete rewrite of the core with many new (and very cool) features. Please be patient until December, we will write an official announcement and our plans for the future of unite cms together with a strong community
    Alan
    @alanpilloud
    These are great news :) Thanks a lot. Unite is already awesome to my eyes, I can't wait to see what you are doing. Remember that I'm also willing to contribute, maybe on the documentation as I am not much of a symfony guy.
    Franz Wilding
    @franzwilding
    Nice :) at the moment we are testing some new directions with unite, once we are done with that, I will come back to you (and everyone else who wants to become a part of this) with contribution options
    Chudylo
    @Chudylo
    Sounds really great! Love it! But short question - is it make sense to start building new website with currently available unite cms version and then migrate it to 0.10? Will it be backward compatible? Thanks!
    Franz Wilding
    @franzwilding
    Hey @Chudylo, we will provide an upgrade script to migrate the data, however you will need to rewrite the domain definition. In a very near future (next week maybe?) we will have a very first test version tagged on packagist you can try out for your website
    Alan
    @alanpilloud
    Thanks for these informations
    Chudylo
    @Chudylo
    Perfect! Looking forward to check it, thank you!
    hedwiggggg
    @hedwiggggg
    Hi, is there a live demo anywhere available?
    Franz Wilding
    @franzwilding
    Not yet, however the new codebase is now in dev-master its not stable or complete, but you can try it out. We will work a lot on this and also on docs in the next weeks, so please stay tuned!
    Alan
    @alanpilloud
    H
    Franz Benthin
    @Franjoo

    Hi guys, first of all I want to say thank you for providing such a great tool. Unites architecture and the possibility to use a graphQL API is really nice 👌

    At the moment I am struggeling running two instances of unite in parallel. I edited the docker-compose.yml of both, so that there should not be an conflict between these two.

    changes:
    unitecms-mysql: container_name, ports
    unitecms-web: container_name

    Did someone already tried that? I appreciate your feedback :)

    Jens Köhler
    @eltomato89
    @Franjoo what exectly is the problem? And what docker-compose file are you talking about? Its not in the git repo, is it?
    Franz Wilding
    @franzwilding
    Maybe @stefan-kamsker can help?
    mafudelaptu
    @mafudelaptu
    Hi guys. How can i update/validate the Domain (json config) via console? I tried doctrine:schema:update and validate with clearing all caches but it doesnt work :(
    Franz Wilding
    @franzwilding
    You can import a config via console, this will validate it. Check the unite: commands!
    Franz Wilding
    @franzwilding
    Hey! I you want to check out the current development of unite cms v0.10, you can have a look at this little installation guide for the dev-version unite-cms/unite-cms#730 it is not meant for production yet, but you can get a first impression, where we are going with unite cms :)
    mafudelaptu
    @mafudelaptu

    Hi guys, ive got problems with image references and thumbnail images. Can someone help me get it work?

    what ive got:

    media.json:
    "content_types": [
    {
    "title": "Bilder",
    "identifier": "images",
    "icon": "image",
    "fields": [
    "@titleField",
    {
    "title": "Bild",
    "identifier": "image",
    "type": "image",
    "settings": {
    "bucket": "@bucket",
    "not_empty": true
    },
    "thumbnail_url": "MYTHUMBNAILSERVICE/bilder/{name}"
    },
    "@altField",
    {
    "title": "Beschriftung",
    "identifier": "caption",
    "type": "textarea",
    "settings": {
    "description": "image caption which is usually displayed below the image."
    }
    },
    "@tagsField",
    "@locationsField"
    ],
    "views": [
    {
    "title": "All",
    "identifier": "all",
    "type": "grid",
    "settings": {
    "fields": {
    "image": {
    "type": "image",
    "meta": false
    },
    "title": {
    "meta": true
    },
    "tags": {
    "meta": true
    }
    }
    }
    }
    ]
    },
    }

    and other.json
    {
    title: "test",
    "identifier": "test",
    "type": "reference",
    "settings": {

            "domain": "media",
            "content_type": "images",
            "view": "all",
            "content_label": "{title}"
        }

    }

    in my backend no thumbnail gets rendered just title
    is that an expected behaviour? how can i get thumbnails in my backend by reference an "media.json" images field