Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Repo info
Activity
    Mark Silverberg
    @marks
    Hey @untoldone - around?
    Michael Wasser
    @untoldone
    This message was deleted
    @marks I am now -- how's it going?
    Mark Silverberg
    @marks
    @untoldone just curious about the new additions to bloom - looks like secure messages, additional data sources, etc.
    Michael Wasser
    @untoldone
    @marks Currently working with a few early users to build out functionality in all three areas. Are you interested in potentially making use of one of them yourself? They aren't open source yet, but I'd be happy to chat more offline if you are interested.
    hcpi
    @hcpi
    Hi
    Nick Lane-Smith
    @nickls
    hello @hcpi
    hcpi
    @hcpi
    hi nickls
    Nick Lane-Smith
    @nickls
    what's up? do you need help with bloomapi.
    hcpi
    @hcpi
    yes I am getting errors
    hcpi
    @hcpi
    bash-4.2# cd $GOPATH/src/github.com/untoldone/bloomapi && go run ./bloomapi.go bootstrap
    2015/12/10 11:37:27 pq: Ident authentication failed for user "postgres"
    exit status 1
    bash-4.2#
    Michael Wasser
    @untoldone
    sounds like your db doesn't have credentials set up properly? are you able to connect to it with the same credentials using TCP (rather than a socket based connection)?
    hcpi
    @hcpi
    Yes I think the issue is connection to the database what are postgres user credentials you are using in the app connection?
    Michael Wasser
    @untoldone
    they can be set in the config.toml files
    the default is postgres user and postgres for the password in the checked in copy (under the folder $GOPATH/src/github.com/untoldone/bloomapi)
    hcpi
    @hcpi
    Thank you! Can I use the Oracle database instead of Postgresql?
    Michael Wasser
    @untoldone
    Sorry, we don't currently support any databases other than Postgresql. We use a number of postgres specific features to make BloomAPI optimized to run very efficiently
    hcpi
    @hcpi
    Understood! I was able to change the config file and run cd $GOPATH/src/github.com/gocodo/bloomnpi && go run ./bloomnpi.go fetch with no errors
    it looks like it did loaded 4740851 records and successfully ended
    When I run bash-4.2# cd $GOPATH/src/github.com/gocodo/bloomnpi && go run ./bloomnpi.go search-index
    0 Records Deleted in 103.980558ms
    it hangs i do not see the activity on the box for a long time .
    What does search-index do and how i can monitor the progress of this run Thank you
    hcpi
    @hcpi
    I do not see the search-index in the list of the options: func showUsage() {
    fmt.Println("Usage: bloomapi <command>")
    fmt.Println("=============================\n")
    fmt.Println("Avaialable commands:")
    fmt.Println("bloomapi server # run BloomAPI server")
    fmt.Println("bloomapi bootstrap # setup BloomAPI shared schema")
    fmt.Println("bloomapi drop # remove all BloomAPI shared tables")
    sorry wrong paste:
    func showUsage() {
    fmt.Println("Usage: bloomnpi <command>")
    fmt.Println("=============================\n")
    fmt.Println("Avaialable commands:")
    fmt.Println("bloomnpi bootstrap # setup NPI datasource in BloomAPI")
    fmt.Println("bloomnpi fetch # fetch latest NPI data and add to BloomAPI")
    fmt.Println("bloomnpi drop # remove all NPI tables")
    fmt.Println("bloomnpi search-index # index NPI in elasticsearch")
    hcpi
    @hcpi
    I do see some reference of the elasticsearch there how do i know if it is doing what is needed? Thanks
    hcpi
    @hcpi
    never mind I find the issue
    hcpi
    @hcpi
    Got it running but getting page not found error
    4758808 Records Indexed in 1h15m38.49502266s
    bash-4.2# cd $GOPATH/src/github.com/untoldone/bloomapi && go run ./bloomapi.go server
    2015/12/14 09:52:25 Running Server
    [negroni] listening on :3005
    [negroni] Started GET /
    [negroni] Completed 404 Not Found in 407.63µs
    [negroni] Started GET /favicon.ico
    [negroni] Completed 404 Not Found in 114.175µs
    [negroni] Started GET /favicon.ico
    [negroni] Completed 404 Not Found in 152.409µs
    [negroni] Started GET /favicon.ico
    [negroni] Completed 404 Not Found in 117.927µs
    shubham-gupta
    @shubham-gupta

    Hey @untoldone ,

    I am working on integrating the BloomAPI with one of our applications. I have the secret key and it also has the beta access. What I really need to do is fetch the patient records. We are currently targeting ‘Palo Alto medical Foundation’ and ‘UCSF Medical Center'.

    I am able to fetch the NPI numbers using the call :
    curl -X GET "https://www.bloomapi.com/api/search/usgov.hhs.npi"

    I am also able to get the my chart locations (To get the org_id) using

    /serach/bloomapi.epic.mychart_locations?secret=<>

    However, I am not able to make the above search by NPI.

    please help me in this regard.

    Michael Wasser
    @untoldone
    Just to clarify, are you trying to map the results of mychart_locations to NPIs?