Where communities thrive


  • Join over 1.5M+ people
  • Join over 100K+ communities
  • Free without limits
  • Create your own community
People
Activity
    Patrick Bovio
    @pbovio
    and how about the xml file it used to produce?
    to have it text searchable?
    bgruening
    @bgruening:matrix.org
    [m]
    it was a JSON I think
    and you still get those if you create a workflow
    Patrick Bovio
    @pbovio
    I just want it to document what I did on e.g. GitHub
    bgruening
    @bgruening:matrix.org
    [m]
    once you have a worklow you can download the workflow as a txt file - in JSON format
    Patrick Bovio
    @pbovio
    ok, I'll give it a look tomorrow and get back to you
    thanks Björn
    bgruening
    @bgruening:matrix.org
    [m]
    ok, thanks!
    Hope you are doing fine! Long time ... :)
    Patrick Bovio
    @pbovio
    Oh, I have important news for you ;) -> PM
    Patrick Bovio
    @pbovio
    @bgruening:matrix.org I tried the "Extract Workflow" funktion again. Still "Internal Server Error"
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    I have a collection of many samples that I ran fastp on (on .eu) - some jobs failed with the cryptic error message "Unable to finish job" and nothing in stderr. What is the easiest way to select all the failed datasets and re-run them to see if they succeed a second time?
    bgruening
    @bgruening:matrix.org
    [m]
    There is an API to restart all failed jobs in a history and it's in bioblend
    If that does not work you need to reload all failed jobs and click rerun inplace
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    ok I'll try bioblend
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    I'm trying to help out a colleague who is doing Galaxy 101 but one of their jobs failed with the message "Unable to finish job". This is history ID 0876ff39fabc4ccd - is there something wrong with the server?
    I just tried re-running the job and got a new error - "cat: write error: Broken pipe" - this is an error reported in the stderr (whereas the previous one had empty stderr) but again it looks strange to me
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    I am trying to move a history from usegalaxy.eu to usegalaxy.org. I exported on .eu and have a link, but when I try and use that to import to .org I get a 403: Forbidden error. is there some setting I am meant to change to make the exported link accessible?
    bgruening
    @bgruening:matrix.org
    [m]
    Are jobs still crashing?
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    yes.. "cat: write error: Broken pipe"
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    seems to be specific to this tool though?
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    ok, looks like this was two different errors, with one masking the other.
    the original error was "Unable to finish job" - then when that went away the "cat: write error: Broken pipe" showed up. The second error is happening with version 1.0.1 of the "Show beginning1" tool but "text_processing/tp_head_tool" version 1.1.0 - the tool that should be used for the Galaxy 101 tutorial - works
    both tools are, however, called "Select first lines from a dataset".
    bgruening
    @bgruening:matrix.org
    [m]
    Ah ok
    That rings a bell
    I will look at it
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    bgruening the earlier "Unable to finish job" error though - do you think that was the tool or the server? I've been getting them sporadically with a bunch of different tools.
    bgruening
    @bgruening:matrix.org
    [m]
    That looks like the server
    I saw yesterday evening a few failures on the cluster
    But when I was trying to look at them in deep I could not see anything failing anymore
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    and do you have a solution to my problem exporting from .eu to .org? seems the .org server is not allowed to download my .eu-generated history archive link.
    sorry lots of questions from me today
    bgruening
    @bgruening:matrix.org
    [m]
    Can you download that link?
    Is it public?
    No I don't know.
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    I can only download from the link when logged into the Galax server. I made the link by choosing the "Export history archive" and "to a link" options. So I can download this archive to my local PC and re-upload - it is large though so this is not practical. I am using the procedure documented here: https://training.galaxyproject.org/training-material/faqs/galaxy/histories_transfer_entire_histories_from_one_galaxy_server_to_another.html
    perhaps this is not a .eu specific issue though. let me test this with another set of servers
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    verified that this fails for other combinations of servers (SANBI Galaxy -> .org for example)
    bgruening
    @bgruening:matrix.org
    [m]
    Can you download the link from a different computer or when you are logged out?
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    nope, I cannot.
    I get the error ""History is not accessible by user" - so I dont think this link-based export / import works.
    bgruening
    @bgruening:matrix.org
    [m]
    Can you fill a bug report. It might be an auth issue
    I suspect this link should be public but it's not
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    bug report where? on Galaxy issues? because this does not seem to be .eu specific
    bgruening
    @bgruening:matrix.org
    [m]
    Yes upstream Galaxy repo
    dannon
    @dannon:matrix.org
    [m]
    This sounds pretty familiar to me; I thought we had automatically made these accessible. +1 to making an issue and we can make sure it gets looked at.
    pvanheusden
    @pvanheusden:matrix.org
    [m]
    dannon
    @dannon:matrix.org
    [m]
    Thank you!