These are chat archives for ushahidi/Community

6th
Mar 2015
Ushbot
@ushbot
Mar 06 2015 00:14
(amnesic) rjmackay: thanks for your answer, in fact my trouble came from a nodejs 0.12 , downgrade to 0.10 fix it.
(rjmackay) ah weird.
(rjmackay) Oh.. I only have 0.10 locally. I guess I better start testing with 0.12
(amnesic) you’re using 0.12 on your side ?
(rjmackay) What issues did you hit? have you got error output I can look at?
Ushbot
@ushbot
Mar 06 2015 00:20
(amnesic) was a problem installing module, not a ushahidi bug : sass/node-sass#653
(amnesic) anyway I still need to investigate why my deployement didn’t work well .. as you can see, there is still some problem ;-) : http://hackathon.lescollecteurs.org/
Ushbot
@ushbot
Mar 06 2015 01:19
(rjmackay) amnesic it looks like a bunch of files haven’t been deployed..
(rjmackay) how are you deploying the frontend?
(rjmackay) kinda looks like it hasn’t run a complete gulp build somehow.
(amnesic) deploying : git clone https://github.com/ushahidi/platform-client , npm install, gulp
(amnesic) i’m using apache2 , so also : cp server/rewrite.htaccess server/www/.htaccess
Ushbot
@ushbot
Mar 06 2015 01:26
(amnesic) excepted 2 warning, I didn’t see error with gulp : http://pastebin.com/KT2wBHsc
(amnesic) I just modified /var/www/hackathon.lescollecteurs.org/platform-client/server/www/css/style.css , to replace an import @import "bourbon” to @import "bourbon/bourbon"; @import "neat/neat";
Ushbot
@ushbot
Mar 06 2015 01:44
(rjmackay) ah right..
(rjmackay) you’re missing the bootstrap styles somehow.
(rjmackay) Did bower install work? ie. do you have things in bower_components/
(rjmackay) ?
(rjmackay) Might be that the gulp step to copy those didn’t work somehow too
(rjmackay) bootstrap should be installed with bower then copied into server/www/css
(amnesic) seems a good idea to check on this way … on the server/www/css I’ve only one file : style.css
Ushbot
@ushbot
Mar 06 2015 01:51
(amnesic) I’ve a WARN during the npm install : npm WARN cannot run in wd ushahidi-platform-client@3.0.0-beta.14 bower install (wd=/var/www/hackathon.lescollecteurs.org/platform-client)
(amnesic) Oops, I understand forgot to put --allow-root
Ushbot
@ushbot
Mar 06 2015 02:08
(amnesic) good, it”s working now. Thanks a lot for your help.
(rjmackay) You really shouldn’t be running any of that as root..
Ushbot
@ushbot
Mar 06 2015 02:13
(rjmackay) Glad that helped