These are chat archives for ushahidi/Community

24th
Apr 2015
Ushbot
@ushbot
Apr 24 2015 02:38
[Robbie Mackay (Ushahidi)] Hey @EvanSimsGuest
[Robbie Mackay (Ushahidi)] did you manage to get those tasks started ok?
[Robbie Mackay (Ushahidi)] and phab/arc working?
[Evan Sims] Yo @Robbie — Yup! Wrapping up one of them now. I ttttthink I got my arc issues sorted. So far so good, anyway. Bizarre errors, haha.
[Robbie Mackay (Ushahidi)] arc can be a little bizarre.
[Robbie Mackay (Ushahidi)] Let me know if I can help debug.. I've seen of the issues before..
[Evan Sims] Thanks, I'll definitely ping you if I hit another. :)
[Evan Sims] Switching from doing Ember.js work for the last year into Angular has definitely been a mind warp, haha. Very different ways of doing things. But not bad once you wrap your head around it.
Ushbot
@ushbot
Apr 24 2015 02:43
[Robbie Mackay (Ushahidi)] hah. Yea Angular has its own approach. Not sure its the right one yet.. but its what we've got :)
[Robbie Mackay (Ushahidi)] Kinda looking forward to seeing what Ping does with React
[Evan Sims] Oooh, React eh? Very nice.
Ushbot
@ushbot
Apr 24 2015 02:49
[Evan Sims] This makes me want to hack on an Ember.js frontend for V3 as a weekend project, just for curiosity sake. See how far I could get. :P
Ushbot
@ushbot
Apr 24 2015 03:00
[Robbie Mackay (Ushahidi)] hah.
Ushbot
@ushbot
Apr 24 2015 03:54
[Evan Sims] So, I'm guessing arc diff doesn't work with forked repos, eh?
Ushbot
@ushbot
Apr 24 2015 04:15
[Evan Sims] Hm, doesn't appear that's the problem. Made a fresh local clone repo, branched it, copied my changes into it, committed. arc diff still doesn't do anything. scratches head
Ushbot
@ushbot
Apr 24 2015 04:40
[Evan Sims] Hurray. Switching php to 5.6 for some reason fixed it. Magic.
Ushbot
@ushbot
Apr 24 2015 12:10
[Vladimir Cvetić (Ushahidi)] trying to figure out filter field in sets table
[Vladimir Cvetić (Ushahidi)] anyone has json structure for it, I'm missing it in all db exports i have
Ushbot
@ushbot
Apr 24 2015 20:14
[Robbie Mackay (Ushahidi)] @EvanSimsGuest thats weird. arc definitely works better without a fork.
[Robbie Mackay (Ushahidi)] Didn't think 5.6 was required though
[Robbie Mackay (Ushahidi)] it does get confused with different git upstreams.
[Robbie Mackay (Ushahidi)] it tries to guess the base from the upstream... so if you've pushed to github then it might get confused
[Robbie Mackay (Ushahidi)] it expects upstream to be 'origin/master' or 'master' but instead it'll be your remote branch
[Robbie Mackay (Ushahidi)] @vladimir we haven't really done anything with the filter fields in sets yet.. I think it should just match the params you can pass to the posts api.
[Robbie Mackay (Ushahidi)] ie you can do posts?q=test&tags=1,2,3 would become { "q":"test", "tags":[1,2,3] }
[Robbie Mackay (Ushahidi)] or something like that..
[Brian Herbert (Ushahidi)] Heya @EvanSimsGuest! Good to see you around ;) (peelbanana)
[Evan Sims] Yeah, no worries. I'm sure it's just something wonky with my local environment's 5.5 config. Hot swapping to 5.6 was just an easy fix, haha.
[Evan Sims] Hey @BrianHerbert! :)
Ushbot
@ushbot
Apr 24 2015 22:58
[Evan Sims] So, I'm trying to get my local V3 fresh install up and running; any ideas on what would be causing "Validation Error: 'tag.role.exists'" error when I try to make a new category? I get a similar error for 'user.role.exists' when trying to add a user. I noticed there's a 'roles' table in the database, but it's empty. Is there a step the bin/update migration stuff may have missed, or do I need to do something manually?